E foundation says: degoogle your life

privacy

#1

What about yourself?


#2

That is weird when I go to the same page I see a slightly different view. Not able to see the gstatic…


#3

that’s the same
domain


#4

@moose @Superman Try to open the e.fondation page in firefox container or temporary container. The gstatic comes perhaps from your surf history. On my side I don’t have the same thing as what you have, I use uBlock origin, uBo scope uMatrix and noScript and no trace of google trackers.

No Script :

uBlock Origin:

uBo-Scope:
fondation

uMatrix:


#5

Just tried NoScript in Firefox after closing the browser first (and auto-delete all history):


Gstatic indeed, but according to Ghostery no trackers:


#6

Gstatic is present also for me (after clearing cache, history and restarting my browser)


#7

Even the cache is cleared or browser restarted but it remains the browser and extensions connections.
To test a given site, it is recommended to open it in a completely isolated tab using extensions such as “Multi-Account containers” and “temporary containers”. Personally I combine the two extensions to have a total isolation at each new tab. And to avoid to login to the same site every time with the same identifiers I set “Multi-Account containers” to open the site always in the same container.

I set up the 1st extension to open all google insatances in the same container, so I don’t log out during the same session and these same instances are completely isolated from the rest of my internet activity.

PS: I apologize because this is not the subject of this post but it still has a relationship regarding privacy on the Internet and google trackers.


#8

gstatic in temporary container too:


#9

Ok.
Sincerely I don’t know why you get gstatic on the e.foundation site but I tested the site on several browsers (Firefox with no extensions profile, safari, Chrome) and in any case I don’t have gstatic.
I can’t explain it.


#10

This is a known issue since October: https://gitlab.e.foundation/e/management/issues/99

The reasons for the problem are known and were already discussed, but difficult to solve permanently.


#11

Shame, right. We clearly have troubles removing everything from gstatic on our website, since it needs to be done at each Wordpress update. Suggestions welcome.


#12

Can you please point us to the code-repository of the package that makes these problems?


#13

It’s the wordpress codebase you know, as far as I remember there are several places with calls to some google fonts and/or js libs…
I think probably the most efficient way would be to put some pressure on the core wordpress developers that they do not include these, or at least add an easy way to disable it.


#14

Effectively, this is a known issue related to a dirty javascript code of the Wordpress tree. This js calls for fonts, even if these fonts are not required. I’ve seen some turn around, but didn’t succeed yet to kill this call.
There are also plugins for this purpose, but failed so far.
I’ll make my best to resolve this point on the new website being under development so far, and I’ll make sure to ring your expertises to resolve this if required.


#15

Or you use Grav instead :wink:


#16

Solving this issue upstream would be ideal as it would make thousands of other websites more privacy friendly too.


#17

Thank you for providing the link to the upstream bugtracker and discussion. Added it to the gitlab bugreport.