/e/ install to root or not to root

support
samsung-galaxy

#1

Hey everyone,

I just have a quick question about the install. Does the mobile device have to be rooted to install /e/? Also, will the repositories feature notifications for updates on applications? Thanks!


#2

Hi @Joe1 No the device does not have to be rooted to install /e/ Follow the process as described for your phone here.
Updates for applications come as part of the build. Separate notifications for individual app updates do not come in /e/.


#3

Ok great and thank you! We do have all instructions but I wanted to make sure I did not have to root the phone as I have done in times past. I spoke to Gael a couple of months ago. We are going to order some new phones and try it out. We will support from this point. Thanks.


#4

Fdroid(open source apps) offers update notifications, and with Yalp(play store apps) its easy to check and update all if needs be.


#5

Thanks for the information. I really am looking forward to the “experience.”


#7

Thank you, great news. I will install shortly. Just one quick question, kind of unclear, does custom recovery TWRP image have to be used or is this optional???


#8

Have a TWRP recovery on you phone is good in case of any issues later on. On my tissot as well as in the instructions for this device I flash TWRP recovery temporarily with
fastboot boot twrp-x.x.x-x-tissot.img
Once the flashing is complete and in case I try to go back to the recovery it takes me to the lineage recovery and not TWRP. It gets overwritten with the above command.
You can flash the TWRP recovery after each successful installation if you want to. Just to be on the safe side.


#9

Great and thank you. Phone should be here by Tuesday. I will install that night if I do not have to work. Will post back results. Thanks.


#10

Ok, so I tried to use heimdall. Failed right out of the gate to this error:
libusb: error [op_set_interface] setintf failed error -1 errno 71.

Trying to figure it out. This was on a Samsung S9


#11

Hi @rhunault please can you help with an issue on samsung S9 phone


#12

Hi,

@Joe1 Which heimdall version do you have? (Use heimdall info to know).


#14

Ok, so I tried a new heimdall version 1.4.1, and now it fails to initialize, ending with a handshake failure. Error -7. I want to note that I tried all USB ports on my PC. Tried another PC with same version of heimdall (older PC) and got the same results. Thanks for your help.


#15

Hi @Joe1, if you have a Samsung device and Windows somewhere, don’t bother with all that complicated stuff :slight_smile:


#17

I do have a WIndows 10 on this PC, dual boot. Last time I rooted a Samsung S3, I had to do it with Windows. I would prefer NOT to use Windows. It looks like I might have to do though. Thank you for this tutorial.


#18

Failed with ODIN on Windows as well. I am beginning to think it is the phone. The model is a Samsung S9 (not an s9+). I don’t know where to go with this thing.


#19

No luck with ODIN either on Windows 10. Failed to install TWRP using Windows 10. I am beginning to think it is something with the Samsung S9. Two different computers, two different OS’s, two different methods (heimdall 1.4.1 and ODIN).


#20

Heimdall v1.4.1 is not the last version (v1.4.2). Unfortunately, you have to build last version manually. Ubuntu instructions are at the bottom of this page.