/e/ on Samsung Galaxy A3 (2016 Exynos) SM-A310F “a3xeltexx”

The SM-A310F came with the last StockROM Android 7.0 July 2018 update with working FM radio including RDS function.


The operating system change to the current /e/ OS ROM e-o.7-o- was done without mistakes. The only thing I noticed is that the link to TWRP on the website /e/ documentation Install /e/ on a Samsung Galaxy A3 (2016 Exynos) - “a3xeltexx”

Installing a custom recovery

  1. Download a custom recovery - you can download TWRP.

leads to this failure message:

Not Found
Page not found.
Try the devices page to look for another device.

TWRP for Samsung Galaxy A3 2016 (Exynos) Code Name: a3xelte ist verfügbar mit der Version wrp-3.3.0-0-a3xelte vom 2019-04-09 18:10:37 EDT.

But - in the first operation the long known bug appeared → “When I connect to my WLAN at home first time, the phone restarted endlessly, till I shut down wlan on the router.” Read more …

Neither a hardware nor software bug is the missing feature FM Radio RDS, which is known in several Samsung devices of the A-system family.

“The build script for all devices is the same so there is no reason the FM radio should be missing on a particular device.” Read more …

An explanation from @rhunault that I can understand: “Probably a value missing in the device config.”

I hope and wish that the /e/OS Build Team will integrate the FM Radio feature into the build until the relaunch of /e/ OS release v1. My request in this regard will be added to gitlab.e.foundation.


@Manoj’s test build /e/ OS ROM e-0.7-p-2020020439971-test-a3xelte.zip runs smoothly and without the just mentioned “WLAN bootlopp”. The feature anaolges FM Radio with RDS is unfortunately not (yet) integrated.


“Hello, we should soon be able to migrate from Oreo to Pie. That should probably solve the problem”.
Free translation by @archje

The “a3xeltex” has received four updates in the last four weeks. From the start, the Oero 8.1.0 build e-0.7-o-2020030443780-dev-a3xeltexx runs smoothly.

But as soon as the WLAN is switched on, the /e/ phone still enters a non-ending boot loop. Even a “Facory reset” did not have a positive effect. So the bug is not fixed yet.


The MuPDF reader has been replaced by Pdf Viewer Plus.

Unfortunately, FM Radio hasn’t yet found a place in the standard pre-installed apps.

Conclusion: unsatisfactory. Only the /e/ Build Team knows why this is so …

The FM Radio will be integrated if possible on the Official Pie builds for the a3xeltexx once we release it…hopefully in a months time.

The slim aluminum frame and the slim case (134.5 x 65.2 mm) with Gorilla Glass 4 on the front and back create a high-quality feel, making the only 7.3 mm thin and 132 g light “a3xeltexx” look noble as a 4.7-inch phone. The finish and transitions are clean and filigree. The SM-A310F “looks forward” to a working /e/ OS 9 pie.

Oero 8.1.0 on “a3xeltexx” works with pure LineageOS 15.1

I’ve now tried the last build of LOS 15.1 :: lineage-15.1-20190709-UNOFFICIAL-signed-a3xelte.zip

[UNOFFICIAL][a3xelte][SM-A310F]Lineage OS 15.1 for A3 2016


There is no bootloop when WLAN is switched on!

Good news: The “a3xeltexx” is on way to the official /e/ OS 9-Pie version.

cool!!! s’il faut tester, ok pour moi!!!
Samsung Galaxy A3 2016 (Exynos) - a3xeltexx -> Pie

The Samsung Galaxy A3 (2016 Exynos) - “a3xelte(xx)” (Models: SM-A310F, SM-A310M, SM-A310Y and SM-A310N0) was newly added to the LineageOS 16.0 portfolio. Since March 2020 the first “Nightly” builds are available. Come on /e/ …

Intéressant !!! A défaut d’avoir /e/ je vais installer et tester ça …
merci :stuck_out_tongue_winking_eye:

Update e-0.9-o-2020043052057-dev-a3xeltexx

From the start, the Oero 8.1.0 build e-0.9-o-2020043052057-dev-a3xeltexx runs smoothly.

2020043052057-dev-a3xeltexx 2020043052057-dev_a3xeltexx
For the a3xeltexx everything remains as is.

hi @archje, So there is no Boot-loop anymore with Wifi switched on?

Hej @weichselbaumj, unfortunately, the listed issues are still not fixed. The FM radio is not implemented; still non-ending boot loop after switching on WLAN.

1 Like

ok, thanks. then we need to wait for the pie upgrade.

LineageOS-for-MicroG build lineage-16.0-20200514-microG-a3xelte runs like clockwork With additionally installed /e/ Apps Store /e/ Browser /e/ BlissLauncher /e/ Wallpaper /e/ OS feeling comes up. And even individualized private DNS provider hostname - it’s not /e/.

@archje is it possible to install the /e/ app store on a non-/e/ phone? I thought that was problematic?

i’m running this test build and it runs like a breeze

Well @Rik," this test build" is a /e/ OS ROM.That /e/ Apps Store “runs like a breeze” there is to be expected, right?!

The joke of the matter is that the /e/ components I mentioned work on a LineageOS 16.0 for microG ROM.This allows me to use the “a3xelte” with /e/ OS Feeking including Android security patch level May 5, 2020.

Below is the /e/ Apps Store in action on a LineageOS-16.0-for-microG ROM (in 13 pictures)

1 Like

cool! well that means that the devs have been able to separate the /e/ app store from the /e/ rom - that’s actually a big accomplishment!! (they used to be integrated)
It’s a really big plus to /e/ - now this app store can be put on Fdroid, for example, so that non-/e/ Android users can also enjoy the benefits of the /e/ app store
Would be good promo for /e/

1 Like

The e.foundation Apps Store works for me also under GrapheneOS (Android 10) and LineageOS 17.1 (Android 10) and Android 11 {R} Developer Preview 4.

1 Like

hee @archje, can you tell us where you downloaded the /e/ Apps Store, browser and launcher?