/e/ on Samsung Galaxy S8 can't reboot into TWRP

I’m remotely assisting a friend who wants to install /e/ on her S8 (SM-G950F with Android 9). She’s using the easy installer.
The installer seems to be working fine until step 3 (see screenshot).

Here, when following the specific key presses we don’t end up rebooting into TWRP. After the first step, the charging icon ends up showing, and then we boot into the default recovery (Use volume up/down and power., Reboot system now, Reboot to bootloader, Apply update drom ADB, Apply update from SD card…)

Is there a step we’re doing wrong/missing ?
Thanks for your help !

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi, @Manoj

It’s typical with Samsung Devices !

Hi @ohemelaar

please retry from the beginning with the easy installer,
and at this step, try to use only
“volume down” and “power” : to turn off the phone first

Then reboot to recovery with “bixby” and “volume up” and “power”.

Thanks for your quick reply, we’ll try that again tomorrow and I’ll keep you posted.

Hi @piero I do not have a Samsung device to test this… Pl can you let me know what should the sequence of steps be like.
The developer had tested the Easy-Installer extensively on Samsung devices so if there is an extra instruction that needs to be added to the screens let me know and I can communicate it accordingly.

I suppose that devs are used to use the adb reboot recovery command

Experienced this also. After the first step (get out of download mode) you directly have yo move your fingers for the next step. If you are too late, the device reboots and removes the flashed twrp again.

1 Like

Yes, re-do the installation and once you are at this step again, as soon as the screen turns off move your finger from Volume down to Volume up to boot into TWRP. If you boot into the system, TWRP will be replaced by the default recovery and you will have to re-do the installation.

1 Like

To boot in TWRP the key combination is Volume UP + Power + Bixby

Yes, it’s a matter of finding the proper timing. I’ve experienced this on two different Samsung’s (not much forgiving phones as about timing) and on a Motorola, a much forgiving one

Hi @ohemelaar !
What is happen with your friend’s installation ?

Hi @piero, thanks for checking.

Unfortunately we’ve been pretty busy these last days so we didn’t have the time to try again yet. Maybe this week-end, I’ll keep you updated.

1 Like


I am facing the same issue, I try to follow the advice of @piero but i am still stuck on the Android Recovery boot mode.
I join a photo of the error messages at the end of the Android recovery screen.

Thanks for your help !

Hi @thomasp,
Welcome to this forum,

This is the Samsung Recovery, it looks like it failed to replace it by TWRP,

What is the model of your device ?
I am afraid it is a special model witch is not compatible,
( it is manufactured specially for an US carrier )
even the SM-G950U is not supported by the codename because of his snapdragon chipset.
Only global/international exynos models are compatible with /e/
please read this :

Hello everyone,
I’m sorry for forgetting to keep you updated, but better late than never. In the end my friend tried again and it worked. Apparently being quick enough and keeping the buttons pressed through the reboots and battery screens seems to work.
Thanks again for all your replies!

I experienced the very same behaviour either on the S8 and on a i9300. The key is the proper timing in pressing the buttons

Hi @piero,

I double checked my phone, it is a supported model, Samsung Galaxy S8 SM-950F (dreamltexx), the EU version with Exynos8895.
Concerning pressing the buttons, I follow the advices, pressing Power & bixby & volume down et immediately up when the device turns off. In this way, the phone turns on immediately without passing by the charging phase. But this has no effect on the issue.


Hold ´volume down’ and ´power’ only to shut down

Hold ´home´, ´volume up’ and ´power’ to reboot recovery
Release when you see the little blue line at bottom of the screen…

Hello everyone,

I’m new to /e/. Just bought a S8 (SM-G950F) to install /e/ on it but I am having the same issue.

I tried with both the easy installer or in command line with heimdall numerous time but it seems I can’t boot on TWRP. The devices reboot in the Samsung recovery no matter how fast I switch the keys combination.
I looked online a find a way of forcing Samsung’s devices to boot in TWRP by removing the battery, but of course, it’s not possible with the S8…
Is there any other way I can boot in TWRP ?