e/OS 1.1 refused to read SD card that worked fine since e/OS 0.18

Have a FP3+ and upgraded to e/OS 1.1 last week.
At a reboot today the OS refused to read a 64GB SD card with MBR Partitioning and format with exFAT.
Rebooted the phone several times with the same result, that the e/OS identified a problem and recommended to format the SD card.
No problem for my linux machine to read the SD card.
making a backup of the content right now on the laptop.
Anyone more that have had the same problem?
My problem is now how to restore the backup on the formated SD card

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Welcome to the community.

I hope others might contribute better advice, but for the time being …
I can remember that more than once when I first inserted an SD card into a smartphone, the card was actually shown as “defect” and it would suggest to format it, giving me the choice between extended internal storage or portable storage. Now given I only ever used SD cards as portable storage (just like you, as you wrote that the card works in another device out of the box), this eventually turned out to be just a kind of setting up, not an actual erase + format procedure. Data already on the card was still there.

Being aware that a while ago, /e/OS dropped the extended internal storage option, there should not be a choice available in /e/OS now. The prompt to format might be a leftover from when both options were still available.

I know it’s a risk, but you might still keep the data on the card when you choose format. If you want to take the risk is up to you, of course, but it’s good to read you already backed up the card elsewhere.

1 Like

I think you have done a significant Android version upgrade as well as /e/ upgrade?

I believe /e/ version 0.18 is where SD card “internal storage” capabilities changed.

So you may be in a singular position in your options.

I suggest you beware of formatting the card before sorting out a back up solution!

An USB OTG drive might help to reinforce your back up.

Hi, have upgraded for every version(0.18=>0.19=>0.20 …and so on…=>0.23=>1.0=>1.1).
SD card installed in e/OS 0.18
And there was no problem to read content and information on the card in any e/OS before ver 1.1!
There is no problem to read the SD card with TWRP (which i Boot from fastboot), so there is no mechanical problem in the phone.
I could also se that the SD card is there in normal mode ( e/OS with debug activated and “adb shell”)
ls with adb shell in e/OS active gives the following
ls: /storage/7CE3-C43C: Permission denied ( “7CE3-C43C” is the ID of the SD card, same as in Linux!)
I guess that “ls: /storage/7CE3-C43C: Permission denied” is related to that e/OS no longer could read the sdcard? But as said above is no problem for Linus or TWRP to read the card
Any suggestions?
AND also notice my comment above. When I update to ver 1.1, 12 of July, there was no problem with the SD card, but today when the phone rebooted due to a bug in a app, the problem arise. So it is not impossible that the buggy app did something. Also notice that the phone not are rooted.

I pleased to hear that it is not the issue which I had feared.

If you backed up all the files on the card to the computer, then why not let Android be happy and format the card, and then either see whether @urs_lesse’s hint applies and the data might still be there, or otherwise just copy the files back via connection with the computer?

1 Like

Have formatted the sd card now
And the big difference is that the type of file system changed
Old type that e/OS did not accept any more was #07, “HPFS/NTFS/exFAT” to new type #0c “W95 FAT32 (LBA)” ( copy from fdisk -l in Linux)
Is not the type #07, “HPFS/NTFS/exFAT” supported by e/OS anymore?
NOT above problem!!!
Because when i copy back my files from the laptop to the SD card ( with removing the card) the SAME problem occur!!
So there is some issue related to how e/OS manage SD cards!!
It is now IMPOSSIBLE to remove the SD card and copy files external (on my lap) to the card, because after this type of action the e/OS will not longer recognize the card!.
I assume the in the system crash that initiate all may problem some app made an writing to the SD card similar or from e/OS perspective counted as external writing. If I copy files over USB file sharing it seems to work correctly!

So please
Could someone please test with a 64BG SD card and make file writing external ( I have Ubuntu 20.04)?
Do the same problem occur or is it only my copy of e/OS that is weird?
( I tried a 128MB SD card and this SD card was possible to copy files to external, why not the 64GB SD card is working like that is a mystery for me!)
There is some bug/issue here but I do thing we need someone else having the same problem before we could figure out what the problem is!