/e/OS apps on diferent non-/e/OS ROM

Hey there!

I failed to find any place to get default /e/OS apks for non-/e/OS devices like Calendar, Contacts, Mail, Notes and backup manager to also have my photos backed up.
My new workphone is unsupported by /e/OS and I need it to have GPay anyways, but having these two synced could be nice.
Is that even possible?

Thanks, guys!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

/e/ Apps as apks are at e / os / android_prebuilts_prebuiltapks_lfs · GitLab … but you’ll need to self sign to install them - it makes more sense to install their non-fork from the F-Droid Appstore.

For your question you’ll need… Davx5, Etar, k9mail and Nextcloud-Notes. Then there’s Nextcloud-Client for the photo sync. Another user recommended “FolderSync” as commercial webdav App that seemed pretty well made.

I once catalogued all upstream App-Ids for fun at /e/ upstream default Apps re-installed.. why? bc! … but there are a lot of other good substitutes too


Thank you very much for saving one noob few evenings of his life!

I found e-mail client settings here and server name for nextcloud is just murena.io - using ecloud.global gave me invalid token for some reason. Also permissions for DAVx5 have to be set manually.

Only thing I didn’t get to work is nextcloud Notes, but I guess I can use something else with my /e/ nextcloud acc.

NextCloud Notes needs the NextCloud Sync client app. Add your murena.io account in the sync app, then select that account in the Noted app

1 Like

Yes, that’s it’s dependency. Error occurs when I select my account in Notes app, NextCloud sync work fine by itself. Tried to clear cache, re-install, but nothing seemed to work so far.

What error do you see?

Error says:

and there’s something more to it:

App Version: 3.7.1
App Version Code: 3007001
App Flavor: fdroid

Files App Version Code: 30240190
OS Version: 4.14.186-gd5b54dace-dirty(root.20220810.192554)
OS API Level: 30
Device: Titan_Slim
Manufacturer: Unihertz
Model (and Product): Titan Slim (Titan_Slim_EEA)
com.nextcloud.android.sso.exceptions.NextcloudApiNotRespondingException: Nextcloud Files app API is not responding. This is most likely due to battery optimizations on your phone. Try to disable the battery optimization for both apps (Nextcloud Android and this app). In all other cases please try to clear the storage of both apps.
at com.nextcloud.android.sso.api.AidlNetworkRequest.waitForApi(AidlNetworkRequest.java:162)
at com.nextcloud.android.sso.api.AidlNetworkRequest.performAidlNetworkRequestV2(AidlNetworkRequest.java:298)
at com.nextcloud.android.sso.api.AidlNetworkRequest.performNetworkRequestV2(AidlNetworkRequest.java:180)
at com.nextcloud.android.sso.api.NextcloudAPI.performNetworkRequestV2(NextcloudAPI.java:199)
at com.nextcloud.android.sso.api.NextcloudAPI.lambda$performRequestObservableV2$1$com-nextcloud-android-sso-api-NextcloudAPI(NextcloudAPI.java:129)
at com.nextcloud.android.sso.api.NextcloudAPI$$ExternalSyntheticLambda0.subscribe(Unknown Source:6)
at io.reactivex.internal.operators.observable.ObservableFromPublisher.subscribeActual(ObservableFromPublisher.java:31)
at io.reactivex.Observable.subscribe(Observable.java:12284)
at io.reactivex.internal.operators.observable.ObservableSingleMaybe.subscribeActual(ObservableSingleMaybe.java:31)
at io.reactivex.Maybe.subscribe(Maybe.java:4290)
at io.reactivex.Maybe.blockingGet(Maybe.java:2320)
at io.reactivex.Observable.blockingSingle(Observable.java:5381)
at it.niedermann.owncloud.notes.persistence.CapabilitiesClient.getCapabilities(CapabilitiesClient.java:32)
at it.niedermann.owncloud.notes.importaccount.ImportAccountActivity.lambda$onActivityResult$5$it-niedermann-owncloud-notes-importaccount-ImportAccountActivity(ImportAccountActivity.java:97)
at it.niedermann.owncloud.notes.importaccount.ImportAccountActivity$$ExternalSyntheticLambda2.run(Unknown Source:4)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:462)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1167)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:641)
at java.lang.Thread.run(Thread.java:923)

I tried google store version as well, still same.

Have you tried clearing the storage for both apps s suggested by the error messages? (You will have to setup the account again in the sync app)

Yes, first thing I tried. I can live with webapp for now I guess. This looks like something more complex… Too lazy to dig deeper :slight_smile: