/e/OS GSI on Galaxy Tab A7 (2020) SM-T500 / T505

:warning: Warning: Samsung has provided the Stock Android 12, October 2022 update with Roll Back Protection, which means that once installed, it is no longer possible to downgrade to earlier versions. Until now, it was possible to downgrade to Stock Android 11 and even Stock Android 10.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

The SM-T500 (gta4lwifi), SM-T505 (gta4llte) are generally currently running stock Android 12. While I’ve been able to successfully install and use GSI’s based on AOSP 11 and 12 from other developers, I want a /e/OS GSI.

So I first installed a stock Android 10, then /e/OS-Q V.1.4 GSI. The /e/OS GSI boots properly and can be set up in stages, which means - the initial setup cannot be done as usual, because the Tab SM-T500 reboots automatically after about 60 seconds. This means that only a step-by-step configuration is possible. Even when the initial set-up is complete, the Tab reboots continuously every minute or so. So it is not really usable.

Does anyone have an idea how I could solve the problem?

I imagine that you already have tested to apply a factory resest, then also a format of /data partition …

@piero, that is not new to me! I did that as a matter of course. Since I record every step of the installation procedure in writing, I can see exactly if, what and when I did it. Nevertheless, thank you for your time

Ok, even after installation !

@piero, if only it were that simple. Knowing from your posts which Samsung devices you use, I assume that you have not yet installed GSI on a Samsung Galaxy device with Super Partition (Dynamic Partition), AB slots, and no fastboot’d’ mode support. With a standard installation, no progress can be made. Since the error-free installation of AOSP GSI 11 + 12.1 worked for me, the reason for the reboot after one minute of /e/OS-Q GSI must have other causes.

You are right,

even if i am curious, i have no excedent money to spend on a recent and unsupported device to experiment.
One day i hope to buy an FP3 or a s10e… one day…in a few years… when they will cost less than 80€

About GSI, you could ask in “LeOS telegram support channel
As they are focused on GSI : search about LeOS

LeOS-R-VNDKLITE-arm64-bvS runs right away. But I can’t really make friends with these GSI.


Well, I know that guide. It may be that the GSI installation worked for him. It’s just like so often with instructions from the WWW - they don’t work with my devices.

That’s what the above guide says:

i) run these commands in order
fastboot erase system

If I run this command on my SM-T500 with Android 10-Q firmware:

fastboot erase system
Erasing 'system' FAILED (remote: 'Partition doesn't exist')
fastboot: error: Command failed

Quintessence: Only the result on its own device counts. The rest is grey theory.

For another test,
I completely rebuilt the system with Stock Android 10-Q, then a LOS 17.1 GSI by @andyyan.

Conclusion: LOS 17.1 GSI works perfectly - without ever rebooting automatically. /e/OS-Q V1.4 continues to reboot after about a minute, repeatedly.

1 Like