/e/OS Installation: Signature verification failed

i am tryring to install /e/ on a Lenovo yoga tab 3 plus.

The install process stop with the error

E: failed to verify whole-file signature
Update package verification took 78.4 s (result 1)
E: Signature verification failed
E: error: 21

i tried multiple build from https://images.ecloud.global/dev/YTX703F/
(2.0 , 1.21 ) but the error is still the same.

I bought this specific tablet only to use it with /e/
any clue ?

thanks a lot


Same device here, upgraded to /e/OS 2.0 using OTA:

What method & recovery are you using?
Also, did you manually verify the checksums for the build images?

Hello, so nice to have reply !
Unfortunately i can’t use OTA at the time : the device is brand new and still on stock google crap.
My problem is i didn’t manage to install TWRP correctly i tried many times but this never worked i probably did it wrong way, and i always fall back to the recovery mode already installed (wich seem to be the stock android recovery ?)
i tried to make the install of /e/ using this recovery, but i get the error mentioned in my first post.

Did you try to install /e/ Recovery?

Yes problem was the same.
I had to read again this morning the TWRP tutorial

i will try again tonight, i probably made a mistake at the end i didn’t hold the key to reboot
" many devices will replace your custom recovery automatically during first boot. To prevent this, use the proper key combo to enter recovery. After typing fastboot reboot, hold the key combo and boot to TWRP. Once TWRP is booted, TWRP will patch the stock ROM to prevent the stock ROM from replacing TWRP. If you don’t follow this step, you will have to repeat the install. "

1 Like

Yes, this is a common mistake when installing TWRP.
Finger crossed! :crossed_fingers:

Hello again,
I managed to install TWRP but new problem :
the e-os install doesn’t run well i got “No OS installed are you sure you want to reboot” :sob:

I don’t know what i should do …

This has also appeared to me sometimes with /e/OS recovery and lineageOS.
If your phone has a microsd, save the rom on it.
Restart the mobile in recovery mode, indicate flash rom from the device, navigate to it and flash. Ignore the error code and say yes. It will install and then reboot.

@pealfa holy dude thank you ! you saved my evening this was the right idea !
(and thanks to @smu44 who also helped me you guys rules :+1:)

1 Like

this is an expected successfull message