/e/OS on a Galaxy s4 Active

Suite du sujet eOS on the Galaxy S4 :


I have recently bought a “second” (probably multi) hands (new for me) Samsung Galaxy s4 Active.

I fall into complications, but i like it

It was an english only interface (why i get it for 20€+4€port)
I discover it was a rooted system, and decided to flash on it a clean french firmware, TWRP 3.3.1-0, and a fresh official e-1.4- dev

I cannot find the navigation bar in settings ! ?
Also i have no sound when trying to aswer to a incoming call !
and Camera says it is occupied.

I first thought it is because my installed XEF firmware (I9295_XX_S_DQD2)
is more recent than the one /e/OS is based on and don’t have the same bootloader version
(I9295_XX_U_DPF1) …
So i tried to downgrade to another XEF firmware…older than the two others, with the same bootloader version than /e/

Same problem with Camera ! (don’t have a look to others issues).

Looking around firmware’s versions, i remember that samfw.com offer IMEI check and found that the device was initially shipped with an “ILO” csc (israelian)
latest firmware for ILO has the same version number than the base of /e/ for this device
According to most of the Samsung firmware download sites it is supposed to be android 6 but when installed : it is finally android 5

e-1.4-dev flashed on it.

Problem with Camera was solved by openning the galery from the link at the bottom right in Camera screen ! :blush:
Navigation bar always cannot be founded,
Same problem, no sound on my side when trying to answer incoming call, saw noise on the other side…

i think it is a device specific issue