/e/OS on Samsung Galaxy J5 2017

The hardware specification for the test rom does not matter. You are not supposed to install the build, just finish it.

It should be just any oreo build. Nothing more. The finished build will be destroyed and not installed.

Regarding jack
you can try this

export JACK_SERVER_VM_ARGUMENTS="-Dfile.encoding=UTF-8 -XX:+TieredCompilation -Xmx1024m"
with different values at the end

I won’t install the build don’t worry. I just want to know if my build env is okay, that’s it - and for this exercise a5y17lte is the easiest as it does not require any custom roomservice file.

Forget this. You are building with docker, where this command is included.

And you never need a roomservice for an supported device! !

The fact is that no J5 does appear in lineage 15.1 tree. I checked yesterday, and even the officially supported devices from /e/ are not there.

Anyway my build failed this time there :

Any clue ? The build process is rather random - last attempt I was greeted with a compiler segfault and without changing anything now I got this. (And prior I got the jackd errors) I know my mobo and my RAM are not faultly.

It looks like a signature related issue according to a quick search.

I know, and no I did not sign my build - I’m just using Docker and it fails at this stage. Is there a specific location for sign keys ?

you are building for a5y17lte ??

Have I missed something ?? Is your test build finished successful ?? I haven’t seen any message, that you test build was finishing successful

How have you solved the Jack issue? ?

I am building for a5y17lte to check if my build setup is correct. Then I will try again for j5y17lte using all your customizations.

For the jack issue, it solved by itself which is rather strange. No change, nothing. Just restarted my user session (with KDE).

Ups, sorry, need glasses :frowning:
As one off my trainees often tells: who can read is on the better side

Regarding Jack, seems your jack server wasn’t started.

Yes I’m trying something to find the culprit (the error popped up again). If this is what I suppose I tell you it.

EDIT : My guess proved to be right. If I play some music or some sound the soundcard gets busy and then jackd fails to start in Docker (which is rather weird).

Solution is to run the following command prior to building or each time you hear a sound :

pulseaudio -k

A nice fix would be to use /dev/null as the sound card to fix this issue and make builds more reliable.

In term of memory usage the build topped at 8 GB RAM used.

BTW this time I could build successfully everything (no signature issue - dunno while it failed before, maybe the soundcard issue again). So now do you think I can try with j5y17lte ?

Trying again with j5y17lte

If I use repo Exynos7870 (just a sed in the original roomservice.xml file) I get this :

ninja: error: 'kernel/samsung/exynos7870/arch/arm64/configs/j5y17lte_01_defconfig', needed by '/srv/src/OREO/out/target/product/j5y17lte/obj/KERNEL_OBJ/.config', missing and no known rule to make it

If I use repo SamsungGalaxyJ5-2017 it won’t find product lineage_j5y17lte. Trying again (but few hope) with repo nailyk-fr, and I will attempt as well with other forks of repo Exynos7870.

What is with your test build? !?!?!

I could build image a5y17lte. Now I’m trying to build j5y17lte with roomservice.xml files, and playing with different forks of repo Exynos7870 (fork from naylik-fr does not work).

I try to tweak the roomservice.xml file very progressively and will let you know.

how do you have solved the issue with the missing sign.apk ? Such things are interesting for others

Nothing special. The first time it did not work, the second time it did work. Weird.

I really can’t beleave that all our issues are solving by his own. Lucky man !

Not all. For jackd it’s a soundcard issue (which is very weird and very unsafe in term of build process - it would be safer to find out a way to redirect soundcard to /dev/null for jackd). For the certificate I dunno but it does not reassure me. Now I’m checking for Wireguard : there’s a script named fetch-latest-wireguard.sh which relies on a variable named BASH_REMATCH. I’m trying to find out where its value is defined.

In los17 sources, the wireguard stuff is available. You can clone the /net/wireguard folder manually in your sources.
But I fear, docker will remove it

That’s why I hate docker. Totally unflexible