/e/ OS 'Q' alpha builds are coming!

Seems to boot and run well on a FP2.


It works well on one plus six.


Seems to boot (and work, didn’t do a lot of testing) fine on FP2 and it seems, that finally this bug is gone now: https://gitlab.e.foundation/e/backlog/-/issues/1510

eRecovery is working too.


Mail notifications are not happening at the moment. Others also mention this on pie builds here

Tried various settings in the app but no luck so far.

This looks like an issue with the latest builds across all OS versions and is being tracked here

1 Like

Pl check if the device is already mentioned in the requests for a device. If not create a new one and share details of the official LOS builds. If th LOS build is working well on your device pl do let us know. If there are a large number of users requesting the device we can add it to our list. for support /upgrade.
I have been using a SM G930U heroqlteue for the last couple of days as my daily driver. We had initially hoped to port this device until we realized it would not work with /e/ OS code. So now it is running stock Samsung ROM. It is a US model. 5’ screen , well built , easy to use with one hand…it is really a shame manufacturers are jumping on to larger screens.
Any way the /e/ idea is to support devices as long as it is possible. One issue would be the lack of vendor security patches. Hopefully we will be able to pull along some of these so-called old devices for some more time.

Just installed the alpha Q build on One plus 7 Pro (guacamole). It went through the installation fine, connected to the Internet using both wifi and mobile data. Calling works. And that is how much I’ve been testing so far.

1 Like

after finally repairing my FP2 I directly installed the alpha Q build on it. Looks like it is running well, eventhough I did not test a lot yet!

I’ve been using it on a FP2 for 8 days now and for me it’s running well, too.

I’m really looking forward to this!!! Once the OS and recovery is stable, I will pack up my PH1 with everything /e/!

It’s a pity that since my PH1 is my only trustworthy phone, I cannot risk breaking it by flashing the alpha build… My other phone is a Huawei shit, I can’t wait to throw it away!!

By the way, @Manoj, does current builds need some Chinese translations? Maybe I can help with that.

Thanks for offering to help with the translations. You can check the documentation site for details on how to help with the translations.

I’m new to /e/ and would like to install it on my new Fairphone 3+ device. As I understand /e/ OS will only be available after the Q release for this device. Therefore i would like help with the testing if this would help your efforts. Just PM me.


I’d like to try out the Q builds for the FP3 is possible, I have the new camera modules so will be able to test them out as well.

this Q-GSI are working on FP3 (tested by a german user)

Any chance of a build for the a3xelte and the YTX703L, @Manoj :slight_smile: ?

Short info: Manoj is out of office the next days.

I started to check my mails today…there is a huge backlog.
@Rik the YTX703L is being added to the official list most probably on monday. Things got a bit delayed this week. I just updated the documentation for this and 7 other devices. The updates with the builds should reflect on the servers most probably on this coming Monday. The a3xelte is there in our plans and will get the ‘official’ tag soon.


Last night I did a build for my Xioami my A1 (tissot), with the latest /e/ sources with Android Q. In previous occasions (a few days ago) it didn’t boot the smartphone after flashing correctly. But now it has worked fine.
Everything seems to work (at least what I’m trying), except the contacts application (com.android.contacts v1.7.31) that gives Forced Closure when trying to start it.
I’ve also noticed that when the screen is locked, when unlocked, the wallpaper image comes out smaller and tighter to the lower left corner (the rest of the screen is black) and immediately resizes to cover the whole screen.
To be an alpha version, it doesn’t work bad :+1:t3:


Pls keep in mind, the sources are still have the goolag captive login call. All others are removed, as far as I could see


For information: I have build a new Q-GSI with todays sources. All goolag calls are gone. Good job :+1::+1::+1: