/e/ OS 'Q' alpha builds are coming!

Please note the ‘Q’ builds have been updated in the table above…more devices are being added to the list. The zip files are tagged ‘dev’ which means testers will not need to manually flash the official builds when they come out later.


Ah, FP2 is on the list, I am impatient to try it on FP3 :slight_smile:

:grin: :grin:
Yessss! I was waiting to try this on my 6T, just saw this on the list now!!! Gotta backup everything then GO!
Think this made my day, THANK YOU TEAM


Any chance to get the public repos on gitlab updated to reflect the new builds? Specific fatal errors in the public repos make me think that they don’t reflect what got released…

Yes, that’s great. But on my FP2 it doesn’t boot. It’s trying to start but after some time booting it restarts to recovery.

Did you try a clean flash of the /e/ Q ROM on the FP2

So I’m quite relieved that it isn’t there for FP3 yet :grin:
I tend to install such pieces of software to my daily driver :grin:

Yes. I did a factory reset first and (just in case) tried to install it via adb sidelload and TWRP install function and it was always the same. The image might have been corrupted during download (I didn’t find a checksum the verify its integrity) but at least during install there was no error.

Well, it’s an alpha build so (better safe than sorrow) I created a full backup first… :wink:

Did a clean install (format data, wipe etc) eOS Q on Oneplus 3T but it failed.

All steps seemed to go ok through to the bouncing ball for a minute or so (is it only me by the way who sees the e logo with the bouncing ball as the back end of a dog with a bouncing poo? Might be too many failed installs on my other device! :sweat_smile:) but did not get as far as “my data is MY data” and rebooted into recovery (twrp).

I tried rebooting recovery again, then system, same result. So it’s powered off for now.

@Manoj, Is there a new recovery in this ROM?

@chrisrg @ff2u all : We have started a new build for all devices with updated vendor source code…that could be the reason these builds are failing
Will update the links to point to the new builds once they are available


Yes there should be a new recovery in the Q code


@manoj: are the build made from the public gitlab repos or some private internal ones? If the public ones then https://gitlab.e.foundation/e/os/releases/-/commit/b06e6d4175ddaa92bc91e45a4fd5c3132e03099a#note_51974 will cause all builds to stall on the boot screen (e with bouncing ball). If they’re made from private repos, when will you update the public ones?

First we want to get the builds working and then we will make them public.


Well, it’s sad that /e/ is not more transparent with the development! It also precludes testers from resolving the bugs…

If you noted the comments above we have the first set of builds failing. If the code was open to all there would have been a flood of user complaints. Transparency does not mean you share code which still has some issue with all. Once the code is stable we can share it with all users. There are enough post on this forum from users trying to build with code that works but they still face issues.


Hmm, I had the feeling all the messages are from users downloading the pre-built images, not users that fetched the source code and built it. The only two messages that mention compiling from source are mine and @LEPT’s, who evidently hit the same bug I initially did until I fixed it.
Also, if you noted my message above, I pointed out that relatively obscure bug in the public sources that causes exactly the kind of problem users are seeing. I guess I’ll see from the time-stamps in the git commits when that was fixed internally and can compare to when I flagged it…

Just tried on oneplus 6 from e 0.11 pie.

First I tried to “upgrade” by booting twrp and installing the image, it was stucked on booting animation.
Then tried to wide data, cache, system and clean install 0.11 Q, it installed, boot, and reboot on e-recovery. I can’t manage to install it. I tried wipe data cache system then installing with adb sideload from e-recovery, same result.

e-recovery gives : Can’t load Android system. Your date may be corrupt.

Should I try something else ?


We are running a new set of builds with updated vendor files. Will share those for all devices in a couple of hours.