/e/OS Q-Beta installieren/ flashen über LineageOS 17.1 (Android 10/Q): Besteht ein Risiko aufgrund von "Downgrading"?

Ich habe ein Sony Z5 Compact (“suzuran”), Modell E5823 erhalten. Auf dem Gerät ist LineageOS 17.1.0 installiert (Android 10). Ich konnte noch nicht genau herausfinden, woher diese Version stammt. Eine offizielle LOS-Version gibt es für das Z5c nur für 14.1. Es muss also ein inoffizielles Build sein, aber die genaue Quelle habe ich nicht recherchieren können (u.a. bei xda gesucht).
Jedenfalls plane ich, /e/OS drauf zu installieren, was ja eigentlich wenig Aufwand wäre, weil TRWP usw. schon drauf ist. Die offizielle aktuelle /e/-Version für das Gerät ist Android Q-Beta.

Beim Install-Guide für das Gerät steht jedoch folgende Warnung:
Warning: Downgrading Smartphones already on Android Q or LineageOS 17.x to Pie or other OS can cause instability or at worst brick some devices”
https://doc.e.foundation/devices/suzuran/install

Kann es da wirklich eine Downgrading-Problematik geben? Es ist ja Q drauf und das /e/-Build wäre Q-Beta. Wenn ein Risiko bestehen sollte, wie könnte man es minimieren?

Da steht doch “Downgrading Smartphones already on Android Q or LineageOS 17.x to Pie” … das passiert doch jetzt hier nicht, es bleibt doch bei Q.
Wo ist da jetzt das Downgrade-Risiko?

1 Like

@AnotherElk Genau, das dachte ich mir auch. Also steht die Warnung einfach bei jedem Install-Guide obendrüber, wie es scheint? Ich sehe auch gerade, dass es sogar bei den Guides steht, die sich auf die Installation von R-Builds beziehen. Ist ein bisschen verwirrend, aber gut: besser zu viel warnen als zu wenig…
Ich hatte bislang nur mit Installationen zu tun von niedrigeren Android-Stock-ROMs aus, also immer mit Upgrades.
Danke für die Bestärkung, dass kein Risiko besteht. Dann schaue ich nur noch mal, ob es noch relevante Issues zu dem Device gibt und dann kann’s losgehen!