/e/ Page says /e/ is ungoogled/degoogled, why is /e/ then connecting to google?

Hello,

yesterday i flashed /e/ on my Galaxy S10. Now im setting it up. Until now, i only add my contacts and didnt done anything else.

Then i found this on my Pi-hole:

On this Site: About - E - e Foundation - deGoogled unGoogled smartphone operating systems and online services - your data is your data there is nowhere written that /e/ makes connection to google. Indeed it says, that /e/ is degoogled/ungoogled and privacy safe etc etc…

Luckely, my Pi-hole is so configured, to block any Microsoft, Amazon, Alphabet, Google, Facebook, Whatsapp, Tiktok, Youtube, etc… Services wich exist on this Planet (over 30 million domains) so my phone couldnt reach google like you can see from the screenshot.

Maybe its microg? Because it isnt possible to disable “Cloud Messaging” and Google “SafetyNet”.

I changed it to a fakedomain, dont know if this helps.

(here would be a screenshot, but im only allowed to post one picture)

1 Like

It is possible to dissable microg completely, but it is perhaps only a GUI glitch because "Cloud Messaging” and Google “SafetyNet” depend on Google device registration.

And how? On your posted link there is no information how to dissable microg completly.

But anyway, if this behavior is wanted, than the e.foundation should change they websites and FAQs.

Because nearly on every page is written, that /e/ dont make any connection to google (and dont send any data to google, and dont depend on it), wich is in fact not true.

Not sure at all, but it could be the new /e/ apps-lounge store that connect directly to gogol store sever ? luke aurora does.
When the old /e/ apps-store used an intermediate server. (that was my preference for /e/ default users, but many users did lobying against that anonymous intermediate server)

Dont know. I dont use this app store. I need only F-droid. But first i wait for response/solution why /e/ is connecting to google and how to disable it, then i install F-droid.

1 Like

As an experimentation, i propose you to refuse LTE and WIFI access for this app and see your Pi-Hole report…

Done it now for both:

“App Lounge” seems not used any data. Only microg. So microg phones home to google?

Yes it is its fonction…

If you start App Lounge the first time there is a question how you want to access Google.

On my phone clients3.google.c o m is contacted when starting & using App Lounge, don’t use it ;- )

i never started App Lounge. Like you can see in my previous screenshot.

Edit:

@Manoj why are you hiding my Thread and Posts with the reason: “Your post was flagged as spam: the community feels it is an advertisement, something that is overly promotional in nature instead of being useful or relevant to the topic as expected.”

Thats clearly not spam. Its a fact wich anybody can check self!

Hi,
The system flags posts by new users which contain links. This automated process works in most cases, as we get a lot of spammers. At times, genuine user posts also get wrongly flagged. I have unhidden your post, and it should be visible now.

2 Likes

The Phone is since 2 days unused on the table (still stock, dont installed any app, dont used any app (only contacts)), and still tries to connect to google, now few more domains showed up:

And bcmls2.glpals.co_m is continiously blocked too. DNS Lookup from this domain:

Seems to be from Amazon. Why? The same for gllto.glpals.co_m.

Sadly, until now im disappointed from /e/. For that that /e/ says it is totaly privacy safe, and dont make any connection to other services, it already tried 79 times to connect to these services from google and amazon (log from pihole). :confused:

Coming back to this thought …

… as well as seeing this …

… Could you perhaps use the toggles pointed out in the GitLab issue, or uninstall the App Lounge (package name is foundation.e.apps) this way, and have a look whether this changes anything?

Like said, i never touched and started “app lounge”. Not single time.

As you can see in privious posts from me, i blocked like suggested microg and app lounge from internet too. But this didnt seem to help/be the issue.

Sure, i could remove with adb or root all these apps. “App Lounge”, MicroG, etc. But what happens if a update comes over ota? Get this all restored again? Or breaks the updateprocess? Or what happens?

But anyway, this all is only fighting against symptoms. The real issue is, that the devs/founder of /e/ makes statements about /e/ how it safes privacy etc and that /e/ dont make any connection to third party services, wich is in fact not true. its a big lie.

No, as you can see in the linked topic.

The App in question gets deactivated for the current user and isn’t available anymore. Which could then perhaps hint at the App in question being the source of the issue, if the troublesome connections would stop appearing.

Of course :roll_eyes:. If the App Lounge is causing this on your phone, it would be an acknowledged issue as you can see, which has to be fixed and naturally would better not have seen the light of day to start with.
But nothing can be discussed anymore without everything being a huge conspiracy and a total outrage. Just tiring.

supl should be A-GPS. This could get interesting, too.

4 Likes

This seems to be from microg too.

Could i remove it completly? So it is NOT possible to restore it again (by me or system or who ever). Dont found a option in the manual of adb until now.

Edit: “Removed” or to be right, deactivated anything i could find. “App Lounge”, microg (4 different apps), mozilla, magic earth, nominatim.

But everything is still on the phone. The only difference is, that the system say they deactivated.

Edit:

beyond1lte:/ $ pm uninstall --user 0 org.microg.nlp.backend.nominatim
Success
beyond1lte:/ $ pm uninstall --user 0 org.microg.nlp.backend.ichnaea
Success
beyond1lte:/ $ pm uninstall --user 0 com.google.android.gsf
Success
beyond1lte:/ $ pm uninstall --user 0 com.google.android.gms
Success
beyond1lte:/ $ pm uninstall --user 0 com.google.android.gms.droidguard
Failure [not installed for 0]
1|beyond1lte:/ $ pm uninstall --user 0 org.microg.gms.droidguard
Success
beyond1lte:/ $ pm uninstall --user 0 com.generalmagic.magicearth
Success
beyond1lte:/ $ pm uninstall --user 0 com.android.vending
Success
beyond1lte:/ $ pm uninstall --user 0 com.reecedunn.espeak
Success
beyond1lte:/ $ pm uninstall --user 0 foundation.e.apps
Failure [not installed for 0]
1|beyond1lte:/ $ [user@titan ~]$

They all still on the device installed.

Edit:

After a reboot, still makes connection to google and amazon:

In the UI ->settings ->system ->advanced ->microG
switching OFF have to be done in the right order : start from the bottom to the top

.

Yeah that wasnt possible. Maybe because of a Bug? Because the “On/Off Slider” dont do anything and stands on “on”. Not matter how hard/precise you decide to touch it.

Anyway, like @AnotherElk suggested, i disabled now App Lounge, Microg, and anything else what have to do with it (still researching how to remove it completly instead of deactivating).

About “supl.google.co_m” i found this german blog: Android: IMSI-Leaking bei GPS-Positionsbestimmung ⋆ Kuketz IT-Security Blog

This seems to fix that. Must find out how to edit it with adb as root, because su is not available.

Than i must find out, what on the phone makes a connection to gllto.glpals.co_m.

Still researching.

Edit: Found one place where gllto.glpals.co_m is written:

beyond1lte:/ $ cat /vendor/etc/gnss/gps.xml

<?xml version="1.0" encoding="utf-8"?> <hal PortName="lhd" NvStorageDir="/data/vendor/gps/"
LogDirectory="/storage/emulated/0/gps/broadcom/storage"

WakeLock="geo"

LPmode="false"
CpColdStart="false"
CpGuardTimeSec="1"
CpLppGuardTimeSec="1"
CpLppeProvideHighAcc3DPosOnComIECap="true"
ReAidingOnHotStart="false"
SuplSslMethod="SSLv23_NO_TLSv1_2"
SuplEnable="true"
SuplUseApn="false"
SuplTlsCertPath="/vendor/etc/gnss/gps.cer"
SuplTlsCertDirPath="/system/etc/security/cacerts"
SuplUT1Seconds="20"
SuplUT2Seconds="20"
SuplUT3Seconds="20"
TcpConnectionTimeout="20"
SuplLppCapable="false"

LbsEnable="true"
LbsServer="BCMLS2.glpals.com"
RtiConfig="gllto.glpals.com:80/rtistatus3.dat"
HttpSyncLto="true"
LbsCellEnable="false"
LtoDir="/data/vendor/gps/"
LtoSyncThresholdDays="1"

IgnoreJniTime="true"
AssertEnabled="false"

IgnoreFwConfig="false"
DisablePglorNmeaCallback="true"

GnssYearOfHardware="2016"
WakelockAlertSec="1800"
EventDumpEnable="true"
AttributionAppPkgName="com.sec.location.nfwlocationprivacy"

/>

<gll
LogPriMask=“LOG_INFO”
LogFacMask=“LOG_GLLIO | LOG_GLLAPI | LOG_NMEA | LOG_RAWDATA”
FrqPlan=“FRQ_PLAN_26MHZ_2PPM_49_152MHZ_300PPB”
RfType=“GL_RF_4755_BRCM_EXT_LNA”
MultiCarrLnaMask =“L1_EXT_ON”
MultiCarrRFMode =“GL_MULTI_CARR_RF_MODE_L1”
WarmStandbyTimeout1Seconds=“10”
WarmStandbyTimeout2Seconds=“15”
RfPathLossDb_Cp=“5.0”
RfPathLossDb_Ap=“5.0”

<gll_features
EnableLowPowerPmm=“true”
EnableBeidou=“true”
EnableGalileo=“true”
EnableACSD=“true”
MPFCollect=“true”
/>

beyond1lte:/ $

Edit: found supl.google.com. Replaced it in every file with “localhost”. Restarted Smartphone, and now only the two amazon services/domains left.

BCMLS2.glpals.co_m and gllto.glpals.co_m

Changing both now too, and then i report again.

(just for some who curious how i found the domains: on /e/ is luckely grep installed. So grep -rnw / -e supl.google.co_m for example shows every file where this domain is set)

2 Likes

is BCM related to wifi portal ?

It seems not. My Research showed that this, or to be pricise the domain bcmls2.glpals.co_m and gllto.glpals.co_m are domains wich the owner is “PERFECT PRIVACY, LLC”. And that, what they want to host, they host it on amazon aws (wich i cant use, because i block everything wich comes from amazon for example like already mentioned). https://www.whois.co_m/whois/glpals.com

The Domains have something to do with (A-)GPS. Replaced any domain with “localhost”.