/e/VPN disapear

I changed my carrier and reset my network settings. Then the VPN /e/OS disappeared.
Or maybe it’s related to the /e/OS1.12.3 update?
Do I need to reinstall the /e/OS VPN or if /e/OS1.12.3 handles it differently?
If I need to reinstall it, what are the parameters?
Thanks for your feedback

Do you mean Advanced Privacy? I neber heard that /e/ has a VPN

/e/OS (as android in general) only offers an interface (or slot) for “VPN” which might be used by e.g. vpn services (apps that relate to external VPN-services) or DNS-filtering-/firewall-/network-analysis- apps (like “NetGuard”, “nextDNS”, “blokada”, “personalDNSfilter”, “PCAPdroid”, “AdAway” etc.) or the hide my IP module of Advanced Privacy

Utilizing this interface it is possible for apps to force (most) all internet traffic through that interface and thereby allow tunnel/control/analysis of out-/ingoing traffic.
If an app wants to make use of that interface it must ask permission and can be granted access, in that case a “vpn” (interface) is configured (automatically) for that specific app within /e/OS. (it is also possible to manually add and configure VPN in the settings via the “+” symbol).

Maybe an existing configuration got lost during update?
The app that wants to use it should then ask for it anew so it can be granted.

You find existing vpn-interface-configuration of your phone/system in:
system settings > network&internet > (expand menu) > VPN (here you find all configs listed per app - Advanced Privacy only after activating the hide my IP module)

The available parameters within these per-app-vpn-interface-configurations are limited anyways (not 100% sure about English wording…):

  • “always on” On/Off (I´d use active as a default but depending on the function of the app…)
  • “block traffic without VPN” On/Off (do not activate as activating generally blocks all traffic - that´s a bug…)
  • “delete vpn” (deletes the specific config, if needed again, app must ask for permission, see above)

edit: corrections with regards to Advanced Privacys “hide my IP” module which I mixed up with “hide my location”

process to reproduce :

  1. install protonvpn
  2. connect your account
  3. reboot
  4. system settings > network&internet > (expand menu) > VPN

See the Advanced privacy VPN is newly created

I cannot reproduce this as I have no protonvpn-account, maybe others can.

[quote=“Sebu, post:4, topic:50458”]
See the Advanced privacy VPN is newly created
There´s no “Advanced Privacy” VPN among my several app-specific VPN-definitions (with AP hide my location activated and rebooted).
Maybe there´s some device specifics going on…(?) mine is a Samsung S7

Mine is samsung s9.
I have an old proton free account.

Here is the screenshot

That´s strange as I presumed that You now have two vpn defined in your system settings after that reboot: one for proton (as this app requests and uses it from what I understood) and one for AP…

No clue which phone behaves buggy: mine, not showing the AP-vpn, or your phone which shows the AP-vpn (instead of proton-vpn?) (?)
maybe others can contribute what they see in their settings…
From a functional perspective mine is OK (=AP hide my location is working - without a “visible” AP-vpn in the system settings).
As long as yours is functional too … no worries :slight_smile:
I must add that I never used a dedicated vpn service like proton (only DNS filters and the like), so maybe yours shows normal behaviour anyways…

I delete the protonmailVPN but the AP does not disapear even after a reboot.
I don’t know if it is linked but I’ve noticed that I regularly lose my data connection via a malfunctioning app or the no internet message on browser, to found that AP VPN is randomly blocking data access. When I deactivate it, the data is open again and display the network traffic moniror in the status bar :thinking:

Hello @Manoj
maybe someone @ /e/ could look into it and see if everything work as expected ?

I always used to find Advanced Privacy under VPN. If AP is deactivated, it presumably won’t block data either.

It sounds like Proton may not have been installed correctly.

Sorry for the confusion, I badly mixed that up:
it´s the “hide my IP” module that uses the vpn interface and not the “hide my location” module of Advanced Privacy. :person_facepalming:

I´ll correct my posts above to not cause further confusion for others.

Now that I testwise activated the “hide my IP” module I also get the AP-vpn in system settings - so all seems fine in my phone.
Sorry @Sebu, I am afraid I was not of much help so far :slight_smile:

Proton was auto installed like mozilla I used before that.
The weird thing is that AP VPN is displayed only when we install another VPN.

This topic was automatically closed after 90 days. New replies are no longer allowed.