/e/, whyred and Nextcloud

Hello, guys!
Best wishes to you all with the new year!

I installed /e/ on a xiaomi note 5 - whyred.

Most things seems to work (:grinning:) but :slight_smile:

  • clock (horloge) : never worked;
  • I had an account with e.email (but seem to have lost it -??) : e.drive never worked
  • I can’t sync contacts with my nextcloud (calendar works). The Nextcloud app can’t add an account. No sync thus.

Anyone facing the same problems?

PS : I use the latest rom (as january 6th)

Thanks for your interest!

1 Like

@mascaret you would need your e account to get the edrive and contact working. Please send a mail here contact@e.email with your details to get the account back.

What symptoms do you have with the clock? For example does it show the wrong time?

In order to access the contacts of your own Nextcloud-instance, you don’t need the Nextcloud-Android-App, but you need to add a WebDAV account via the settings menu (I have a Nougat-System, so I don’t know, where this option is located in the Oreo settings menu).

To add a WebDAV account the location is almost the same in Oreo /e/ builds i.e. Settings >>User & acounts >> Add account …this will display a screen where you can add the WebDAV account

1 Like

This might be worth mentioning though:

1 Like

Hello!

Sorry I could not revert to you any sooner.

Clock : signals an error upon boot the time is displayed on home screen. However, the “Horloge” (clock) app hangs.

I’ve added my webdav accounts from start. Calendar works : synced with nextcloud.
That’s not the case with contacts.

Even with the android Nextcloud app : I can access my files on the server, everything working BUT contacts syncing (I can’t create an account from my e-phone as required by the nextcloud app).

Before the e-whyred, I used lineage on an galaxy note 3 (hlte) with davdroid : was flawless.

So, I presume it’s an e-related glitch.

Thanks for your interest!

@mascaret Can you try and download the clock app separately from Apkpure and try and install it just to check. I just tried it and it on my phone which has /e/ and it works separately as well… then I have two clocks on my phone and they are both working. One scenario I can see is if the time is set to a different time zone then it may crash.
You can also try and change the time settings under Settings >> System >> Date & time

I just installed a second clock app. Which seems to work as expected. The /e/ clock still doesn’t.

However, my concern is mostly with Nextcloud (impossible contacts syncing)…

Anyway, thanks for your time!

Hello,

Have you solved the issue ? Cause I’m facing similar issue : next cloud android app don’t sync my data with my own next cloud in the background on my e.phone 0.5 , a xiaomi redmi note 5 whyred

Hi @Markus had you not setup a cloud instance of your own? Are you facing this issue?

I will test this as soon as I upgrade my phone to 0.5. With my LeEco on 0.1 I have no such problems.

1 Like

Sorry for my misleading previous post - I was under the impression that you were unable to sync files with your nextcloud server, which works for me.

Now that I have updated my system to 0.5, I searched for a way to update files in the background and found out that the Nextcloud-App (V3.5.0) does not provide such a functionality. Hava a look here for more background on this topic:

Hello, my experience with /e/ on my Xiaomi Redmi Note 5 Pro Whyred :
First I Unlocked my bootloader, installed TWRP 15 days ago and followed the wiki instructions to install /e/ on whyred.
But, the first time I only erased data, caches & system. The /e/ rom installed itself with success but I think some Xiaomi prior datas were kept on the phone somehow, MicroG was acting weird, push notification only at phone boot, the phone was a little bit slow… I was not happy with it.
I decided to install it another time and I erased everything, all erase options of TWRP and install /e/ back and give another try.
This time all was working great : All is working great out of the box : clock, drive sync, cloud sync, calendar sync, contacts sync, e.email sync, MicroG, push notifications for apps… Battery last ~ 2 days. My phone is rooted, off course, and all my apps are working great, I upgraded to 0.5-201904187440 by OTA without problem.
One little problem when I installed adaway, I had to whitelist “mtalk.google.com” (and same thing in all adguard, blokada or similar apps) and my MicroG push notifications come back again. I have 130 applications on my phone (yes I know, too many, some I even don’t use daily) and everything is working great so far.

Thanks /e/ team !

Notes: I remember in a cyanogen forum, from a dev who said everytime you flash a new rom, you should flash it 2 times on the go, why, I don’t know…