Easy Installer "Cannot get security patch information"


I’m running the Easy Installer on a macbook air M1 to install /e/os on my Fairphone 4. The installer fails to resolve the security patch (which is July 5 of 2023 in my case).

I think maybe it is because the latest available version for Fairphone 4 (https://images.ecloud.global/stable/FP4/) is the version 1.13-s. This version is compatible with devices with security patch of June 5.

So in my case the anti-rollback security will brick my phone if I install this version. Maybe to avoid this the installer does not work ?

Also I cannot do the manual install (of version 1.14 for security patch of July 5) as it does not work on macOS.

There is a way to install /e/OS on my Fairphone 4 from my mac ?



PS: Of course my phone is unlock I already did an installation few month ago and everything worked fine.

I don’t think that’s exactly what’s happening. The installer is not able to read the version number (for whatever reason). And as it doesn’t know the version number, it can’t know if the anti-rollback feature might brick the phone, therefore it stops. The outcome is basically the same as if the version number was too low, but the fix of the issue will be different.

If you click on the “V” left of “Log” the installer will show its debug log. That should indicate where the problem is exactly. But IIRC it’s not possible to copy the log text from there (just try, maybe it has changed at some point) and nobody knows where the log file on Mac OS is located, so that one could open it with a simple text editor in order to paste its contents here.

Edit: the error message indicates that the following command didn’t succeed (and the log should contain the corresponding error message)

adb shell getprop ro.build.version.security_patch
1 Like

I have the same issue. Haven’t been able to solve it.


I used the manual installation procedure instead of Easy Installer and it work.

1 Like

With a MacBook M1 and FP4? I’ve bricked it once, wouldn’t want to do it again ahahah

Hi, I had the same issue (… cannot get security patch information …) on my macbookpro for a fairphone4.
I switched back from easy installer to a more manual installation: https://doc.e.foundation/devices/FP4/install
However, the procedure failed while using the script flash_FP4_factory.sh like supposed in the description:

 chmod +x flash_FP4_factory.sh && ./flash_FP4_factory.sh

This script is not intendet for the use with a mac. Finally I found an even more manual way to flash the custom ROM: https://forum.fairphone.com/t/install-e-on-a-fairphone-fp4-fp4-beta/80760
This explanation is somewhat cryptic, but all lines, how to flash, are to be found somewhere in the easy installer script flash_FP4_factory.sh and can be taken from there.
For the custom ROM IMG-e-1.15-s-20230916331435-dev-FP4 (look for the download yourself, I am not allowed to post more than 2 links), which I used, the following bash script worked for me:

../platform-tools/fastboot flash bluetooth_a bluetooth.img
../platform-tools/fastboot flash devcfg_a devcfg.img
../platform-tools/fastboot flash dsp_a dsp.img
../platform-tools/fastboot flash modem_a modem.img
../platform-tools/fastboot flash xbl_a xbl.img
../platform-tools/fastboot flash tz_a tz.img
../platform-tools/fastboot flash hyp_a hyp.img
../platform-tools/fastboot flash keymaster_a keymaster.img
../platform-tools/fastboot flash abl_a abl.img
../platform-tools/fastboot flash boot_a boot.img
../platform-tools/fastboot flash recovery_a recovery.img
../platform-tools/fastboot flash dtbo_a dtbo.img
../platform-tools/fastboot flash vbmeta_system_a vbmeta_system.img
../platform-tools/fastboot flash vbmeta_a vbmeta.img

../platform-tools/fastboot flash bluetooth_b bluetooth.img
../platform-tools/fastboot flash devcfg_b devcfg.img
../platform-tools/fastboot flash dsp_b dsp.img
../platform-tools/fastboot flash modem_b modem.img
../platform-tools/fastboot flash xbl_b xbl.img
../platform-tools/fastboot flash tz_b tz.img
../platform-tools/fastboot flash hyp_b hyp.img
../platform-tools/fastboot flash keymaster_b keymaster.img
../platform-tools/fastboot flash abl_b abl.img
../platform-tools/fastboot flash boot_b boot.img
../platform-tools/fastboot flash recovery_b recovery.img
../platform-tools/fastboot flash dtbo_b dtbo.img
../platform-tools/fastboot flash vbmeta_system_b vbmeta_system.img
../platform-tools/fastboot flash vbmeta_b vbmeta.img

../platform-tools/fastboot flash super super.img

../platform-tools/fastboot flash aop_a aop.img
../platform-tools/fastboot flash featenabler_a featenabler.img
../platform-tools/fastboot flash imagefv_a imagefv.img
../platform-tools/fastboot flash multiimgoem_a multiimgoem.img
../platform-tools/fastboot flash qupfw_a qupfw.img
../platform-tools/fastboot flash uefisecapp_a uefisecapp.img
../platform-tools/fastboot flash xbl_config_a xbl_config.img
../platform-tools/fastboot flash core_nhlos_a core_nhlos.img

../platform-tools/fastboot flash aop_b aop.img
../platform-tools/fastboot flash featenabler_b featenabler.img
../platform-tools/fastboot flash imagefv_b imagefv.img
../platform-tools/fastboot flash multiimgoem_b multiimgoem.img
../platform-tools/fastboot flash qupfw_b qupfw.img
../platform-tools/fastboot flash uefisecapp_b uefisecapp.img
../platform-tools/fastboot flash xbl_config_b xbl_config.img
../platform-tools/fastboot flash core_nhlos_b core_nhlos.img

../platform-tools/fastboot erase userdata
../platform-tools/fastboot erase metadata
../platform-tools/fastboot --set-active=a

Before you give these bash commands, you should download the android sdk platform tools for mac (look for the download yourself, I am not allowed to post more than 2 links) and place the directory “platform-tools” next to the image directory “IMG-e-1.15-s-20230916331435-dev-FP4” on your hard disk. Then cd into the IMG… directory and give the commands. (Actually I created a text file named “flash_commands_FV” and saved it into the IMG… directory. Then I startet the batch file by “./flash_commands.txt”.)
In the end you have to check, whether the slot of the partitions on the mobile phone is chosen correctly. (Last command in the batch list changed to slot a.) Therefore, restart your mobile phone and see if everything works fine. Otherwise switch to the other slot and try again.

So far I have not yet locked my bootloader again. I am not sure if this can “brick” my device. Maybe somebody here knows more about that? Btw all given information is on your own risk.

Hope this will be useful to someone! /e/os is a nice ROM with properly selected preinstalled apps - in my opinion. And the preconfiguration of the settings is fine.

The two missing links in my last post are:
(images of /e/os)

(android sdk platform tools)

This topic was automatically closed after 180 days. New replies are no longer allowed.