Easy installer does not start download latest FP3.zip

Hi there, I`d like to install e/os on my fp3 but download is failing … does not start. Can you help me please?
Nice greetings from berlin

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @hansvondingen welcome to the /e/ forum

If you can find the log this might help inform an explanation.

1 Like

thanks! unfortunatelly its different. I use Mac, downloader starts and when it comes to download the files it just says there is an error downloading it. as I understood the downloader needs to connect https://status.murena.io where is “something broken”.
Am I right it is maybe this and is there another solution to get the needed files?

Post script Edit … ok … I see on second look you are currently seeing

Something’s broken; we’re on it!

… in which case you must just wait for it to clear!

Well Easy Installer is a program; you would need special knowledge to break into the script – if you had this you would just do:- Install /e/ on a Fairphone FP3/3+ - “FP3”.

Surely it is not sooo unfortunate to use a Mac? :slight_smile:

Is not the log in the same relative position as described for Linux?

We do not yet know what difficulty Easy Installer experienced.

If something is broken I expect it to be recorded in the log; then you could try to ask for a fix.

I had a look at the source code of the installer. I don’t see that it explicitly checks https://status.murena.io/, but of course, if a general maintenance is announced that could also affect the download of the install images.

The only file that needs to be downloaded for the FP3 is https://images.ecloud.global/stable/FP3/IMG-e-latest-FP3.zip which at the moment seems to be accessible, even if the status page still says “Something’s broken; we’re on it!” (I didn’t wait for the full 1,2 GB to be downloaded, just checked that the transfer starts).

The log file on Mac definitely is not in the same location as on Linux. ~/snap/easy-installer/common is the location there, because on Linux the installer gets distributed as a so-called Snap package. Which is not the case for Mac OS (or Windows for that matter).

Looking at the source code, the log on Mac OS should be either in /tmp/easy-installer or the bin subfolder of the path the application gets installed to on Mac OS (wherever that is, I don’t have a Mac).

Edit: what you can try to do is to download the file I linked above, go to the folder where the installer got installed to (that folder should contain subfolders bin, conf, legal and lib), create a new subfolder sources and another subfolder inside sources that is called FP3. Place the downloaded file in the FP3 folder. Then start over with the easy-installer.


@Ingo_FP_Angel thanks for this!
I put the downloaded file into the bin/sources/FP3 folder and started easy installer again, but easy installer still fails trying to download the file… how can I pass this? make easy installer to find the file?

thanks in advance!

@aibd because easy installer does not work although I download and put it in place manually like @Ingo_FP_Angel described, I try to go the complicated way Install /e/ on a Fairphone FP3/3+ - “FP3”.
for this I need to unblock the bootloader and to do that I need to enter IMEI and Serialnumber. BUT I get an error The IMEI and/or serial number is incorrect. Please check for typos. I entered correctly!
I had e/os running for two years, then my FP3 was broken and they changed the motherboard. at the repair summary I can see an IMEI IN and a different IMEI OUT… I tried both…
Any idea?

thank you all very much!

Were you able to find the location of the log file?

I found bin etc but no log-file…

I put downloaded file here (also tried unzipped…)


So if it’s not in bin, it should be in /tmp/easy-installer.

But then, you could also look at the log in the running installer by clicking on a blue “>” icon. But AFAIR you won’t be able to copy the text from there.