Easy Installer fails halfway through (Galaxy S7)

I have seen these error messages many times. Follow the steps below exactly:

Reboot into TWRP recovery

Now tap **Factory Reset**, then **Format data / factory reset** and continue with the formatting process. This will remove encryption and delete all files stored in the internal storage, as well as format your cache partition.

Reboot into TWRP recovery again

To be on the safe side and for testing, clear again:

Wipe > Advanced Wipe >Dalvik/ART Cache, Cache, System and Data.

Repeat the deletion until no more error messages are displayed.

Return to the main menu.

Tap > Mount and check¹ whether the /data partition can be activated.

¹Only check, do nothing else

If the /data partition is ready to be mounted, continue with the installation of the /e/OS ROM …

Now the eOS ROM is flashed by tapping the TWRP button “**Install**”, selecting the file e-0.13-o-2020120889191-dev-herolte.zip from your **microSD** card and installing it. At the end of the automatic installation process, tap Wipe > Dalvik/ART cache and boot into the SYSTEM.

@SuzieQ: It actually worked so far…I can’t believe it…thank you so much. I hope I can get through the setting up process now without any difficulties. Thank you, thank you, thank you. I really appreciate it.

@SuzieQ: Do I install the update for /e/ through the recovery mode or should there be a possibility to automatically update it? When I try to install an update it says that I need a combatible recovery system to install updates.When I press OK, the update installation fails.
If I have to install it through recovery mode, is the way to do it as follows:
Recovery Mode --> Install --> e-0.14-o-2021012798648-dev-herolte-1.zip?

Oh, and am I supposed to update TWRP? I’m asking because when I first installed the latest version it didn’t work and with the older version, that was linked to above, it did.

Help is really appreciated. Thank you.

Wow, how fast time flies: 13 days later.

@ParksandRec, normally, an S7 OTA update should be installed automatically using TWRP Recovery. If this does not happen, there is an issue.

Now there is the possibility to update manually. If the download via OTA worked, but the installation did not, then start the device in Recovery Mode. Use TWRP “Install” to navigate to the directory /data/lineageos_updates and tap on the file e-0.14-o-2021012798648-dev-herolte.zip.

If the update file is not available, download the current /e/ OS e-0.14-o-2021012798648-dev-herolte and transfer it to the internal memory or a microSD card. From there, the update can also be triggered via TWRP “Install”. Everything alright?

Can you guess what the issue is, if I can’t update automatically?
Do I need to wipe Cache/Dalvik after installing the update manually? Yes, installing the update manually worked. Thank you again.
Should I update TWRP and if yes, what’s the best way to do it?
Thank you so much for the quick help. I’d have given up on this long ago…

The TWRP install feature can install another TWRP version
But for Oreo the TWRP 3.3.x-x is the best

As long as you are working with /e/OS Oreo 8.1, the installed version TWRP 3.3.1-0 is absolutely sufficient.

It’s only given up when the device is physically broken … :))

I would have been mentally broken way before that :wink:

Bonjour @piero J’ai exactement le même problème que ParksandRec avec le même téléphone.

Toutefois, pourrais-tu me transmettre les explications en français car là je t’avoue que je vais vraiment galérer…

Merci infiniment

Je viens d’utiliser la traduction de @Anonyme. En jonglant entre ces manips et l’appli ça semble fonctionner. Je suis à l’etape où le logo e fait du basket-ball… Par contre c’est vraiment très long cette phase ou c’est que pour moi ? (Ça fait 20 min)

Re…
Après plus de 4h j’ai toujours le logo e animé sur mon téléphone…

Bon Jour, @Jog

C’est tout a fait normal car je crois qu’il manque une etape dans le TUTO :
Rebooter en mode recovery après ”format /data" et avant de pouvoir de nouveau utiliser la partition.

Peux tu arreter l’appareil avec les boutons
home + power ?

Et démarrer en mode recovery avec les boutons
Home + volume haut + power ?

Dans TWRP Choisir “Reboot System” ?

Tout d’abord merci pour ta réponse.

J’ai réussi à rebooter le téléphone refais toute la procédure présenté par @Anonyme, mais à la fin mon téléphone n’a pas affiché le logo /e/. Je voyais en fond le dernier menu présenté puis l’écran s’est éteint après un certain temps.
Et après 1h30 l’écran est toujours noir et les combinaisons de touches home+power ; home + volume haut + power ; home + volume haut + power ne donne strictement rien…

if you see something like that :

… … It … FAILED … ! … …

this is the Official Stock Vendor Samsung / Gogol Firmware Recovery screen !
Please re-read and retry the flashing process of TWRP.

les boutons haut et bas sont peut-etre inversés sur le s7, pour les modes download et recovery

Merci pour les réponses. J’ai pu rebooter.

J’ai refait toutes les manip présentées. Le téléphone présente le fameux e depuis 2h… On a voir

1 Like

Mlaheureusement le “e” est resté toute la nuit et le lendemain… sans que le téléphone ne veuille redémarrer…

Reboot into TWRP recovery

Now tap Factory Reset, then Format data and continue with the formatting process. This will remove encryption and delete all files stored in the internal storage, as well as format your cache partition.`

Reboot into TWRP recovery again

To be on the safe side and for testing, clear again:

Wipe > Advanced Wipe
Dalvik/ART Cache, Cache, System and Data.`

now, install/e/

En utilisant une version plus ancienne du /e/ ROM ça fonctionne parfaitement ! Merci infiniment !! Vive la libération

Bonjour @piero je lis ce topic et je comprends que Easy-installer n’est pas la methode recommandée pour installer /e/ ? Je me réjouissais d’avoir un telephone supporté par Easy-Intaller mais je me suis réjouis un peu vite ?