Easy installer fails with Samsung S8 - Only official released binaries are allowed to be flashed

Hi guys,

I bought two S8s with the hopes of flashing them (as you unfortunately don’t deliver to Australia).

The Easy Installer (v.0.10.1-beta Ubuntu Snap) gets to the ‘Installation’ screen and stops with 'The installation encouter an error".

I hit ‘send to support’ but couldn’t see the log.

However the Samsung installation screen on the phone logs the following last line, in red:
‘Only official released binaries are allowed to be flashed (RECOVERY)’

Can you help with suggestions what to do?

Hi @eelo-in-Oz thanks for sharing the error details… also can you confirm that the installer is trying to access the default build for the S8 and that you are running it exactly as the screens mention.
You can access the logs on windows PCs here

Thank you for your response. I’m on Ubuntu 20.04 but I believe I found the log. It is uploaded here

Hopefully it will show whether the installer accessed the standard build for the S8 (not sure where else to check).

Confirmed that I did everything exactly as shown on the installer screen, subject to:

  • ‘Android debugging’ wasn’t available on the phone so I tapped on ‘Enable USB debugging’

  • Before being able to select ‘OEM Unlock’, I had to make the option appear by manually setting the date to more than 7 days ago, deactivate some auto updates and restart the phone, as per this tutorial, and then restart Easy Installer and begin again

That time I got as for as the error message.

Thanks for the details …let me check with the developer and get back

1 Like

Hi @eelo-in-Oz pl can you raise a bug with all details here. The developer will have a look and get back to you in case more info is required.

Hi @Manoj,
There is a similar post/topic about a s7

Hi @Manoj and @piero

I got the same Problem with easy installer and my Galaxy S8 (SM-G950F).
Do you already know more?

Best, Géraldine

Pl can one of you raise a bug with details in Gitlab. I can pass it on to the developer tomorrow during office hours and have the updates added on the bug report.

Sorry, actually it is not the same problem than described by eelo-in-Oz.
I tried to flash /e/OS on my Samsung S8 with easyinstaller. From the screen (see picture below) i cannot boot into TWRP.

I tried like it is described in this post
But it boots into Android recovery and looks like this:

What am i doing wrong?

Just after flashing TWRP (with no reboot option),

To get out download mode :
Hold ´volume down’ and ´power’ only to shut down

Then immediately reboot to recovery mode :
Hold ´home´, ´volume up’ and ´power’ to reboot recovery
Release when you see the little blue line at bottom of the screen…

Hi @piero
Now i tried to install /e/OS by flashing TWRP with ODIN as described in this “howto”.
I could install TWRP and boot into TWRP. I wiped the partitions (dalvnik, Cache, System, Data and preload).
:arrow_right: Do i have to wipe “internal storage” as well?

Further i could Copy-Paste the ZIP folder of the /e/ ROM into the internal storage of the smartphone.
But the installation via TWRP fails by displaying “error 7”:

what does it mean? how can i solve it?
And what is going to happen if i click on “reboot system” after the wipes and the failed installation of /e/OS?

Just for information, i’m super happy to tell you that it finally worked out to get /e/OS running on my Samsung S8!

  • I followed this “howto
  • to solve ERROR7 which encountered, i hat to take an older Version of TWRP (Version instead of
  • then i could install the latest version of /e/OS (e-0.12-p-2020102981459-dev-dreamlte.zip)

thanks for all the inputs in this forum :hugs: :+1:

Also just for information:
I had the same easy installer fail message with Samsung S9 (Model SM-G960-F) running Software revision version 15 (Feb or March 2021). The solution was similar to the above, that is:

  • follow the howto mentioned by geri ( howto )
  • installing TWRP at the first attempt failed, with the same “only official released binaries…” error. This caused the ‘OEM Unlock’ option to disappear, and I had to make the option reappear by manually setting the date to more than 7 days ago, deactivate some auto updates and restart the phone, as per this tutorial ,
  • for reasons unclear to me, the second attempt to install TWRP worked, then the remainder of the howto mentioned above worked as well, with the following small differences
    • there was no Error 7 when installing the /e/ .zip file
    • after the install, there was no prompt whether to install TWRP to run under /e/

Versions involved:

  • Phone: Samsung S9 (Model SM-G960-F) running Software revision version 15 (Feb or March 2021)
  • Odin3_v3.14.4
  • twrp-3.5.1_9-0-starlte.img.tar
  • e-0.13-q-2021012097133-dev-starlte.zip

Remark: searching for the error message “only official released binaries…” led me to recommendations to root the phone and then disable the Knox security feature. However, if you do not want to root the phone, this is an overkill and has its own problems.

Hi everybody,
Just bought an S8 to install e/OS following @geri instructions.
Eveything is going fine except i cant enter in TWRP. i cant even be in Android recovery.
The phone is simply on the main screen like if i just was turning on.
I’ve tried many times without success.
And about the alternative procedure, i cant find “Options” tab (between “Log” and “Pit”).
Where am i supposed to find this?
thanks for your help

Did you ever, previously enter other booting modes, before you started the install of /e/?

Any clues for you here? Know your hardware - Samsung

You are calling from a thread where users started from Easy Installer and found they had “some-sort-of-Samsung-lock” still applied. Do you think you have that situation? What evidence? :smiley:

i have never ever enter any booting mode before.
I bought a refurbished S8 and Didnt start to use it.

I answer on this thread cause i have been following Geri’s instructions step by step.

iam gonna read tonight the link you gave me for the beginner like me. hope, i Will find something to understand whats going on.
Right now, it doesnt seems i have à Samsung lock, its more like if i Was doing something with out any effect.

if you have more advice for someone like me jupping in the unknown, i would love to read them :sweat_smile:

Envoyé depuis ProtonMail mobile

-------- Message d’origine --------

Well you have a very good tutorial here, and also in French.

My guess there will be the unlocking stage near the start you need to review.

Bon chance

Hi Topper,

I installed /e/ on an old S8 I had lying around yesterday. I had some problems but it eventually worked and I’m up and running.

Did you use the Easy Installer or are you just using the other guide?

The Easy Installer only partially worked for me. I’m not sure whether the error message I received was exactly the same as that posted further up the thread, however I used the guide linked by @geri to finish off.

To finish the installation, I manually downloaded the zip file and copied it to the Internal Storage of the S8. I then installed the .zip file using TWRP. This didn’t work first time either and I had to repeat the process.

To enter TWRP are you sure you are pressing the Power/Bixby/Volume buttons in the correct order (volume up rather than down)?

Good Luck!

Hi @DWhitt

i Was doing wrong to enter correct l’y into TWRP: your instructions were clearer for me than the one’s on Geri’s link.

So, i Did it !!!:relieved::joy:
First time, iam doing something like that but with procédures and help, it seems e/os is running fine !!

Thanks to you and @aibd

Envoyé depuis ProtonMail mobile

-------- Message d’origine --------