Easy Installer FP4 -

Hi dear community,

to install /e/os on my fairphone 4,
I use a PC on Windows 11 Home 22H2*,
easy installer steps worked fine (in particular “developer options on”, “USB debugging connected”, “USB file transfer turne on”, “OEM unlocking on”)
…up to:

Checking Security Patch Level

The progress bar is full, but no “continue” button.
On the screenshot below you can see the last 5 lines of the log: there I don’t see any hint towards an error…

Someone described the same situation as mine in French, here:

It is not helping me, as her solution was to use another PC…which then worked.

Do you have any other advice or idea of the origins/causes of my problem?

Looking forward for your reply!

Greetings from Austria!

'* Edition Windows 11 Home
Version 22H2
Installed on ‎16/‎04/‎2023
OS build 22621.2861
Experience Windows Feature Experience Pack 1000.22681.1000.0

You might check out recent forum posts in the easy-installer and Easy Installer sections.

It seems a recurring problem, keywords being “Download fails” or “Try again”. I suggest you study one or two recent posts if they seem a bit like yours, perhaps dig out the log Howto troubleshoot issues with the easy-installer.

Looking at the source code of the installer the step to check the security patch level is done by the script store-rom-info.bat and according to the last lines of your log it should download https://images.ecloud.global/stable/FP4/e-latest-FP4.zip.prop next. For that, the script uses bitsadmin.exe, which seems to be some tool that comes with windows itself, but if I understand https://learn.microsoft.com/en-us/windows-server/administration/windows-commands/bitsadmin correctly, it seems that is no longer the case on Windows 11. But then I would expect some kind of error message about a missing command.

Can you open a command prompt and execute this:

bitsadmin.exe /transfer "RomInfo" https://images.ecloud.global/stable/FP4/e-latest-FP4.zip.prop e-latest-FP4.zip.prop

That’s exactly what the installer is suppose to execute next. What happens if you execute it manually?

Edit: I was able to check and bitsadmin.exe is present on Windows 11 (Pro or Enterprise, not sure which edition the work PC runs, certainly not Home), so maybe the documentation above just isn’t up to date.
In any case, I hope that the results of above command line gives some more insights

2 Likes

BITS has to be in all editions of Windows 11, some Microsoft software still rely on it.
Sometimes the documentation will not get updated :wink:

Additionally, BITS client log can be watched using Event Viewer.
Here is a Custom View you can save to an XML file, then import in Event Viewer (Action menu):

<ViewerConfig><QueryConfig><QueryParams><Simple><Channel>Microsoft-Windows-Bits-Client/Operational</Channel><RelativeTimeInfo>0</RelativeTimeInfo><BySource>False</BySource></Simple></QueryParams><QueryNode><Name>Bits-Client_Operational</Name><QueryList><Query Id="0" Path="Microsoft-Windows-Bits-Client/Operational"><Select Path="Microsoft-Windows-Bits-Client/Operational">*</Select></Query></QueryList></QueryNode></QueryConfig></ViewerConfig>

If no entries are shown, you may try in an admin command prompt sc qc BITS, then look at START_TYPE: should be 3 (DEMAND_START).
If there are errors, you can try bitsadmin /reset in an admin command prompt.


Also, is https://gitlab.e.foundation/e/devices/easy-installer/-/blob/master/README.md?ref_type=heads up to date with logs location?

2 Likes

Hi Ingo,
thanks for your idea!

Here is the result in Command Prompt, when easy-installer at “Checking Security Patch Level”:

Microsoft Windows [Version 10.0.22631.2861]
(c) Microsoft Corporation. All rights reserved.

C:\Users\flavi>bitsadmin.exe /transfer “RomInfo” https://images.ecloud.global/stable/FP4/e-latest-FP4.zip.prop e-latest-FP4.zip.prop

BITSADMIN version 3.0
BITS administration utility.
(C) Copyright Microsoft Corp.

Unable to add file - 0x80070057

“unable to add file”…? but:
The easy installer comes to “Start device in Fastboot mode”!

(Yeah! Level +1 :slight_smile: )

Then following step by step the easy installer prompts worked fine!
Great!

Wishing all merry christmas and a happy new year!!!
:snowman_with_snow:

2 Likes

For the record, BITS may need a full path for local file.

1 Like