Easy Installer installation on Linux problem

Hi, I’m having trouble getting the Easy Installer on my Purism laptop (Debian fork I think). I thought I had Snap installed correctly, but when I run

sudo snap install easy-installer --beta

I receive the message:

error: cannot perform the following tasks:
- Mount snap “easy-installer” (21) (snap “easy-installer” assumes unsupported features: snapd2.43 (try to update snapd and refresh the core snap))

So, I try:

sudo apt update

And I receive:

Hit:1 https://brave-browser-apt-release.s3.brave.com stable InRelease
**Hit:2 https://wire-app.wire.com/linux/debian stable InRelease **
Err:3 https://s3-us-west-2.amazonaws.com/brave-apt buster InRelease **
** 403 Forbidden [IP: 52.92.148.144 443]

**Hit:4 Index of /pureos/ amber InRelease **
Hit:5 Index of /pureos/ amber-security InRelease
Hit:6 Index of /pureos/ amber-updates InRelease
Reading package lists… Done
E: Failed to fetch https://s3-us-west-2.amazonaws.com/brave-apt/dists/buster/InRelease 403 Forbidden [IP: 52.92.148.144 443]
E: The repository ‘https://s3-us-west-2.amazonaws.com/brave-apt buster InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I’m obviously very green at everything I’m trying to do. I bought two Samsung S9+'s as once I saw the “Easy Installer”, I thought it would be great quickly get the /e/ software installed. It took me several weeks to install the OS on a couple of OnePlus phones previously. After hitting this roadblock on pretty much step one of the Easy Installer route, it’s not looking good. I know it’s not e-foundation’s fault, but man this stuff is still really tricky and finicky. It’s still so far from being easy,or even easier than following all the complicated manual steps like I did with the OnePlus phones.

It looks like one of six repositories couldn’t be updated.
Given that “buster” is in the URL, I assume that Debian 10 is meant by that.
The version of snapd in “buster” is too old (2.37): Debian -- Details of package snapd in buster
So not being able to update that repo isn’t really a problem because the snapd version in that repo is not the required one anyway.

You could still try sudo apt upgrade and see if a more recent version of “snapd” is in one of the other repos.

But overall I think you get better chances at an answer how to update snapd in the purism forum, not here.

2 Likes

I am not familiar with Pure OS repositories, but I can have a look at them. Can I ask if, before you installed Snap, had you done update && upgrade with no errors.

Please can you could point me to the link you used for your snap install (which I assume is a third party) to see whether we can improve on that. Please tell me if I am wrong, but it looks like you can be fairly safe to follow Debian guides mostly.

Edit, sure enough as @Ingo_FP_Angel says, Buster will only deliver v2.37 while bullseye has 2.49. So it will probably be a matter of finding out how to use a backport, or whatever PureOS calls it … checking.

2 Likes

Thanks for the replies. “sudo apt upgrade” didn’t update snapd.

I’ll switch over to the Purism forums and see if someone there has figured how to get snapd updated from 2.37 to 2.43 or higher.

Hopefully getting close.

1 Like

That is correct, if you changed nothing.

With a standard Debian Buster system you will get 2.37. Pure OS is merely Debian in the cleanest form, so expect that standard procedure.

Two choices you upgrade the whole system to Bullseye, where you will be updated to 2.49.

Or you use backports. Here, Instructions, you add a line to your /etc/apt/sources.list informing the repo that you might want to use a selected newer package sometimes.

Now when update&&upgrade nothing happens but inform apt of your intentions.

Now Instructions

apt install -t buster-backports snapd

gives you 2.49. All subsequent update && upgrade maintain (or advance, in due course) this situation.

Hi again,

So I added in the backports line to sources.list. However, I run “apt update” or “apt-get update” I get what looks like the same errors of not allowing some downloads:

Hit:1 https://wire-app.wire.com/linux/debian stable InRelease
Get:2 Index of /debian buster-backports InRelease [46.7 kB]
Err:3 https://s3-us-west-2.amazonaws.com/brave-apt buster InRelease
403 Forbidden [IP: 52.218.184.48 443]
Get:4 Index of /debian buster-backports/main amd64 Packages [486 kB]
Get:5 Index of /debian buster-backports/main Translation-en [408 kB]
Get:6 Index of /pureos/ amber InRelease [5,784 B]
Get:7 Index of /debian buster-backports/main amd64 Contents (deb) [5,860 kB]
Get:8 Index of /pureos/ amber-security InRelease [5,845 B]
Get:9 Index of /pureos/ amber-updates InRelease [5,843 B]
Ign:10 https://brave-browser-apt-release.s3.brave.com stable InRelease
Get:11 https://brave-browser-apt-release.s3.brave.com stable Release [3,434 B]
Get:12 https://brave-browser-apt-release.s3.brave.com stable Release.gpg [833 B]
Reading package lists… Done
E: Failed to fetch https://s3-us-west-2.amazonaws.com/brave-apt/dists/buster/InRelease 403 Forbidden [IP: 52.218.184.48 443]
E: The repository ‘https://s3-us-west-2.amazonaws.com/brave-apt buster InRelease’ is not signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

I tried “apt install -t buster-backports snapd” just to verify, and unfortunately it gave me the same notice that 2.37 is the newest version available:

Reading package lists… Done
Building dependency tree
Reading state information… Done
snapd is already the newest version (2.37.4-1+b1).
The following packages were automatically installed and are no longer required:
libmicrodns0 lightning purebrowser
Use ‘sudo apt autoremove’ to remove them

How to force these damn downloads? Forbidden IPs and unable to access the repository securely?

Thanks for your help so far. Just a thought I had from somewhere else- do I need to close/exit the terminal in between any of these steps?

Are you sure you did evey update and every upgrade mentioned in the instructions.

There is no point in moving on to a snap installation till you have fully and correctly upgraded your system.

Before introducing your EI snap installer package, and after following the above…

Please run snapd -v, snapd -V,
or snapd --version to confirm you fixed the system.

Also, in general always be sure you run update and upgrade with no errors before you install a package.

@aibd are you sure that the backports contain snapd? To my knowledge only some packages are backported. And using the package search for buster-backports gives no results: Debian -- Package Search Results -- snapd

Thanks, @Ingo_FP_Angel looks like I omitted an essential step before relying an leaving the house! Sorry, @Franko

Edit, just to give you an alternative to upgrading your system to Bullseye (or installing /e/ from the manual instructions) you could consider building from source.

The info on the Snap Github here is a bit advanced as it assumes you might want to actually hack Snap. You might find a more useful step by step online. Or you might follow a tutorial to “Install your first package from source” before you go further.

Whoops! Ok, I’ll scratch this for now. Still back to the original question of getting the updates to go through the “403 Forbidden” issue.

Being able to update those repos sure is a thing to be fixed. But it won’t solve your problem of not being able to install a new version of snapd.

Now, aibd’s suggestion to build the required snapd version from source code might be empowering, but to me it sounds like bad advice for people who’ve never built software from source code (assuming that’s the case here).
When going down the “compiling it yourself” route I’d rather suggest to build the easy-installer without snap. If it doesn’t work, you end up with a single program that’s broken. If building snapd yourself doesn’t work my fear is that the entire snapd setup could get broken (to my knowledge it’s a system-wide demon and not a simple executable).

Yeah, I’m not “building” anything. I’m already at 6-8 hours of just trying to get this snapd thing installed. Not even having started my original battle of getting some privacy-oriented daily driver phones. Once you step outside of iPhone world, its a lot of work and commitment to see these obscure projects through. Coworkers just shake their heads.

I wish there was a straightforward “update” function. This messing around with the 403 Forbidden and unsecure Buster file from Amazon AWS (yuck!) is tiring. Not sure why this is a problem unique to me; I must be doing something really obviously wrong that all the pros are assuming that I would/would not know to do.

(as the thread digressed to cleaning up apt ppas: something must have changed at the brave ppa since you installed it. An easy thing: remove anything related to brave within /etc/apt/sources.list (outcommenting lines) and /etc/apt/sources.list.d/ (just delete the file), then do a subsequent apt update and the 403 vanishes.

Then attend to getting a more recent snapd (if possible) and later go to brave.com and redo the current installation steps for the browser.

Thank you @tcecyk and just to butt in with a search for the original error (which I should have done at the start! My bad). I will just give the links, but do feel free to ask again. Brave not installable from repo on Debian Buster · Issue #12636 · brave/browser-laptop · GitHub, in which is a link to a “solution in Testing”: Add support for Debian Buster by bsclifton · Pull Request #14115 · brave/browser-laptop · GitHub.

I must be doing something really obviously wrong that all the pros are assuming that I would/would not know to do.

Please don’t see it like that. You are on a learning adventure, expect a few hiccups, and not seen here coworkers who just shake their heads.

I was also thinking (in agreement with @Ingo_FP_Angel) that lots of purists would not like snapd in their pure system, and a self-built Easy Installer would be preferable.

So, is it in general agreement that the straggling Brave install won’t have any effect on snapd? I use Brave (and Dissenter) as my browser so maybe I’m just on an older version? If I can avoid the mess of bookmark backups and loosing password history I would rather not deal with it right now, I just don’t have the hours for it.

And I have no idea about building my own package for Snapd. That sounds like a third rabbit hole for me to fall into. This whole phone project should have taken no more than an afternoon of profanity and rebooting.

So, any other ideas about how or why Snapd won’t update? Or is the Brave issue a potential roadblock for the whole update process?

So the brave issue is not directly related to Snap. Somehow I did not see in your replies that your could not actually do apt update error free. To take away from this is that is is best to update and upgrade with no errors before starting a new project involving new packages.

Bearing in mind that Buster is Debian 10 wiki, here is what Brave says about installation

I hope that will be a fix. You will want to include the steps mentioned by @tcecyk. (I see from one of your traces that you once had PureBrowser, you might reconsider the decision to replace it?)

It is always good to learn how to get backups of things, so that you don’t fear upgrades. How do I export bookmarks from Brave as an HTML file? See bottom of the article. https://support.brave.com/hc/en-us/articles/360019782291-How-do-I-import-or-export-browsing-data-

Their Help Centre is informative on Passwords: https://support.brave.com/hc/en-us/articles/360018185951-How-do-I-use-the-built-in-password-manager- , again bottom of the article, If you’d like to save your passwords to be imported in another browser or device, click the icon sitting just above the Saved Passwords list and select Export.

Buster is now classified as OldStable

This is part of the explanation that newer versions of Snap packages are not supported.

why Snapd won’t update?

That was answered in post #2 but perhaps not clear straight away. When we do apt update in Debian all we do is inform our system what is new on the repositories. When we do apt upgrade we order the available upgradeable, individual packages to be installed.

We can also search the repositories online like post #2 to tell us what is there. You can also easily change that search to Bullseye to see what is there!

Package: snapd (2.37.4-1) is what you get. OldStable has stopped at what was regarded as Stable in the past.

Perhaps reflect first, but one day you should probably upgrade to Stable, Bullseye. Probably you should check with your Distro first to know what pitfalls might be. I read this comment in a quick search. At what point should I upgrade from Amber to Byzantium? - PureOS - Purism community.

is the Brave issue a potential roadblock for the whole update process?

I hope I covered all the angles, no it is not directly, but I would want a Pure system clean, and I would regard it as a prerequisite that I could do apt update error free.

Edit. Of course I do not know PureOS so you really want to fully check there. Now I just saw this announcement,

Here again the Debian wiki (as a cross reference) DebianUpgrade - Debian Wiki

1 Like

DONE! I tried a bunch of stuff, but here is what ultimately solved my world’s problems.

I went into the Software and Update Centre on my laptop. In there, I assumed the “Other Software” section was just a list of items outside of the “PureOS Software” section, for clarity, as in the other stuff on the computer. All the Other Software items have always had checkmarks beside them which I thought meant they were installed and active. I noticed the line with the Brave bad actor… so I highlighted the line and hit remove. I went back into the terminal and ran the update command, and everything went ahead smooth, no errors. Snap updated to the newer version, which allowed me to then install the Easy Installer. A few reboots thrown in to recognize the new version of Snapd as well.

When I selected the line with Brave in it to delete, I received a pop-up notice that it was old/outdated, which makes sense. The active Brave browser never did disappear from my desktop, so that line was just some junk from a previous escapade.

Whew.

Once I had the Easy Installer running, it went pretty good. Much quicker and cleaner than doing it all manually. The least painful part of this process! In the past I struggled with the install on my three OnePlus phones, but this went smooth onto my Galaxy S9+ (the struggle was all about my particular laptop).

Thanks to everyone for their tips and thoughts, it helped me wrap my head around the issue and to better understand my system. Good learnings! I hope some day I can contribute back to the community. I guess even this thread may be some help to others.

5 Likes