Easy Installer needs attention

I’m sorry to say this because I really support everything you are doing but the Easy Installer needs some serious work to make it into what it is called- “Easy”.
There are just so so many logical inconstincies and ways to get lost and lack of information.
It’s actually easier to install via TWRP from a YouTube video and install e/os that way than it is Easy Installer.

Such a shame because it’s the way e/os can grow and take over the world, which I want it to do!

e.g. currently on “Downloading Recovery-e-latest-xxxx” with a green bar oscllating and “Try Again” button underneath???..this does not make any sense…surely the Try Again should appear if the the download fails as opposed to during?
What did I do? I just hit NEXT after Easy Installer found my device. Then it goes "Downloading e/os and Necessary Files and it downloads the “recovery-e-latest-q-xxxx” which it downloads (39Mb of 39Mb) and bam…oscillating green bar and Try Again…even though it says at the top of the screen Please Be Patient Downloading e/os AAAGGHH
Has it failed or not? What’s going on. Easy Installer is really really bad…sorry, but that’s my opinion. I would happily pay money for a better version.

It’s one of those situations where you want to say “Have you tried sitting next to someone who is using it and observed them?”

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

1 Like

“sitting next to someone”: video demos are great in communicating frustration. Also a good way for outsiders pinpoint the line of code that left you in a “oscillating green bar”. You’d need to at least name the device you ran into the issue with.

But I abandoned Easy Installer and just used TWRP…super easy…in fact it’s how the Easy Installer could be! (apart from the installing of TWRP with the very quick combo button push when you get the black screen after hitting START on Odin…)
I just feel Easy Installer needs some love and attention in its GUI and instructions, that’s all really.

before you went ahead and wrote TWRP to the partition yourself, did you check if the downloaded recovery was in fact written out to the partition?

it reads like the install-recovery.sh failed at this “f2” step (did you run this from linux or some other OS?) - but I currently have no Samsung at hand to test - https://gitlab.e.foundation/e/devices/easy-installer/-/blob/1ec8f52b/src/main/resources/yaml/star2lte_flash.yml#L52

Let’s see if more S9+ users pop up having issues flashing from the same environment

1 Like

When I flashed my S8+ I also ran into a couple of problems with the easy installer. Some problems were fixed after an E-Mail to the team but it still had some weird behaviours like pressing too fast “next” when I had to retry installing it meant the program hang itself up and not being able to go back to a previous step even tho nothing was installed between the steps is a bit unintuitive.

I’d be happy if it was updated and there were some quality of life changes. The download itself also wasnt so easy because it said it was downloading but it wasnt doing anything (had to check my packets to see this).

You can also Use open android installer which goes beyond in term of automatic install


1 Like

That openandroidinstaller looks so easy!
Have you tried it?!

Yes , I contribute a bit to it , You can to !

It’s available as flatpak now on flathub so one click away on linux


1 Like

It requires to download and install freedesktop 1+gb…

I use Openbox so determined that was recommend not require.

After the install … to launch I used:

iain@laptop:~/Path/to/installer$ flatpak run org.openandroidinstaller.OpenAndroidInstaller`

One click seemed a little optimistic !

Yes you can grab any other build format if you prefer


Flatpak is a shortcut for wider distribution support but yes it has caveats …

1 Like