Easy Installer on Mac (Installation experience?)


I mean that it is only new that you can install Easy Installer on Mac.

I was happy about it, only: the installation does not even start and none of the troubleshootings are the reason. Anyway, just nothing happens!

Download source: Easy Installer beta for MacOS

Similar experience?
Thanks a lot!

My equipment:
MacBook Air 2017
MacOS: 12.6.1


last I installed easyinstaller on mac 2 weeks ago the installer window to copy over on desktop to install did this in the background and I too thought nothing is happening (not using a Mac much so I was dumbfounded until I realized this)

but yeah I had to go through all the steps outlined in the docs as in allowing the source etc … then minimize all windows to copy it over…

Thanks for your answer!

I closed everything and looked for a window in the background: but, nothing.

  • no Rosetta popup
  • under Security_General no Java is to be found
  • under Security_Privacy the install process cannot be enabled

Unfortunately it does not work.
Does anyone else have an idea?


Worked here… up to a certain point.
First, you need to copy the app from the downloads folder to the desktop (otherwise the app may run, but it will fail to install /e/)
Also, you need to allow the app to run on OSX (by tweaking the security settings in the system preferences).
In this manner, I was indeed able to install /e/ on my device. BUT the installation is not perfect : Easyinstaller did not relock the boot loader after installation, and I am unsure what to do about this …
(MacOx 10.15.7 on imac 2013)

It’s far from perfect, but it works (for now).

After clicking on the dmg file, - nothing happens.
But, in Finder > Places (where all external storage media are shown) a “place” does appear: “Install”.

There double clicks then open the EasyInstaller, after I have shared it under Security-General and under Security-Privacy Java. The two popups then appear on their own.

Thank you all for the help!

Well after discovering that putting the app into the Applications Folder is the way to get it to work, I found it very easy to use. Certainly perfectly usable for the layperson.

I tried a Samsung S7 I was given. Great to have an Android 8 (max) unit running 10.

I am going to see the effect of updating the e/OS versions on my data, then pass it over to someone who needs a replacement phone.

1 Like


I started following directions on the Easy Installer page.
When I try and verify the sha256sum of the downloaded dmg I fail:

$ cat EasyInstaller.dmg.sha256sum 
42c8db2676860a2e0a004909b972a5e7c41f439096803f7a4ff7b24571fc47e1  EasyInstaller.dmg
$ shasum -a 256 EasyInstaller.dmg
ed584f51a4b2a856b483623314cc6d826483d89b3212ec8ca80ac5720eb92eea  EasyInstaller.dmg

If we are to be serious about security, as I thought the e-os team was, it’s not a good idea to proceed with the installation. Anyone can explain this mismatch?

1 Like

automation should upload the .dmg build and sha256 at the same time - https://gitlab.e.foundation/e/devices/easy-installer/-/commit/28c8a80572d6ad4672af8cb72d76e40d93b16f79

Something went wrong, write a message to helpdesk@murena.com to create at ticket.

Maybe ask them to setup a /security.txt too, very useful at times