Easy Installer + OnePlus Nord

Hi everyone, the Smartphone Selector page lists the OnePlus Nord AC2003 as supported by the Easy Installer. I tried it, but after the first few steps I get the message “Your AC2003 is not yet supported by /e/ OS”! Am I missing something?

I think it is a similar problem like in this case with one of the Samsung models:

According to Try the Easy Installer beta the OnePlus Nord is supported with codename “avicii” and according to your quoted message, yours is a codename “AC2003”.

I don’t know enough about OnePlus devices,but Info about OnePlus Nord - avicii shows “AC2003(EU)” as supported so I assume there are other “AC2003” with something else than “EU”. And the easiest explanation could be that you have a non-EU version of the Nord?!?

If you could post the logs as described in the above topic it might help to understand the situation.

2 Likes

Thanks for the response, the model AC2003 is indeed shown as supported by the Easy Installer. EU in brackets means that the model AC2003 is soldin Europe. Other regions have a different model name (eg AC2001 for India, which is also supported). I have uploaded my log here: hastebin

I see no mention of avicii in the log; please can you try to confirm the device codename [HOWTO] Find device codename, or as mentioned in Post #2 you could install Download 1.89 (APK) | AIDA64.

Probably your device is Info about OnePlus Nord - avicii, but I think it is wise to double check in this way.

The adb command in a windows shell just returns “Nord”.

These are the detailed device infos from the log as detected by the installer

device product:Nord_EEA model:AC2003 device:Nord transport_id:1

Relevant is the “device” value which is “Nord” as you said.

A later line in the log shows which file is going to be loaded for the installation steps

loadYaml(/yaml/Nord_flash.yml)

Looking at the source code at src/main/resources/yaml · master · e / devices / Easy Installer · GitLab the filename doesn’t match: there it’s called OnePlusNord_flash.yml and not Nord_flash.yml.

Looks like a fix is already under way: Allows the detection of On official ROM and on /e/ rom (!193) · Merge requests · e / devices / Easy Installer · GitLab

If I rename the OnePlusNord_,yml files in the source to Nord_.yml and run with gradlew will it work?
Or I should wait for the next release 0.18?

Yes, good point. Looking at the change I’d say it’s safe to assume that renaming the two files to just “Nord*” should succeed as a workaround.