Easy Installer Samsung Galaxy S9 no Teamwin

Hi @janoschkus welcome to the /e/ forum and thank you for your contribution. Reviewing your error @LTR I have seen I had to make a small correction to my earlier reply to you. I did a little more research on libusb which I included in this post

1 Like

@janoschkus Thanks for sharing that info. I tried a USB port on the back of the computer this time around and although it still failed i think things may have changed a little as the errors in the logs are different this time.

@aibd As requested the new logs have been uploaded here:


  • ERROR: Failed to detect compatible download-mode device.
  • (debug)libusb: error [init_device] device ‘USB\VID_04E8&PID_6860\2330667C8C0C7ECE’ is no longer connected!
  • ERROR: Failed to receive session end confirmation!
    • 2022-04-27 09:24:50,072 WARN [JavaFX Application Thread] e.e.i.u.UiUtils [null:-1] loadImage(), image’s file name = , error = java.lang.NullPointerException: Input stream must not be null
  • 2022-04-27 09:24:50,083 INFO [Thread-15] e.e.i.t.CommandRunnerService [null:-1] Command Task call()
  • 2022-04-27 09:24:50,084 DEBUG [Thread-15] e.e.i.t.CommandRunnerService [null:-1] updateParameters(), Parameters = {device_id=2330667c8c0c7ece, adb_folder_path=C:\Program Files\easy-installer\bin\adb}
  • 2022-04-27 09:24:50,084 DEBUG [Thread-15] e.e.i.m.Command [null:-1] command: [cmd.exe, /c, ““C:\Program Files\easy-installer\bin\scripts\wait-recovery.bat”, “2330667c8c0c7ece”, “C:\Program Files\easy-installer\bin\adb””]
  • 2022-04-27 09:24:50,095 INFO [Thread-15] e.e.i.m.Command [null:-1] Command’s Process started

Also, to confirm, do the drivers need to be installed manually if everything is working fine such as files can be transferred to and from the phone in Windows?

Just to confirm, once in Download Mode and the transfer appears to have been completed by the installer i should HOLD DOWN “Volume down + Home/Bixby + Power” and the instant the phone is off IMMEDIATELY PRESS AND HOLD “Volume up + Home/Bixby + Power” and hold down ONGOING until i see TEAMWIN? If so, i have been doing that but seeing a white Android with an error flash across the screen super briefly and then the standard Samsung boot/recovery options.

Any further advice would be appreciated. I would really like to get this sorted out once and for all. I’ve rooted and flashed phones in years past but never had issues like this before. Are there any other options other than doing this manually without the Easy Installer?

Hi @LTR I commend your patience.

I think you probably mastered the finger presses. I think this is still an Easy Installer problem. Here is my extract from your log.

OS name = Windows 10
language = en, country = AU
adb devices
Command's Process started
List of devices attached
2330edit-alt7ece       device product:starltexx model:SM_G960F device:starlte transport_id:2
C:\Program Files\easy-installer>"C:\Program Files\easy-installer\bin\heimdall" detect  1>nul 
ERROR: Failed to detect compatible download-mode device.
C:\Program Files\easy-installer>if errorLevel 1 (
echo not found  
ping -n 2 -w 1000  1>NUL  
 goto :heimdall_detect 
)  else (echo succeed ) 
not found

C:\Program Files\easy-installer>"C:\Program Files\easy-installer\bin\heimdall" detect  1>nul 
ERROR: Failed to detect compatible download-mode device.
Uploading RECOVERY
... 97%...99%...100%
RECOVERY upload successful
Ending session...
ERROR: Failed to receive session end confirmation!

It is mysterious; success followed by fail looks like fail.

It looks very much like a communication error !

One of the jobs of libusb is to be an intermediary between multiple specifications and configurations used by multiple manufacturers. However libusb did not complain this time ! adb is seen to connect fine. My naive interpretation is that you have an unlucky combination of hardware.

In packaging Easy Installer I guess other intermediaries are involved which may be responsible. I am sorry not to be more useful. (I can hardly bring myself to say … try a different PC)

Trying to answer a question about Windows drivers gives me the creeps … Here is an image of Windows device manager

If you try to run Easy Installer with Windows device manager open alongside do you see any problem device? The implication in this case would be that you require a driver. There are those on the web who say it is fine to load random drivers for good luck; Windows will only access them if they are a match for your problem – I am naturally over-cautious. You do not have to install an “unknown” driver, you can simply offer a driver from external media like USB stick.

Yes you do have options. Are you aware of this

Edit, @LTR (I have little Windows experience, but) should you be thinking further about drivers and Zadig mentioned in the linked post, I noticed that LineageOS wiki points to this as a source of guidance https://github.com/pbatard/libwdi/wiki/Zadig.

1 Like

Hi @LTR and @janoschkus,
Do you have “RMM State: Prenormal” on the download screen?
If yes, your issue is probably linked to the latest Samsung security patch on S9/S9+ and maybe newer models. I’m looking into it for more than 2 weeks now, here is the link to my post in the forum if you would like to follow my research.

@aibd Thanks for your in depth explanation and help, it is much appreciated. I cannot see any issues with the drivers and none of them are showing any errors or missing drivers.

@Anonymous I didn’t see anything related to “RMM State:Prenormal”. Did you manage to find a fix with your problem?

I decided to wait for a while until a newer version of the easy installer and E OS came out and have just tested again and now have updated results.

I followed the instructions over from the beginning and all appears normal visually until i reach the Recovery Screen. The Recovery Screen i see is the stock standard Android one, NOT the E Recovery version as indicated in the instructions. Does this matter?

The standard Recovery Screen i see still includes the option to “Factory Reset” (the next step in the E installation instructions) as well as the option to “Apply Update From ADB” (a further step in the E installation instructions).

Should i continue with these steps despite it being in the stock standard Android Recovery???

Yes it matters a lot. When we flash a custom ROM we must flash a custom Recovery first. While Samsung/Android is in charge you cannot flash /e/.

I notice the first thing I said to you was Post #2. This would be the first thing to rule out.

Yeah i figured it did matter but was trying to be hopeful…

Ok so i have gone through the Easy Installers steps again and all the options it recommends like USB Debugging, USB File Transfer Mode, Developer Mode and OEM Unlock are already enabled so i turn off the phone in the standard fashion. Is all this correct so far?

I then simultaneously press and hold down the Power, Volume Down and Bixby buttons and the phone enters Download Mode. I then release all 3 buttons and press Volume Up to continue. The Easy Installer does it’s thing in a command prompt window which eventually goes away and i then turn off the phone by simultaneously pressing and holding down the Power, Volume Down and Bixby buttons until the phone turns off completely. Is this all correct so far?

Then i simultaneously press and hold down the Power, Volume Up and Bixby and continue to hold the buttons down even after the Samsung screen loads and continue to do so expecting the TeamWin based recovery menu to appear. However it never appears and instead i briefly see a white Android with a (red?) exclamation mark flash across the screen super fast and then the stock standard Android recovery menu.

Please advise if any of the above steps are incorrect.

Well I think it is correct, I prefer the wording

  • the instant the screen goes black (black as in off) and before the device starts to restart
  • instantly change the finger press to Volume up + Bixby/Home + Power.

If you did get that right, then you have a different issue that the custom recovery failed to flash. (This might also be indicated “a (red?) exclamation mark flash across the screen”)

As you are trying a different version of Easy Installer it might be worth sharing a new log – my original wording suggested I was not totally sure of my interpretation of the log (but I have not revisited it today!) At the time I noted usb cable, this has to include the whole chain: cable, usb hubs (avoid) and usb secondary ports in the PC (avoid front ports when they are not wired direct to the motherboard – generally the back usb ports are direct wired).

I mentioned that using a Samsung “original” cable is no guarantee of success.

I followed your expanded steps precisely but it still shows the white Android with the red exclamation mark and loads the default Android recovery menu rather than TeamWin.

I have tried different cables and different USB ports on the desktop (including USB3 on the rear) and nothing seems to make this work. I also tried running the installer as Administrator and that didn’t make a difference either.

The log from my most recent attempt a few minutes ago is here:
haste[DOT]tchncs[DOT]de[FORWARD SLASH]olarefoyog[DOT]yaml


I am using Easy Installer v0.15.0 on Windows 10 x64 on an older Acer desktop.

I really hope you can help as this is getting ridiculous and i am almost entirely out of options…

Thank you for sharing the log. You might hold on for a second opinion but this is my highly selective cut from your log (idk why pasting the log failed for you!) hastebin

2022-08-20 21:32:46,846 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)C:\Program Files\easy-installer>"C:\Program Files\easy-installer\bin\heimdall" flash --RECOVERY "C:\Users\TV\AppData\Local\easy-installer\sources\starlte\recovery-e-latest-q-starlte.img" --no-reboot 

2022-08-20 21:32:50,948 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)Downloading device's PIT file...
2022-08-20 21:32:51,072 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)ERROR: Failed to receive end PIT file transfer verification!
2022-08-20 21:32:51,072 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)ERROR: Failed to download PIT file!
2022-08-20 21:32:51,073 DEBUG [Thread-10] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)Ending session...

2022-08-20 21:32:51,478 DEBUG [Thread-11] e.e.i.t.CommandExecutionTask [null:-1] 
  (debug)"waiting for recovery"

I interpret that as a fail. The Recovery never transferred as I see.

Btw the Samsung cable definitely doesn’t work for this. The Easy Installer couldn’t detect the phone when using the Samsung cable so i had to use a different one… as you suggested previously.

1 Like

Thanks for that… it does seem like a fail indeed. Do you think it’s possible the cable i am using is to blame? It’s relatively new and not known to play up though.

Is there a cable for sale somewhere online (ebay perhaps) which is guaranteed to work for this process?

The cable can be a bit trial and error, your log does show many “attempts” before proper contact but this is seen quite frequently.

If you were to try the “manual” instructions Install /e/ on a Samsung Galaxy S9 - “starlte” you might find this guide useful [HOWTO] Install /e/ on a Samsung smartphone with Windows easily. (It seems I mentioned both links already, maybe not to you though!).

Please don’t rush to start, but you will get a chance to test the cable with Odin, when you get to the point, so any weakness in the cable might be revealed at that stage.

Prenormal was already mentioned, if this was an issue it will show on the Download mode (aka Odin mode) screen. I think you are already aware that this would be a blocker.

Ok, thanks for the info. I will give have to try the manual instructions another day and see what happens from there. I expect any errors in the manual process will be far more obvious than with the somewhat automated Easy Installer.

Thanks for all your help and feedback. I really appreciate your time and effort. Thank you.

1 Like

Did you finally manage to finish successfuly the install?
I am stuck in a similar situation an would apreciate your feed if anyway you found how to solve it.

Just as a cross reference to others; you have reported your install problem solved apparently due to KG : Prenormal here Installation of e/OS fails on Samsung S9 DualSim - #7 by Arken. Thanks.

No, unfortunately not. I will need to attempt to try the manual installation instructions (Install /e/ on a Samsung Galaxy S9 - “starlte” for my particular model) sometime when i have the time and patience. The Easy Installer attempts to automate the use of the commandline tools and steps which would have otherwise been the only way to install a non standard Android version like /e/

If you install manually yourself please let me know how you go.


My problem isn’t solved quite yet but i will give the manual installation a go sometime and see if that helps. Thanks for the info regarding the prenormal state… i will check for that next time i go through the steps.

When looking through the manual steps i need to select the correct device. I have a single sim Galaxy S9 (SM-G960F) but the only available options for this model state “dual sim” in the Sims Slots column. However, when i hover over the words Galaxy S9 the mouse over popup states:
SM-G960F (single sim???)
SM-G960F/DS (presumably the DS is dual sim???)

Is this suitable for my single sim SM-G960F? There’s no separate single sim only option i can see

1 Like

I think so…


I think so…