Easy-Installer + Samsung S9+

Hi All… @manoj

Has anyone used the Easy-Installer recently, and can advise what OS version it installs… ? I used it 18 months ago on a new S9+ and it installed A 8 / Oreo. It then was a near impossible task to get it to A10 / Q.

So… has Easy-Installer been updated so it auto installs a newer OS like 9/P or 10/Q on a new S9+ today… ?

Trying to help family get onto eOS, but I find the manual installs to hard to do as there is no clear newbie guides, so Easy-Installer seems like the only option, but NOT if it keeps the phone on A8/O.

Any comments very welcome…

Thanks IT VAULT :slight_smile:

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

will install Q on both starlte and star2lte (S9 and S9+)

Hi @tcecyk Thx for the reply :slight_smile:

So… just to CHECK first… if it’s a new sealed box S9+ (so I assume it will be on A 8.1… I don’t have to update it to Q… just go from Boxed 8.1 to Easy-Installer and I get Q… ?

Thanks very much for the clarification…


haven’t flashed S9/S9+ - I see there were Android 10 releases for both. Support ended in March 2022 with the latest update. So I guess you should upgrade to A10 then before flashing.

Ok thank you! I’ll give it a try :slight_smile:

1 Like

Hi All + @tcecyk

EDIT: Ok… so it seems the problem is “RMM Prenormal” issue, which I can see in the small text at the top of the blue phone screen. ARE THERE SOLUTIONS… ?


Easy Installer Not Installing (yet) and I would sure appreciate any comments :slight_smile:

I have an S9 (NOT +) I am trying to install eOS on. I have updated it to A10 from A8, and installed all other updates it wanted to do.

USING: MacBook Pro + macOS (Ventura v. 13 Latest)
Then I tried running Easy Installer v0.16 (latest version), and I do all the following:

  • Use Premium Cable

  • Enable Dev Mode = SUCCESS

  • Enable USB Debug = SUCCESS

  • Enable File Trans = SUCCESS

  • Remove ALL Accounts = NOT AN OPTION ANYMORE >>> There are NO accounts showing, which may be because I didnt set up one… ? Just did s/w updates so far.

  • SM-G96F is Compatible with eOS = SUCCESS

  • Download latest eOS = SUCCESS

  • Your Are Now Ready To Install :slight_smile:

  • Disable Auto Update System = SUCCESS

  • Disable Auto Download over WiFi >>> This does NOT exist in my setting as shown in Easy Installer. It is NOT there to turn off… So I just ignore and continue… ?

  • So I restart my phone as Easy Installer says to…

  • Unlock OEM = SUCCESS

  • Do Power + Bixby + Vol Down = Blue Screen for D/Load mode = SUCCESS

  • Accept Warning + Press Vol Up

  • Recovery Installation FAILS and phone has RED TEXT:
    “Only Official Release Binaries are allowed to be Flashed”

How do I get passed this… ???

Thanks for any help guys… Dont know what to do next…

IT VAULT / David :slight_smile:

I have made a collection of clues in this thread Know your hardware - Samsung #KG or RMM State Prenormal

As it is brand new it may be as simple as using it for a time with SIM and wifi !

Thanks for that… I will give this a try for a day or two and report back the results.

thanks @aibd, that was educational… if my reading of thecustomdroid.com link is proper, it’s sufficient to wait 7 days until the mode leaves “prenormal” and you’d be free to flash the bootloader?

… you will be forced to experience the 7 days lock period for the first time. So, if the OEM Unlock toggle is missing on your Samsung Galaxy, you must have a SIM card inserted, connected to the network, and must not reboot your phone for straight 7 Days (168 Hours).

@ITVAULT I haven’t seen the easy-installer instructions. Did you execute a heimdal oem unlock, or did you too toggle the OEM Unlock from within the developer options in the booted Android Settings?

Yes… :slight_smile:

I believe I did it all correctly just from within Dev Options… then spotted this RMM Prenormal state…

I thought his comments re the 7 Days was to get the OEM Unlock toggle available, which I already have available. I have now inserted the SIM, and have been using the phone for a few calls and texts, web browser etc… and will see if the state changes after it “talks” to Samsung. No wonder we want to get off big tech :slight_smile:

Learning now @ITVAULT that you are in Australia, I tried to search your Region Samsung Support from this link Product Help & Support | Samsung Australia. I have not been able to confirm or deny from the UK that Galaxy 9 (+) is officially sold; I suggest you try with a “local” login. (To be pedantic I guess your SM-G96F Post #6 is your typo ?)

The Region Lock article I wrote contains an image the EU “seal” which features on the packaging. I would expect you to have seen the “locally appropriate” Region Lock notification with the device.

I think the majority of users get through prenormal successfully. When reading on the subject and following a line of positive clues one has to look for an exact match with what you experience. I only present this negative view at this point in case you might consider a potential return of the device if in fact it should turn out to be a “grey import”.

In short, while “waiting it out” can you satisfy yourself that Samsung intended the device to be used in your Region ?

sorry, I wrote instructions to use TWRP because in my case it worked to solve Easy Installer problems.
Now I realize maybe you says all is solved. Other case, see the editions of this message.

an XSA firmware exist…

1 Like

@Eudald Thanks for your reply. Just to clarify, did you also have the “RMM Prenormal” issue as I do… ?

I didn’t think that using Odin + TWRP would make any difference if I have the “RMM Prenormal” issue as others have also posted that Odin reports the “RMM Prenormal” issue if you have it… ?


yes, also I had difficulties to get the OEM unlock. I have seen a lot of videos and info playing with the date:

although no success only with that.

Finally I solved the problem by manually setting the date to some years ago and then burning the stock Android 10 Samsung with Odin. In that way it showed the unlock notice. And after that, using TWRP to burn /e/ like I wrote you.

A little nightmare, really!. You can try this way if you want. Just be careful to select a right A10 firmware in sammobile.com, according your country and operator.

Hope you can have luck