Easy Installer stuck on downloading screen - Samsung S7

The command line instructions

Thanks. That’s beyond my abilities.
I think I’ll give up at this point.
Thanks for the pointers.

Hmmm … you got all the the ideas in place … not really “beyond” …

stand by … for a while.

1 Like

Give it a try Valerie, you could be surprised by your unknown abilities :wink:


Just use the “recovery-e” instead of TWRP [HOWTO] Installer /e/ sur un smartphone Samsung avec Windows facilement
. https://doc.e.foundation/devices/hero2lte/install

Edited @ValerieD, I could reproduce your experience using the two commands

wget https://images.ecloud.global/stable/herolte/e-latest-q-herolte.zip
wget https://images.ecloud.global/stable/herolte/e-latest-q-herolte.zip.sha256sum


$ cat e-latest-q-herolte.zip.sha256sum
1a7b7e9edc1f59893137562eec9edbfb5ba573c70e24178ebb30017be02ab754  e-latest-q-herolte.zip
$ sha256sum e-latest-q-herolte.zip
073e9f10f05e4f136dd5c4e435f6eb6c0d7b3e7a931d3ca3128bb81a5cb40e7a  e-latest-q-herolte.zip

The valid sha256sum file seems e-1.17-q-20231109350746-stable-herolte.zip.sha256sum

$ cat e-1.17-q-20231109350746-stable-herolte.zip.sha256sum
073e9f10f05e4f136dd5c4e435f6eb6c0d7b3e7a931d3ca3128bb81a5cb40e7a  e-1.17-q-20231109350746-stable-herolte.zip

Perhaps @Phie might check this one?

or in the meantime perhaps try the method described here

Bonjour Piero,
J’ai réessayé, mais rien n’a changé, je reste bloquée au téléchargement.
J’ai regardé votre tuto détaillé, je vais peut-être essayer, je suis absolument nulle donc ça m’effraye un peu mais vous avez l’air confiant…
Par contre que voulez-vous dire par "just use recovery-e instead of TWRP?


I found the correct recovery file and replaced it and it seems to be working! My phone has a blue-green screen that says downloading and my computer says it’s installing. It’s taking a long time though so fingers crossed… is that normal?

If that fails, I have found an old Samsung S5, I’ll give the manual version Piero suggested a go.
Thanks a lot

It is very fast (less than 1 minute) but you won’t be notified, unplug the device, and pay attention to the finger’s action timing on the buttons…

The bootloader is already open on that generation.

Bonjour PIero,
Vous me conseillez de débrancher et démarrer mon GSM alors que l’easyinstaller est en cours? Le téléphone affiche toujours Downloading, l’ordi toujours Recovery Installation. J’ai aussi un écran de commande noir qui dit Extracting driver files…
Installing driver(s)…
depuis une heure environ

Hi Piero,
Do you recommend I unplug my phone and start it while the easyinstaller is still working? The phone still says downloading, the easyinstaller screen ont he computer says Recovery installation, and the black command screen says: Extracting driver files…
Installing driver(s)…
no change for about an hour now.

Well I’ve managed the download but when I try and reboot in recovery mode, it reboots with Android recovery. I’m trying to be quick with my fingers but no success. Any additional recommendations?

The log is likely very long, very many repeats of "waiting for … "… but did that ever resolve in the log? I am guessing not; that is the Recovery file never uploaded correctly.

Maybe there still was a driver issue … or try with a different cable or try different USB port on the PC, aim to use a USB port soldered to the motherboard, typically at the back.

All normal except that I would expect the Easy Installer screen to roll over to the next episode, telling you to boot into your new Recovery.

If you run Easy Installer again, have open a Device manager window. As the boot into Download mode happens check that the phone has not become a " :warning: Problem device" within Device manager. If it does then run Windows update while the device is connected in Download mode.

J’ai finalement réussi sur le S5 sans trop de difficultés. Sur le S7, j’ai d’abord eu les messages d’erreur rouge sur Teamwin et j’ai eu les soucis rapportés ici Stuck on Teamwin Logo - #33 by rfalc
j’ai heureusement su remettre la version d’usine et réessayer. J’ai utilisé le format suggéré dans le poste mentionné et ça a marché. Je bloque maintenant à l’étape qui devriat être la plus simple, à savoir de copier le fichier zip de l’os sur le téléphone!
Merci en tout cas pour votre tuto, si vous pouviez juste modifier le paragraphe sur le reformattage des données, je pense que ça pourrait en aider d’autres.
Bien cordialement

I managed to get tot he next stage where it explains how to reboot your phone, but it rebooted to Android recovery. I tried several times, trying to be quick with my fingers as suggested but no luck. I have since used Piero’s tutorial and successfully installed /e/os to an old S5. I’m currently still a bit stuck with the S7. First, there was an issue with the reformatting he suggested (resolved by reinstalling stock rom then trying again and picking a different format as per this thread Stuck on Teamwin Logo - #33 by rfalc). I’m not having the stupidest issue: I can’t seem to copy the /e/os file to the phone using the usb cable (I have tried several).
I will keep trying. So far this has taken me a full day, this is not for the faint hearted, even with you guys offering muc-appreciated support).

gah just had to right-click on the zip file, go to properties and unblock.
I’ve got /e/os, thanks to the community!
That was hard work…

1 Like

Congratulations Valerie!
If I where you, I would be proud of myself ^^

1 Like

Just FYI I linked this to the gitlab issue:

If any of you can comment there, please do.

1 Like

If you’re having the same problem I had, this post suggested by Piero ([HOWTO] Installer /e/ sur un smartphone Samsung avec Windows facilement) enabled me to install /e/os on my samsung S7 and S5, with the following modifications:

  • both: step 8.3 the text mentions Internal Storage and not the image, but I clicked on Internal Storage as per text
  • S5 no need to unlock OEM (the option was not available and I saw someone mention that some older versions had it by default, so gave it a shot and had no problems)
  • S7 step 8.A4 with red error messages: DO NOT select exFAT, that got my phone stuck. I had to turn it off ( Press and hold Volume Down and the Power or Side key for about 7 seconds until the device restarts), then find the stock ROM on sammobile site, flash that, then retry, this time selecting EXT2 instead of exFAT as per this thread Stuck on Teamwin Logo - #34 by rfalc)
    step 8B3, I couldn’t copy the file, tried different usb cables, no joy. Right-click properties, there was a box to unblock content coming from another computer which enabled me to copy the file.
    Best of luck…