Ecloud Selfhosting (Beta)

Ecloud Selfhosting (Beta)
I got a VPS and a domain. However after the installation it says:

[mydomain] not resolving to ip

Could someone post a video step by step instruction. Some of the VPS do not support more than 1 line of reverse DNS, and its almost impossible to add any additional reverse dns records.
A step by step would be extremely helpful.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

A video, really? :flushed:

This is a 2-steps configuration (replace yourdomain.tld with your real domain name):

  • on your VPS provider, IP V4 address is to be set to mail.yourdomain.tld
  • on your DNS domain provider, add:
    – type A record yourdomain.tld (often this is a @ A record) to your VPS IP V4 address
    – type A record mail.yourdomain.tld to your VPS IP V4 address
    – type MX record to mail.yourdomain.tld (priority 10, may display as @ MX)
    – type CNAME records autoconfig.yourdomain.tld, autodiscover.yourdomain.tld, spam.yourdomain.tld, welcome.yourdomain.tld, to mail.yourdomain.tld

Wait 1hour or 2 for propagation to do it’s magic (you can check from your VPS shell with dig or nslookup commands, against mail.yourdomain.tld).
That’s all !

If I understand your post, you’ve done the VPS part (reverse record), now you have to go to your DNS provider management interface and add all the forward records.

As an example:

@ 1800 IN A
mail 1800 IN A
@ 86400 IN MX 10
autoconfig 86400 IN CNAME
autodiscover 86400 IN CNAME
spam 86400 IN CNAME
welcome 86400 IN CNAME
@ 86400 IN TXT v=spf1 -all
mail._domainkey 1800 IN TXT v=DKIM1; k=rsa; p=some_very_long_key
_dmarc 86400 IN TXT v=DMARC1; p=reject;;; fo=0; adkim=s; aspf=s; pct=100; rf=afrf; sp=reject
_smtp._tls 86400 IN TXT v=TLSRPTv1;

Note: this setup is not specific to ecloud selfhosting, you may find plenty of tutorials around…

I did set the reverse dns settings on VPS to point VPS IP to the domain, and used this to confirm that DNS reverse is set up. Yet, still when you go to the webpage nothing happens

when setting up: it asks about

mail domain

alternative mail domain

Where does the prefix gets added to? first or second?

Everything looks fine from here.
Maybe you didn’t wait enough? :wink:

Let’s try to reproduce the script.

dig NS +short | head -n 1

=> OK, we got at least one authoritative DNS server for your domain :slight_smile:

dig +short

=> OK, the authoritative DNS got an IP address for :slight_smile:

nslookup x.x.x.x | grep "name ="      name =

=> OK, we got a PTR reverse record :slight_smile:

As you have only one domain, please leave alternative empty.