Enabling 2FA causes all sync to fail

(Using FP3)

Enabling two factor auth. wit TOTP causes all sync features on my /e/ OS phone to fail. I even could not login in on a fresh install without removing 2FA.

Deactivating TOTP as 2FA instantly fixes everything.

But for increased security for my account, i’d rather use 2FA. Are there workarounds for this issue?

Best Regards,

Scytale

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

3 Likes

I also just activated 2FA and could not fix the sync issue. Only solution was to deactivate 2FA again :confused:

Same here, using /e/ on a galaxy s9+. Is it possible to set up an app password or something similar?

To enable your phone to sync when 2FA is enabled on your e-cloud account set up an app password in your ecloud>Settings>Security>Devices+Sessions

Enter the app password in /e/>Settings>Accounts>/e/>AccountSettings>GearWheel>Password

More details at https://docs.nextcloud.com/server/latest/user_manual/zh_CN/session_management.html

4 Likes

Thank you very much for this instructions. It works :slight_smile:

edit:
In addition to your guide, there’s an fairly new /e/ OS guide:

1 Like