Encryption not working on galaxy tab S2

Hi there,

I tried to encrypt my galaxy tab S2 (SM-T813, /e/ 0.19-2021): charged the battery, plugged in the usb cable as requested, and hit the encryption button : the screen turned black with de android robot showing up for a couple of seconds. Then back to the “login” screen (asking for a pin number).
In the settings, it says that the tablet is not encrypted.

Any thoughts ?



Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I look into all “cannot encrypt” posts here, they’re not all the same but I think the galaxy-tab-s2 uses full disk encryption with a crypto footer. What it is most likely missing is a bit of space at the end of the userdata partition for the key that encrypts the partition (thus “cryptofooter”).

Some versions of twrp seem know the partition size offsets needed for this, the thread LineageOS on Samsung Galaxy Tab S2 does not encrypt : LineageOS says it’s twrp 3.2.3 you could test. Give it a try?

One can do it also without twrp all in command line (with mkfs.f2fs or mkfs.ext4 depending on device and calculation the target size).

1 Like

Thanks a lot for the quick reply !
I’ll give it a go and will keep you posted.




Sorry it took me so long to give it a try.
Thanks a lot mate, it actually worked !!!

I downgraded twrp to 3.2.3 using heimdall. Fine.
First time I booted in recovery and formated data, then rebooted, reset /e/ and tried to encrypt : it failed (green robot for a couple of seconds, then power off. Rebooted, went to settings : tablet was “not encrypted”).

Second time, I formated /data and resized data. Rebooted, reset /e/ and set up a pin number to unlock screen and finally encrypted. Same thing (green robot for a couple of seconds and power off). But this time it worked : it asked for a pin before running android when I rebooted.

Thanks again tcecyk !

1 Like