Error 7 when trying to install /e/ ROM on a Galaxy S9+ (modifing "updater-script" doesn't work)

Hi! I also have this “Error 7” message trying to install /e/ on my Samsung Galaxy S9+ (codename: star2lte). I have tried the soltution modifing the “updater-script” file (directly in the ziped image) and deleting the “assert” lines. But unfortunately it doesn’t work. Please find below the (unmodified) code in the updater-script file. I tried to delete the first 4 lines including the first 2 semicolons, then including “ifelse(is_mounted(”/vendor"), unmount("/vendor"));", then the whole section with the error message. Nothing worked.

assert(getprop(“ro.product.device”) == “star2ltexx” || getprop(“ro.build.product”) == “star2ltexx” ||
getprop(“ro.product.device”) == “star2lteks” || getprop(“ro.build.product”) == “star2lteks” ||
getprop(“ro.product.device”) == “star2lte” || getprop(“ro.build.product”) == “star2lte” || abort(“E3004: This package is for device: star2ltexx,star2lteks,star2lte; this device is " + getprop(“ro.product.device”) + “.”););
ifelse(is_mounted(”/vendor"), unmount("/vendor"));
mount(“ext4”, “EMMC”, “/dev/block/platform/11120000.ufs/by-name/VENDOR”, “/vendor”);
ifelse(file_getprop("/vendor/build.prop",“ro.vendor.build.date.utc”) != “1536890700”,
unmount("/vendor");
ui_print(" “);
ui_print(”=============================================");
ui_print("=============================================");
ui_print(" ERROR: “);
ui_print(” Vendor image on the device “);
ui_print(” is NOT compatible “);
ui_print(” Expected version: 27_ARI9 “);
ui_print(” You can download from is.gd/omexok “);
ui_print(”=============================================");
ui_print("============NO CHANGE HAS BEEN MADE==========");
abort(" “););
unmount(”/vendor");
ui_print(“Target: samsung/lineage_star2lte/star2lte:8.1.0/OPM7.181205.001/6c208ec4f9:userdebug/dev-keys”);
ifelse(is_mounted("/system"), unmount("/system"));
package_extract_dir(“install”, “/tmp/install”);
set_metadata_recursive("/tmp/install", “uid”, 0, “gid”, 0, “dmode”, 0755, “fmode”, 0644);
set_metadata_recursive("/tmp/install/bin", “uid”, 0, “gid”, 0, “dmode”, 0755, “fmode”, 0755);
mount(“ext4”, “EMMC”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”, “/system”, “”);
run_program("/tmp/install/bin/backuptool.sh", “backup”);
unmount("/system");
show_progress(0.750000, 0);
ui_print(“Patching system image unconditionally…”);
block_image_update("/dev/block/platform/11120000.ufs/by-name/SYSTEM", package_extract_file(“system.transfer.list”), “system.new.dat.br”, “system.patch.dat”) ||
abort(“E1001: Failed to update system image.”);
run_program("/sbin/e2fsck", “-fy”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”);
run_program("/sbin/resize2fs", “/dev/block/platform/11120000.ufs/by-name/SYSTEM”);
run_program("/sbin/e2fsck", “-fy”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”);
show_progress(0.020000, 10);
mount(“ext4”, “EMMC”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”, “/system”, “”);
run_program("/tmp/install/bin/backuptool.sh", “restore”);
unmount("/system");
show_progress(0.050000, 5);
package_extract_file(“boot.img”, “/dev/block/platform/11120000.ufs/by-name/BOOT”);
show_progress(0.200000, 10);
mount(“ext4”, “EMMC”, “/dev/block/platform/11120000.ufs/by-name/SYSTEM”, “/system”);
run_program("/sbin/sed", “-i”, “/exfat/d”, “/system/etc/selinux/plat_sepolicy.cil”);
run_program("/sbin/sed", “-i”, “/sdfat/d”, “/system/etc/selinux/plat_sepolicy.cil”);
unmount("/system");
set_progress(1.000000);

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello, welcome in the forum :slight_smile:

So simplest solution is to use TWRP 3.3.1 instead of 3.4.0.

But some users told they were able to flash normally after one or two reboot in recovery. Turn off your phone (TWRP > Reboot > Turn off) and reboot into recovery again and try. If it doesn’t work, use TWRP 3.3.1.

Hello! Thank you for the quick answer. I have also tried twrp-3.3.1-0 and twrp-3.3.1-1 now but it doesn’t help. Also the rebooting into twrp doesn’t help. The error message stays saying: "Updater process ended with ERROR: 7 … Error installing zip file …
Any other suggestions? Before getting trouble with this Error 7 message I deleted Dalvik / ART Cache, Data, Internal Storage, cache and system as suggested in your tutorial. Should I try to delete more? Best, Victor

What is written after error 7 ? I should be :

E3004: This package is for device: star2ltexx,star2lteks,star2lte; this device is ?????.

It’s weird that it doesn’t start even with TWRP 3.3.1 and after deleting this part :

assert(getprop(“ro.product.device”) == “star2ltexx” || getprop(“ro.build.product”) == “star2ltexx” ||
getprop(“ro.product.device”) == “star2lteks” || getprop(“ro.build.product”) == “star2lteks” ||
getprop(“ro.product.device”) == “star2lte” || getprop(“ro.build.product”) == “star2lte” || 
abort(“E3004: This package is for device: star2ltexx,star2lteks,star2lte; this device is " + getprop(“ro.product.device”) + “.”););

I think this is telling what to do.
For me, it looks like you don’t have the right firmware on your device. What android version was on your device BEFORE you have flashed eOS and which eOS Android version have you tried to flash ? Both the same ??

1 Like

It ist only written:
Updater process ended with ERROR: 7
Error installing zip file ‘/sdcard/e-0.9-o-2020051454222-dev-star2lte.zip’
Updating partition details…
… done

I have exactly deleted thees lines until the 2nd semicolon.

Look here: ifelse(file_getprop("/vendor/build.prop",“ro.vendor.build.date.utc”) != “1536890700”,

Fuck. It’s embarrassing but I don’t know which Android version was on the phone before. I always did the recommended Updates by Samsung so I would assume it should have been Android 10? I tried to install this /e/ version: e-0.9-o-2020051454222-dev-star2lte

So Harvey was right. Deleting the assert part is useless here since it’s not the issue. Looks like your vendors are too old.

Before trying to install /e/, were you on the stock ROM ?

@harvey186 why such an error is possible ? I thought the vendor part was coming with the ROM (in case of a “normal” build and not a GSI).

there are several parts, for example ‘modem’ which isn’t included in a custom rom. That’s why we always writing that the original firmware must fit the eOS rom version.
And he has written, that he was on Android 10 !!! And eOS is Android 8. So it’s a downgrade issue.

He has to downgrade to Samsung Oreo version before flashing eOS Oero

1 Like

Thank you harvey. I didn’t know that I have to have the same Android version on the phone and that downgrading ist not possible. You say that I should downgrade to Samsung Oreo. How do I do that? Where do I get it? Best, Victor

Apparently it’s not possible to downgrade if you installed the stock ROM that are February/March 2020 (don’t remember) security patch. Since you said you updated your phone, that’s probably your case.
(I will try to find a better explanation on the forum, I know there is one)

The solution would be to wait for /e/ to be supported on Android 10 (September/October).

Okay thanks for the information. That’s sad. So I will have to wait until September to join the /e/ community.

Last question: To get a working phone until /e/ supports Android 10 I hope it should be somehow possible to install a samsung android 10 version again?

In the meantime you could use LineageOS (without or with GApps that you need to flash just after having flashed LineageOS if you want to install them for notifications for instance. Pico is a good choice).

But yes it’s possible to reinstall the stock ROM :

  • Select your model and your country,
  • Click on the one you want to download,
  • Click on Join to download and create a dump account,
  • Return to the previous page and the Join to download will be replaced by a Free download (or something similar),
  • Click on it and wait around 1h30 for the download to complete,
  • Unzip the zip file you downloaded,
  • Go to this HOWTO at the “4) Download ODIN” and follow the steps then go to the “6) Install TWRP” part, you don’t need the 5) part,
  • Follow the steps but instead of selecting TWRP, select the file that was inside the zip file you downloaded,
  • You can stop reading once you reach the “WARNING :”,
  • Your phone should start on the stock ROM, wait a few minutes.

You can start by this :

or this :

Thank you for your great and fast help. I’ll try to install LineageOS or go back to the stock ROM and come back in autum when /e/ OS is Android 10 ready.

1 Like