Error code 7 while installing in osprey Moto G 2015

Trying to install in my Moto G 2015.
Install crashes with error code 7
Kindly help me

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi, welcome in the forum :slight_smile:

Try to reboot the device into TWRP (TWRP > Reboot > Recovery) and try again.

If it doesn’t work, use TWRP 3.3.1 instead of 4.0.0.

Thank you for the reply
I am using TWRP 3.4.0
Should I downgrade it to 3.3.1?

give it a try. In some cases it solves this issue


@cy60rg: I had the same problem when I tried sideloading /e/ OS on my ZTE Axon 7. When I looked the error up, I found a thread with the answer over at the XDA forum; I followed the instructions there and it solved the problem for me. (Unfortunately, being a new user, I cannot link to that thread, but search for "[FIX][SOLVED]Status 7 Error with CWM or TWRP Recovery on Rooted Android!".) If downgrading TWRP doesn’t work, I suggest you give it a try if you think the problem described in that thread is the same you are encountering.


Sorry for the late reply,
I have tried downgrading and it worked.
Thank you guys for the support

1 Like