Error installing with Heimdall

Hello all, I’m new here and I hope I’m posting in the right place.
I’m trying to install /e/OS on Samsung Galaxy S9 on Linux, but I’m stuck at a Heimdall error:

$ heimdall print-pit
Heimdall v1.4.2
Initialising connection…
Detecting device…
libusb: error [get_usbfs_fd] libusb couldn’t open USB device /dev/bus/usb/001/006, errno=13
libusb: error [get_usbfs_fd] libusb requires write access to USB device nodes
ERROR: Failed to access device. libusb error: -3

Has anybody encountered this? The phone is OEM-unlocked with USB-debugging on.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

A libusb error would point to USB cable. Also avoid usb hubs; rear ports sometimes better connected than front ports. (Odd that I notice 2 errors.)

I’ve tried two different cables and two different ports (USB-B & USB-C), both rear ports, besides a front one; always the same error.
Could the problem be the phone’s port itself? I’ve tried installing /e/OS on the same phone from a Windows laptop with the Easy Installer but I can’t install TWRP because the moisture alarm goes off and the phone starts vibrating, interrupting the process.

libusb requires write access to USB device nodes
ERROR: Failed to access device. libusb error: -3

might suggest you might benefit from running Heimdall as root.

Does the phone charge fully and correctly? (It is important to have the battery charged to over 60% - but I doubt this is connected.)

One thing I might do next (just to test the usb module in the phone) is to try any other methods of communicating with the device via usb, like adb commands, maybe even simple attempts to copy from or paste to the SD card with a PC file manager?

To test yet another method, TWRP can be installed from a Windows PC using Odin, as here [HOWTO] Install /e/ on a Samsung smartphone with Windows easily

Thanks for the tip, running Heimdall as root did the trick. How come this isn’t stated anywhere!!?? :confounded: :triumph:

1 Like

I have not known Heimdall to require root myself. I would first guess it was a Heimdall install issue.

Without knowing your distro/install method … so, guessing, … on Debian 11 to install Heimdall v1.4.2 (same as yours) I see as a dependency:
libusb-1.0-0 >= 2:1.0.8 … also may be involved plugdev and perhaps udev – all wild guesses !

I’ve created this Howto to help others, but I’m afraid I’m only contributing to the scattering of information and the general ‘noise’ in this site. Info is all over the place here, there should be fewer guidelines and more centralized.