Error message when starting WIFI Map

When starting WIFI Map I get the attached error screen stating “This app cannot run because the environment is not secure and your data may be at risk”.

This happens only since a few weeks, before the app was running fine.

I’m running /e/OS 1.19.1 on a Galaxy S9.

Any ideas?

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

Was anything updated in that timeframe? The OS or a new version of the app?

There have been times when an app will work fine but then a new version comes out with extra checks (for unlocked bootloader, root, or ??).

I cannot find an app with that name. Is that the full name? Provide package name so I can check it out.

The mentioned app is this one:

Possibly/probably the app was updated. However, when searching for the error message I found that a similar message can also be shown by/for other apps on other OS based on Android

My first thought when I saw the error message was that my phone is compromised. I guess that’s not the case but what exactly triggers the error?

Heh, I couldn’t find the app in Aurora Store because I was on an old Amazon tablet when I read your first post. Not compatible. Oops. :grimacing:

Ouch. That app has a serious set of trackers. 14 or 15 according to Aurora Store but a total of 48 individual bits according to App Manager. Anyway…

You didn’t answer if you updated anything (OS or app) since it last worked. App was updated January 26. Was that about the time things went bad or earlier?
Also you’re on 1.19.1 but didn’t mention if R stable or R or T dev. Probably not necessary now given the below results.

Installed the app on a few ROMs without blocking the trackers to see what I get.

crDroid A11, OnePlus 8T: Fail.
/e/OS 1.14-r dev A11, Teracube 2e emerald: Fail.
/e/OS 1.8.1-q dev A10, Essential PH-1: Fail.
LeOS-R GSI A11, Essential PH-1: Fail.
Firehound A8, Moto G5s Plus: Fail.
Havoc OS A9, Moto G5 Plus: Fail.

Last two have Play Store installed.
All are non-Google, unlocked bootloaders, and rooted.

For the first ROM I had LogFox running. It immediately registers a crash dump. Can’t figure out much from it other than entries dealing with Protection stuff.

May need to look for alternatives for that app. Try FOSS first and work your way up to proprietary. Be mindful of those trackers. Scary stuff for an app meant for connecting to public/open Wi-Fi joints.

I believe this error screen has been covered in the forum but I’d have to check around.
Need someone with a locked bootloader to test if that’s the reason or not.

1 Like

Thank you for your research! Probably the app was updated automatically in the background and added a check for a modified OS.

Probably it’ll be best to look for another app with a database of WIFIs world-wide.

To be honest I know nothing about those kind of apps. Maybe because I don’t go anywhere. :worried:

I read the description and it seems to offer a lot (of stuff I would never use or trust) and can purchase huge databases of info.

Tried searching through my F-Droid client for something similar. What little I found are more like wardrivers for finding access points and building data. None do as WiFi Map such as offering logins and whatnot.

Best bet, consult AlternativeTo.

WiFi Map — Free Passwords Alternatives and Similar Apps | AlternativeTo

Oops, that was too broad. Narrowed down to just Android apps.
WiFi Map — Free Passwords Alternatives for Android | AlternativeTo

1 Like

I agree, such VPNs shouldn’t be trusted. I simply used it to get passwords of WIFIs while traveling.

Maybe something like will do the trick.

Thanks again for your work!

This topic was automatically closed after 90 days. New replies are no longer allowed.