Error "sideload connection failed: closed" when installing /e/ to a OnePlus 8T

I’m so close, but am stuck at the final step!

I’m following the instructions as listed on:

I’m on step 7 of “Install /e/ from Recovery”, where I am instructed to “Sideload the /e/ .zip package” using the command:

adb sideload

Prior to the command, I boot the phone to /e/ Recovery and select “Enable ADB”. After confirmation, I type the following command on my (Linux Mint) laptop from the ~/platform-tools directory:

sudo ./adb sideload

Then I get the following error messages:

adb: sideload connection failed: closed
adb: trying pre-KitKat sideload method…
adb: pre-KitKat sideload connection failed: closed

It seems to be a permissions issue of some sort perhaps? Any ideas of how to get this last step to work?

Can you try the tip about USB, below in doc ?

I don’t see what you are referring to.

Tip: Some devices have buggy USB support while in bootloader mode. If fastboot hangs with no output when using commands such as fastboot getvar … , fastboot boot …, fastboot flash … try a different USB port (preferably a USB Type-A 2.0 one) or a USB hub

Instead of sideloading, you can push the zip file in a partition that won’t get flashed, for example /data, using adb push command, then use Install button in TWRP :wink:
Don’t forget to delete the file when /e/ is running.


I actually flashed the OP7T, but hope my experience is also applicable to 8T.
Perhaps a stupid question, but did you follow the steps exactly, namely those (text in () brackets are my comments):

  • 7 - Sideload the /e/ .zip package.

    • On the device in TWRP, (I think it should say e-revocery, not TWRP, but I might be wrong about the 8T recovery version)

      • select “Advanced”, “ADB Sideload”, then swipe to begin sideload.

      • (for 7T it is “Apply update”, “Apply from ADB” instead)

    • On the host machine, in the console , start the sideload of the package by typing

 adb sideload

The error you posted is exactly what I get if I run the adb command without starting the sideload in recovery first.
BTW, is the 8T recovery really TWRP, or does it have the /e/ logo? I think the docs might be slightly outdated

Did not worked in the slighest,
i tried with eassy installer and with commands, in Manjaro KDE.
The only step i done right was bootloader unlocking, that i made myelf caz the installer did nothing in that case.
Please help, i really hate oxygen 12, i made the biggest mistake installing oxygen 11 then upgradeing to 12 caz i thought maybe will be better than 11.
Now im still stack in 12, bootloader unlocked, the e installer do nothing even it says it does.

I am making another attempt, but with the current version of e. I don’t know if this issue was specific to version 0.21, but I was able to get further in the installation process with version 1.8.1.

When i flashed the Nord n200. I found that the timing of cable insertion made a difference. As odd as it sounds, you might not want to keep your usb cable dettached until you reach /e/ recovery (apply from adb) THEN try adb devices and proceed.

This topic was automatically closed after 60 days. New replies are no longer allowed.