Errors in script

Found an errors in the installation script.
*) got a “DMARC report” today for my new self hosted ecloud, and it looks like the instructions for the DKIM record is wrong. It has the mail._domainkey for host in the TXT record, but it looks like it should be “default.domainkey” My other domain has that instead, and when I changed it on this domain, it passed the DKIM check.

Found an error in the README for installation.
This is wrong:>

bash /mnt/repo-base/scripts/

instead it should be bash /mnt/repo-base/scripts/

I’ll wait a few days to see if I get any more “DMARC report” before filing a bug report.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Didn’t catch that, as I use shell completion :wink:
Thanks! I’ll suggest this to be corrected by Murena team, in next release.

Could be interesting to know who sent this report!
Microsoft, maybe? :wink:

Don’t see the point needing a selector rename and removing the underscore…

Could be interesting to know how your check is performed!

Let’s add some information:

So, the “_domainkey” DKIM record is probably not wrong.
It could really be of value to know more about the DKIM check you are performing, and the detailed output for the problem :pray:
Maybe some servers you are sending email to, are expecting a different (diverging from RFC) syntax that we could add…

I thought I fixed it by the change I made, (Because it then passed the tester I was using.) But when I send another test message, (It is going to a account.) Comcast sends me a “Domain Report”. I am still trying to translate what it is saying… but I know the first email did go through, but went into the spam folder. I just finished another project, so I should be able to work on this tomorrow.

1 Like

You are correct. I made a mistake in reading the report. Where I saw “rejected” was actually the policy that I was giving, not the result of the test. My second report failed the dkim test. When I ran the test at the website, it must have used the old DNS entry, not the new one. My email still went to the spam filter, so I need to look more at why that would be.

1 Like

If you got an encrypted SPAMCAUSE, this may be of help: