Essential Ph-1 Device State=locked

I am trying to install /E/ to an Essential Ph-1. I’m retiring my Pixel 1 with /E/

I reset the Essential Ph-1 with a factory reset. This is Android 10 and the last update Essential sent out. Android 10 with security update February 2020.

I enabled developer options and turned on USB debugging and OEM unlock. I have rebooted the phone a couple of times and checked OEM unlock and USB debugging are still enabled.

When I reboot into bootloader with adb the screen says: DEVICE STATE=locked.

I did get the trust screen on the phone to trust the computer and checked always. The computer is Ubuntu 20.04 LTS and I’ve checked plugdev and udev rules. I think the problem is the bootloader is still locked.

Any suggestions?

Once it reboots to bootloader I can only see the device if I use sudo fastboot devices. I can see the phone in adb without using sudo.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hi @hellaconfused, I have one of these and I would recommend you follow the Lineage install instructions for the best chance of success; just substitute e-recovery and os zips in the commands.

You need to unlock bootloader with fastboot commands as per instructions.

To get started power off the device then boot into fastboot mode by holding vol down and plugging usb into pc.

Please be extra careful to prepare properly for this device, read instructions first and digest because it can be an absolute pig if things go wrong!!

I would also say it’s a good idea imho to flash the penultimate eOS version first time. This way you can receive the latest version as an OTA update after booting up which will install to the other slot.

Thanks for the pointers. I followed your instructions and ended up at the same place.

Here is a photo of the screen after using the command adb reboot bootloader.

I removed the photo as it is no longer needed.

Ah, ok.Well there are now two hellaconfused’s!

Forgive me , it’s been a while since I unlocked the bootloader on this and it’s coming back to me now. It’s going to seem to you like I’m going back on myself,but follow /e/'s instructions for bootloader unlocking and then move on to LOS instructions for booting recovery/install eOS.

Reasons? /e/'s instructions have an additional command for unlocking, but they fall short for the rest of the process. It’s safer to use the e-recovery for flashing , it’s a fork of Lineage’s, but e’s instructions describe the twrp method and they throw different commands for you to choose from. This is just my suggestion…

twrp can be a bit tricky on this device, sometimes no touch.

Wondering if fastboot version might have something to do with this. I think I was on ubuntu 20.10 at the time I did this; it was the platform tools that came with the os and I didn’t need sudo for fastboot devices.

I skipped “fastboot flashing unlock” and went to “fastboot flashing unlock_critical”. This worked. The bootloader is now unlocked.

Thanks for the responses.

Now fastboot returns “Warning: Device A/B support is outdated. Bootloader update required.”

The phone still boots to the last version of Andriod. Not bricked… yet. (joking)

That’s progress, but now you have a warning. Not exactly a smooth install this, is it? :wink:
Don’t know why you’re having these problems, my phone had almost exactly the same Fastboot Mode screen as in your picture except mine is Variant - OPENAM, yours -OPENUS. Don’t think that will make a difference here.

I’m thinking it may have something to do with the fastboot version on your pc. If the warning stops you being able to proceed and fastboot flash boot the e-recovery I would suggest maybe investigating exactly which version fastboot is on your machine.

Have you tried to continue to flash a recovery?

I have platform tools 31.0.2 installed. The latest I believe.

I did try to flash the recovery file and it failed with a complaint about the file size is too big.

I think what I will do is flash the last available android image with adb and hope this ‘repairs’ the bootloader issue.

Maybe I’ll re-purpose this phone elsewhere. The Pixel with /E/ works fine, but it is based on Android 9. I’d prefer 10 at least.

I would have tried changing slots first, before doing a return to stock.
Do you know the fastboot commands for doing that? It’s not a problem

I did not try as the phone reports slot_b active. I tried to flash to slot_a.

Thanks for all of your help, but I think I’m going to re-purpose this phone and skip installing /E/ on it.

I had a free hour last night…

I installed the latest platform-tools and android-sdk-platform-tools-common
on a fresh Ubuntu computer. I could use adb commands without sudo but with fastboot I had to use sudo.

Then everything worked and the installation went smooth. Thanks for the help.

I’m pretty impressed with this port. The Essential 360 degree camera works out of the box. But I do wish it had an app drawer or something besides icons all over the screen.

Hooray! That’s great. Glad you got it working in the end.

Well, that’s the “Bliss” launcher for you. It’s specially made by e and many don’t like it. But it’s just an app, and you can find another launcher and try that. My favourite that I’ve been using for months is Omega launcher. I just posted details for it today in another thread. Other people made their suggestions also. Take a look.

Search the forum for other discussions about launchers and Bliss.

Whenever you try a launcher it always takes a bit of time to set it up and get used to it so patience is the key.

You can go back to Bliss anytime, just go into settings > apps & notifications, find Bliss and set it as your Home app.