Essential PH-1 Mata NO TOUCH

The issue I’m experiecing is after installing /e/ Q ( on my PH-1 from stock (January 2020 update), the touch screen does not work. However, if I use a USB mouse I can navigate the GUI, so the device is not frozen.

I have searched sevaral forums including the /e/ OS communinty, Lineage OS, as well as various others that show up during an online search. Nearly every posts I’ve read have suggested to flash back to stock to the December 2019 or January 2020 update, which I’ve done multiple times, but this does not help solve the no touch issue.

I’ve also tried using various different recovery images, such as:

  • ecovery-e-0.16-q-20210424112062-dev-mata.img
  • lineage-17.1-20210329-recovery-mata.img
  • lineage-18.1-20210607-recovery-mata.img

And the various TWRP images which other posts have suggested:

  • twrp-3.2.3-0-mata.img
  • Patched_Boot_10_Jan.img
  • patched_boot.img
  • Dec_boot_patched_TWRP.img
  • TWRP-SEP.img

None of these recovery images helped address the NO TOUCH issue either in Recovery Mode or after /e/ OS was flashed. I reverted back to stock each time and used all the recovery images listed above before flashing /e/ OS. Also, in case anyone is wondering I navigated the TWRP menus with a USB mouse as there was no touch.

There were some posts that suggested issuing the following to restore touch after flashing a custom ROM:

  • fastboot flash rpm_a rpm.mbn
  • fastboot flash rpm_b rpm.mbn

and even flashing the vendor images before flashing a custom ROM:

  • fastboot flash vendor_a vendor.img
  • fastboot flash vendor_b vendor.img

None of that worked. Additionally, I also tried flashing Lineage OS 17 and 18:

  • lineage-17.1-20210329-recovery-mata.img
  • lineage-18.1-20210607-recovery-mata.img

There is NO TOUCH after flashing either Linage or /e/ - how frustrating is that!

The only way to restore touch is to flash back to stock. I’ve also tried flashing the original stock image QP1A.190711.107 which was the initial Q release from Essential (September 2019 Release) from and then trying to flash /e/ from there - still no touch!

In every single case, flashing /e/ completes successfully (regardless of recovery image used), but when /e/ loads there is no touch functionality. Formating the data paritions, wiping cache, etc. none of that seems to make a difference. Not evening flashing to boot_a and/or boot_b (or both) makes a difference!

Hoping the community can provide some assistance as I’ve exhuasted every forum & guide found online. Thanks!

I’ve never experienced this issue on my PH-1. Yes, I’ve had the no touch issue with some twrp versions and that made me use the e-recovery or lineage recovery whenever possible.

Are you fastboot flashing your stock roms?

Maybe try getting stock rom from another location. I have had success with Q roms via a link on this XD thread.

Specifically, this version:

After setting up the stock rom I then flashed eOS or Lineage for microg by sideloading from their respective recovery.

1 Like

Daze One has a great YouTube video called:

How to install TWRP & Root the Easy way for Essential PH-1

A link is there to " Boot image folder Essential " at that link go to “Essential Stuff” and use the “TWRP_Boot_Jan.img”. I’ve use this video and boot .img to install TWRP and then /e/ on three PH-1 phones.

Thanks @chrisrg & @MikeC.

I’ve tried flashing back to stock (, which is the last update provided by Essential (February 2020 Release) before closing shop. While touch works in stock it will not work when flashing to /e/ or Lineage. I also tried the "TWRP_Boot_Jan.img” file provided from Daze One, and there is no touch in TWRP or after flashing /e/ (I tried flashing both /e/ Pie and Q just to make sure it’s not something with the Q image). Perpahs I have a defective PH-1?

I have successfully flashed /e/ Pie on another PH-1 and it’s worked great for over a year now. This phone with /e/ rocks! Which is why I purchased another unit (as a backup), but just can’t get touch to work outside of stock. :frowning_face:

1 Like

Before you give up. Try the second to last update from Essential, which is the one I use. I read somewhere (I think it was XDA) that the last update from Essential caused problems with custom ROMs and custom recovery. If the phone works on stock it almost has to be a software problem.

Note: I go back to nugget after unlocking bootloader and critical to unlock the sim lock on my phones. Then I flash the second to last update. Going back to nugget may help you.

I agree with MikeC,

Guess you do too; but you have the pesky problem that everthing works on one but not the other. It’s a puzzle, that’s for sure!

So, just thinking out loud, ask yourself what’s different to the time you flashed the other phone (a year ago, yes?) and what you are doing now.

Could it be the fastboot version? I’m sure i read somewhere about mata being picky on that front. Maybe try an older fastboot/platform-tools?

1 Like

Thanks again fellas. I really appreciate the troubleshooting assistance here & helping to double check my steps.

@MikeC - Yes, I had read the same thing about the Feb 2020 update causing issues. I did flash the Jan 2020 and Dec 2019 BTS images and still no touch when flashing /e/. Heck I even want back to the Aug 2019 & Sep 2019 updates. I tried flashing back to Nougat, both the intial release (Oct 2017) and the last (Feb 2018), but after reboot the phone just loops the stock image boot animation (the one w/ the dots); so it never fulls boots to Nougat. I’ve read that flashing back from 10 or 9 to 7 can brick the device? Not sure if that’s the case here as I can flash back to stock, Pie or Q, and the unit seems fine. But I would have to agree with you that it seems like a s/w issue if touch works in stock but not in /e/ or Lineage.

@chrisrg - I do recall that on my primary PH-1 I was running /e/ v7 (Nougat) last year when I flashed it to /e/ v9 (Pie). I had initially flashed /e/ v7 from stock Nougat 2 years prior. I did this on a Windows box which I’ve since wiped and loaded Ubuntu 20.04. I’ve been using both the native fastboot from apt-get (fastboot version 1:8.1.0+r23-5ubuntu2) and the latest from Google (fastboot version 31.0.2-7242960).

A puzzle this is indeed.

1 Like

Sorry spelling is one of my weak points. So don’t put any nuggets in your phone! Lol

NMK24B is the nougat stock ROM I’ve used. Do you factory reset before and after stock installs? Often this fixes boot loop. Do you format data before installing /e/OS and reboot recovery and factory reset after, before booting system?

1 Like

@MikeC - Haha! Yes, NMK24B is the last Nougat release I tried. Yes, I did factory reset before flashing Nougat but not after. Would I do that by locking the bootloader again? When I push a BTS image there’s no TWRP, so I would assume that locking the bootloader would auto force factory reset upon reboot. Yes, I formatted/wiped data & cache before boot.

I’ve exhuasted all I know & read… am considering returning the unit, but I feel that’s like giving up and I know this can be done. :slight_smile:

When you unlocked bootloader did you also unlock-critical?

Flashing stock older OS versions over newer stock OS versions should be ok.

But not flashing custom rom older OS versions over anything newer.


What MikeC proposes below looks promising! Good Luck. :slightly_smiling_face:

The bootloader needs to remain unlocked to use TWRP and /or /e/. To factory reset the stock ROM you can use the command
" fastboot -w " which wipes data. If that gives you a error, reboot the bootloader and retry. You can also use stock recovery. " fastboot reboot recovery " or volume up + power button will get recovery. When you see the android on it’s back, hold the power button 2-3 seconds, then bump the volume up will bring up the menu.

The reason I think Nougat will help is this.
Nougat flashes slot_a and slot_b in 4 steps each, but Pie or Q flashes a and b in 5 steps each. In other words the proportioning is different and Nougat must rewrite the whole slot to have the right number and kind of partitions. This may undo what the Feb 2020 update did that doesn’t play well with custom software. I know it can work, because one of my phones had the Feb 2020 update and now is running /e/.

Like you, I’m about out of ideas. Maybe write it out step by step and make sure you hit every step.


@MikeC - Thanks for the info on the reset procedure. I was able to get stock Nougat to boot after following the volume up + power button procedure within recovery. Then from stock Nougat I flashed the stock January 2020 Release (QQ1A.200105.007); so at the moment I have a PH-1 running stock Q with touch.

I do want to take a step back though & ask a few questions, but before I do I want to share the following:

Note: I trust the rest of the community will benefit from this - when using fastboot and adb tools in Ubuntu (or any Linux distro), make sure you are NOT using the fastboot that gets installed with apt/dnf. This old version will be linked in your PATH and anytime you issue any of the scripts for the stock images it’ll end up using the old version of fastboot. This will cause all sorts of errors to show up in the terminal that are easy to miss if you’re not paying attention. Before I run these scripts I edit the “” file and replace the “fastboot” command with the path of where I downloaded the latest tool (e.g., “~/Downloads/platform-tools_r31.0.2-linux/platform-tools/fastboot”). This should save you some time and frustration.

Now that I’m at stock Q and before I pick this up again I need to ask:

  1. What is the purpose of trying all these different TWRP recovery images? Can’t I just use the recovery .img file /e/ publishes with their ROMs?
  2. What is the purpose of installing Is this even required? If so, is it done after sideloading /e/ or before?

There’s so much conflicting info out there that getting clarification on these two TWRP files will help clear up any confusion for myself and others who come across this post.

Let me begin anew here and see if I can get this unit flashed. :slight_smile:

Thanks again for all the help thus far.


Yes, some good news!

Great point about platform tools on Linux. Never use the one in the repository. It’s really easy to download the zip file, unzip it into a folder, copy anything you want to flash into that folder and then open a terminal in that folder to do your work.

TWRP is a excellent recovery system. You can wipe partitions, do backups, install .img and .zip files and more. The TWRP for PH-1 is old and very “buggy”! TWRP is what most people are accustomed to and that is why it’s in most instructions.

Recovery on PH-1 is part of the boot partition and is not on a partition by it self. So for the first custom recovery install you need a boot.img file with recovery built into it and you can flash that with fastboot. Then you must reboot into recovery (if you boot system it will over write the boot portion and you’re back to stock) once in custom recovery you install the .zip file to make the installation permanent. Warning: The TWRP.img file from their website does not have working touch.

I recommend that you use /e/ recovery.

  1. Download the latest /e/ ROM zip file.
  2. Download the latest /e/ recovery img file and fastboot flash it to boot_a and boot_b.
  3. Reboot recovery, sideload the /e/ ROM zip, factory reset and boot the system.

Just wanted to provide an update. I ended up returning the PH-1 unit I had and purchased another, afterwards I was able to install /e/ with no issues on the replacement. Touch works flawlessly! I’m convinced that the initial unit I tried had a defective touch screen or it was some after market display issue. Thanks all for the guidance & hope others are able to benefit from this thread.

1 Like