exFAT compatibility on /e/?

Hi All,

Sorry if I miss a potential existing post about exFAT partitions on USB key or SD Card but I saw no result in the search tool!

I need to transfer big files (videos) more than 4 GB on a USB key. So I need to use exFAT partitionning instead of FAT32 limited to 4 GB max file weight. It looks like my exFAT USB key isn’t recognized by my /e/ phone. My other Android phone however can access to it without any issue.

I know you need a Microsoft licence to be able to use exFAT. Is that licence included within /e/? If not, do you plan to include it in the future?

What are the alternative ways for partitionning USB key or SD card for storing big files more than 4 GB? Can we find some dedicated apps for that? Can we use NTFS instead (I want to use my USB key also on Windows devices if possible)?

Many thanks in advance for any answer!


1 Like

Linux. My SD card 64GiB is formatted as Fat32, most of my USB drives too. It is a Windows problem, in fact only Fat16 is limited to 4GiB.

AParted is available in Apps on /e/. Needs root access

Or on your phone Settings > Storage > SD card > Format as portable

On your Windows computer:
from AOMEI

OK, have to edit. Both work from your phone Settings > Storage. No need for root access or an app as AParted, screenshots made on FP2 running /e/ Pie:


Thanks for your detailled answer! But when I look to different information resources I always saw there’s a file size limit at 4 Gio - 1 octet for FAT32! Only exFAT or NTFS (among Windows compatible format) can exceed this file size limitation.

And I already tried to write a 8 GB vidéo file on my USB key in FAT32 and it always failed in the middle of the copy… The problem for me isn’t the initial partition size limitation of 32 Gio about FAT32 that can be bypassed by some dedicated applications indeed but only the file size limit that doesn’t look to be exceeded without choosing another partition format.



1 Like

Can’t a USB key be partitioned in ext4 ? I guess it would be recognized by the phone and windows since the data partitioned of the phone is in ext4 and can be read by Windows.

Thanks for your answer but my issue isn’t how to format the USB key in exFAT: my key is already formated in exFAT. My issue is how to read and write data on an exFAT USB key within /e/, not TWRP!

So I need to know first whether /e/ is exFAT compatible. And if not I need to know which is the best alternative format I can use.

I think I will try NTFS and will let you know!



1 Like

Yeah, filesystem support is in the kernel, which is from Lineage. I had assumed that exFAT support was standard these past couple/few years. But then after readimg this little blurb about exFAT support
makes it seem like it may depend on whether or not a device was originally licensed to include such support. Not really sure.

I have no exFAT media to test at the moment so don’t know on my /e/ devices. I may be able to test in the next day or two.

Many thanks marcdw for the link!

That’s the type of information I was looking for!

For your information I tried to reformat my USB key using NTFS format: it works now for my /e/ device LeEco Le MAX 2! But my key doesn’t work any longer with my Android device HTC U11+: so the exact opposite of exFAT format! :stuck_out_tongue:

It would ne interesting to test with other /e/ devices to check whether it is hardware dependant as told in your linked document!

Unfortunately, I still cannot transfer files up to 4 GB of size using my USB key between my two different smartphones with /e/ for one and with Android for the other…

Best Regards,


Regarding the NTFS thing, I learned not to use that. Journaling or permission-based filesystems turn out to be a problem when it comes to sharing. Years ago, when using a PortableApps flash drive it was recommended to use NTFS. I did but when using the drive among different computers I’d find I couldn’t write/save data. Owner/user/permission errors.

Today I’ll pick up a flash drive, format it as exFAT, and check which ROMs/devices can or cannot read it.

On the day I was going to test out a 64GB exFAT flash drive, the devices were low on battery. :expressionless:

/e/OS Nougat on an Essential PH-1 and ZTE Axon 7 was able to read & write to the drive just fine. The mount command showed the filetype as fuseblk.

The five other Nougat ROMs on the Axon 7 also had no issues. Filetype of fuseblk, stock ROM being ufsd instead.

Moto G5s Plus (sanders) did not do well. Stock ROM is Nougat, six other ROMs are Oreo AOSP-based. Five of those failed to read or write. Mount command shows filetype of exfat. Only OmniROM worked, filetype fuseblk.

You may have seen or heard that exFAT support is official with Linux kernel 5.4. Great for the future but…
For the here-and-now what does one do if they need large file support. I don’t know. Paragon Software has long offered third-party support. First for NTFS, then exFAT. Alas, it is not free despite that word displayed on their page.

I have no need for exFAT but I will test it out on the Moto’s ROMs. Will report back.

Many thanks for your tests and help!

Best regards,

Ph. P.

I had the exact same problem with te EXT4 formatted SD cards on my Lineage build. Now I move my SD card in FATex to my Fariphone 3 running /e/ and it’s not recognized.

The problem I had manny times in the past is when I write in TWRP to the SD card in EXT4 and then boot, the Linage OS could not use the files in apps or switcht between phones. NTFS indeed same risk… FATex was the perfect sollution

So do I understand right, that because of Fairphone OS not incorporating FATex, /e/ is not allowed to use it as well?? Is there already a workaround?

Fairphone 3 should support exFat I now read:

Anybody an update about this of the /e/ OS?

1 Like

ahoy all,

to add another data point to the discussion: /e/OS 18 on a Teracube 2e is not recognizing an exFAT microSD card that is recognized on many various stock Android devices i have tried, including 4.x versions. i am waiting to see if Teracube has anything to say on this as well, though their stock Android 10 also does not seem to be recognizing exFAT.

regardless since /e/OS is based on LineageOS i am guessing that it should be possible to add the driver?

thanks and take care, w

Last I read, exFAT had to be licensed which is why it would be in most OEM stock ROMs but not custom. Then word was that exFAT support would be included in the 5.x Linux kernels. Not sure if any Android devices have v5 kernel. I only have one modern Android device, OnePlus 8T running Oxygen OS 11 / Android 11 and kernel 4.19.x. I don’t know if I have any exFAT flash drives (those I did were converted to FAT32) so can’t say if that filesystem is supported here.

1 Like

thanks for the reply and apologies for my delayed one.

my research came to the same conclusion: a license fee to Microsoft would need to be paid by /e/ and/or Teracube to allow exFAT support. and as you say the 5.4 kernel supports it natively, but who knows when that will make its way to Android. maybe i need to just go with ext4 and deal with any compatibility issues with macOS and Windows if/when they come up.

regardless thanks again and take care.

1 Like