Experience with eOS on Galaxy Tab S5e (LTE)

I just wanted to share my experience with installing and using eOS on Galaxy Tab s5e. I will probably add Points from Time to Time.

Installation (differences to official guide on Linux)

  • I had to hold Power+VolUp+VolDown while connected to the PC to get to unlocked Download Mode. Other Options resulted in being in Download Mode, but then Heimdall could not connect to the device. (i saw the difference, as the unlock state was not displayed)
  • I had to use heimdall-git Version from AUR, otherwise no connection was possible via USB & the heimdall command. (this includes a fix to Heimdall 1.4.2)
  • Then i flashed vbmeta.img and rebooted
heimdall flash --VBMETA vbmeta.img
  • Then i went back to download Mode and flashed TWRP as follows
heimdall flash --RECOVERY twrp-xxx.img --no-reboot
  • The Parameter no-reboot is important, otherwise the recovery will be overwritten with stock recovery on reboot.
    So directly boot to recovery after flashing twrp, which is tricky because you first have to Press Power+VolDown to trigger restart, and as soon as the screen gets black, you immediatly have to hold Power+VolUp to boot to TWRP.

  • Then i continued the normal way, Formatting Data, System and Cache, and then installed the eOS Zip.



So far everything works fine.

Things i didnt expect but do work:

  • Screen Mirroring :slight_smile:
  • Connecting to external Screen with USB-C to HDMI cable
  • Official Samsung Keyboard Cover

Things to improve

  • Bliss Launcher does not yet support Landscape Mode


  • I wonder what would happen, if i enable Automatic Update of Recovery via OTA, because i used TWRP instead of eRecovery. Will it break or just overwrite recovery? → Overwrite
  • Is it possible to Re-Lock the bootloader? → no
  • Will the official Keyboard Cover work? → Yes it does :slight_smile:
1 Like

TWRP will be replaced by the “recovery-e”.

Not on this device.

eOS Device on Monitor/Display?


I now tried connecting to a HDMI Screen with this Adapter-Cable:

And it worked out of the Box :slight_smile:


Is your TV an MHL capable device ?
or simply an old-scool HDMI device ?
does the TV HDMI port have the ability to charge the phone ?

comment : for browsing youtube contents without being disturbed by their advertising messages, you can use “newpipe” from “F-droid”…

its a usual HDMI Monitor from my PC.
I dont think its able to charge the device over HDMI, but i have to test it again soon, i didnt pay attention to this.

i dont know if it has MHL, but its a Gaming Monitor, so probably…
i have to find the model number of the screen, maybe i can find out.

thanks, yeah i know newpipe and use it on phone already, just havent installed it yet :slight_smile:

this is the display:

I cant find MHL though…
Maybe my cable has a MHL emulation or sth like that.

Thats (probably a newer version of) the cable:

Hey @KernelPanicake, thank you for sharing your experiences. I’ve also bought a used S5e and tried to install eOS but have troubles with heimdall. I just don’t know how to install and get that heimdall-git version from AUR to work. That’s probably some basic linux knowledge but could you please share how to do this? Maybe there are more people interested…

Thanks a lot! :slight_smile:

What is this ?

Im not on a Arch-based distro anymore, but have you tried: “yay -s heimdall-git” ?
But i guess you could also use any other AUR helper.

What distro are you using?

Heres a quite good description of the different AUR package types :slight_smile:


thanks for the fast response! To be honest when it comes to installing software I only use the pre-installed app store on my distro (pop os) or the terminal when I can copy/paste some command line someone else provides :smiley:
Is this correct, that I am not able to install that heimdall-git version from AUR since it is made for Arch Linux?

I think it is Heimdall from gitlab but comes with a patch to detect some “newer” devices like the S5e. @KernelPanicake correct me if I’m wrong…

You now can use Odin4 for Linux



yep, no access to AUR then.
You could get the release from Github/lab and Build yourself maybe…

I think its just a newer version that has not been put to a regular package yet.

But probably a lot changed since then :slight_smile:

Or try Odin, like @piero mentioned.