F-Droid not updating?

F-Droid has been showing up in the “Updates” section of “Apps” for weeks now. If I try to press “Update”, a progress bar shows “0%”, then quickly changes back to an “Update” button again. Has anyone else experienced this? Anyone know of a fix?


I have the same experience. Then i used my browser to hit f-droid.org and download the app. it worked.

1 Like

I just downloaded a newer F-Droid from f-droid.org, which worked, but it still shows up in the updates menu. I’m guessing this is happening because the latest version in the app store is reported to be 1.13-alpha0, which is a newer version that the one I downloaded from f-droid.org, which is 1.12.1.

1 Like

On my phone the same.
Does’nt /e/ have a solution.
Tried every thing I know notting works. This is anoing!

Regards, rex

I use Foxy Droid instead of the original client and never had a problem with that.

Yeah it would seem like you shouldn’t install F-Droid from App Lounge. Just get it from their website. I had to uninstall the one got from App Lounge first. After this F-Droid can update itself as usual.