Facebook ... I don't want it but I need it


finally managed to install e on my wife’s Samsung S7 Edge. What a great pleasure to have got rid of all that Samsung and Google bloatware …
So, now the painful bit: i know it sounds crazy to install Facebook on e where you are tying to get rid of data hoarders but to convince my wife, I need small steps at a time. Having spent 20 year on Linux, I know what it takes to get people away from the mainstream :wink:

In the App Store, Facebook is shown. When I try to install it, it hangs on the “installing” phase and just does nothing. The icon never appears in the list of apps available. If I don’t give access to Facebook I’m in trouble. :slight_smile:

Has anyone got Facebook working? I also noticed that there is a “Swipe for Facebook” which promises the same experience as the original app but without all the adds and tracking. Is that even possible and how is it that Facebook is allowing other apps to access their systems without being able to sell to its users?

I did a bit of a search on Facebook and didn’t find much (not surprised as those that are on these e forums are moving away from Facebook …).

Any thoughts on how to give access to Facebook are welcome.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Frost from f-droid, its a web wrapper for facebook, so no intrusive permissions needed or needing extra app for ‘messenger’. Do not put facebook or messenger app on the phone :grimacing: I dont personally have FB but people I know that do, use it and say it works great.

1 Like

Also a tip: /e/ Appstore is still a work in progress so it may not always work as intended. F-droid will always be the first place I suggest to get apps, then if you need specific (likely closed source) apps you can use Aurora Store which allows anonymous login access to apps on google play.

Cheers b3pio. What I would say though is that Aurora is also failing to install from App store so will see if I can get it from F-droid.

Would it be fair to say that Facebook would prefer its users to use its app so it can be more invasive but tolerates access from the browser (thus making apps like Frost possible) as it still is able to collect some data?

1 Like

I guess its still getting some info about the user and facebook browsing habits etc (its facebook after all), but its not getting info from the device by infiltrating the users device with the official app through loads of their trackers and all the permissions it ‘requires’. Frost is like a ‘mobile web browser’ just for facebook / a mobile site wrapper. You also have SlimSocial, MaterialFbook & Face Slim in F-droid as alternatives to see which one you like better.

Get the latest Aurora store version either from the aurora store telegram channel here or in f-droid. /e/ appstore version would be out-dated anyway. Latest version available is 3.2.5 (may be 3.2.4 on f-droid as update may have not been build for f-droid yet)

Another alternative that might work (haven’t tried it) is to use Facebook’s PWA directly in the browser. It would be better to install a separate browser only for this specific purpose but it would work very similarly to the an app: icon, offline cache, etc.

I would suggest something similar… use Facebook in a browser, and maybe for her it should be more practical to let password saved. Then save the url in her main screen and she just needs to click on it to open Facebook. I never used Facebook app, so I don’t know if it’s much better than via browser, but anyway, it’s an alternative…

Or try the app " Slim Social for Facebook", it looks a good option (although I never tried this, only Slim Social Twitter", which I like - it’s light, it do not ask for a lot of permissions etc.)

Hi, here we are a few months down the line and my wife has got used to Slim Social (sort of) until I installed the latest update for her Samsung 7 (0.13-20201212 of Andorid 7.1.2) last night and now when she clicks the Messenger icon in Slim Social, it says that there is no availble app to open the link.
Initially I thought it was a Slim Social problem so I tried with Frost. Same problem! So I tried with two different browsers. Same problem! It seems like the /e/ OS update has broken something that allows the phone to open the Messages in Slim Social. Anyone else experiencing this problem?