Failed build for bramble

Hello! I am trying to build bramble (pixel 4a 5G) from source using the docker image and it fails every time. I have tried re-syncing the docker image:

sudo docker pull

Below is the full command I am using.

sudo docker run -v "/srv/e/src:/srv/src" -v "/srv/e/zips:/srv/zips" -v "/srv/e/logs:/srv/logs" -v "/srv/e/ccache:/srv/ccache" -e "BRANCH_NAME=v1.2-r" -e "DEVICE_LIST=bramble" -e "REPO="

Below is the output that I get

`>> [Tue Aug 9 22:46:08 UTC 2022] Copying ‘/srv/local_manifests/*.xml’ to ‘.repo/local_manifests/’

[Tue Aug 9 22:46:08 UTC 2022] Syncing branch repository
[Tue Aug 9 22:48:28 UTC 2022] Setting “UNOFFICIAL” as release type
[Tue Aug 9 22:48:28 UTC 2022] Adding OTA URL overlay (for custom URL )
[Tue Aug 9 22:48:28 UTC 2022] Preparing build environment
[Tue Aug 9 22:48:28 UTC 2022] Starting build for bramble, v1.1-r branch
ANDROID_JACK_VM_ARGS=-Dfile.encoding=UTF-8 -XX:+TieredCompilation -Xmx4G
Switch to Python2
[Tue Aug 9 22:49:55 UTC 2022] Failed build for bramble
[Tue Aug 9 22:49:55 UTC 2022] Finishing build for bramble
[Tue Aug 9 22:49:55 UTC 2022] Cleaning source dir for device bramble
Switch back to Python3

Is there a way to see more details on what failed?

This is my first time building a ROM so any help would be greatly appreciated!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Is there a way to see more details on what failed?

the build output is piped to DEBUG_LOG that sits in


Thanks for the build log location!

The error is below.
FAILED: out/soong/ out/soong/.bootstrap/bin/soong_build -t -l out/.module_paths/Android.bp.list -b out/soong -n out -d out/soong/ -globFile out/soong/.bootstrap/ -o out/soong/ Android.bp

This line shows up about 4 times.
error: vendor/google/bramble/Android.bp:869:1: module "manifest_android.hardware.drm@1.3-service.widevine" variant "android_arm64_armv8-2a_cortex-a76": module source path "vendor/google/bramble/proprietary/vendor/etc/vintf/manifest/manifest_android.hardware.drm@1.3-service.widevine.xml" does not exist

I assume this has something to do with the proprietary blobs that I pulled from the device?

As I follow along with the build steps here (How to Build the /e/ ROM?) I think I have found the issue that is tripping me up. After Step 4 is the step to “Extract proprietary blobs” and in that it says to navigate to folders that do not exist yet. Originally I had just skipped over this step thinking it maybe wasnt necessary for Google phones. Step 6 then created these directories for me, but what is the correct way to run step 5?

(you’re building to get to know the process? there are bramble images - /e/ image ROM download)

you have 3 options - 1) either go through the linked docs to extract the binaries from your own device (there’s a script that pulls via adb)

or 2) add a environment variable to the docker community script -e INCLUDE_PROPRIETARY=true that will go out and fetch the proprietary files from a git repo (a fetch at ~30GB and rather unoptimized, it will fetch all vendor blobs).

If you lack bandwith/space, instead of +30, grab 4GB - 3) skip the variable and just create any filename with xml extension inside a self created hostside folder (name wouldn’t matter) local_manifest and put into this

<?xml version="1.0" encoding="UTF-8"?>
  <remote name="github" fetch="" />
  <project remote="github" name="TheMuppets/proprietary_vendor_google" path="vendor/google" />

and add this folder (it’s a relative path) as volume to the docker invocation (only the target directory matters, as it’s predefined to be /srv/local_manifests)

-v "./local_manifests:/srv/local_manifests" \

the file get rsynced for the next repo sync at · ac306a6d · e / os / docker-lineage-cicd · GitLab

1 Like

Yes I would like to learn more about the process and make some changes to the default apps, etc.

OK I had tried option 1 to extract via a local device and also via the downloaded zip. Both were giving me errors. To extract from the Device it says it failed to get multiple files, then during the build process it fails.

I will try method 3!

Thanks so much for the help! I am learning!