Failed connection to a Nextcloud istance from android client

Hi everybody,

Maybe somebody can help me facing this issue.

I have 2 Nextcloud instances. The /e/ instance and another instance coming from an association I belong (Exit that is an Italian association that shares knowledge about privacy items and gives some services privacy oriented like a nextcloud cloud space).

I access to them both using Android Nextcloud client on m FP3. The /e/ is running well while suddenly I’m not able anymore longer to the access to the association instance.

What I can note is that suddenly the acces to the association instance seems do attemps to work with the location permission. I don’t know why since the app is not allowed to access the location data. So in my mind it could be something related to the server setups.

I leave an link where you can find the little video where you can see the behavior

Thanks in advance to anybody can give me a cloue.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

hey Luca, I do selfhost nextcloud (v 20.0.14), watched your screencast and tested nextcloud android cilent 3.18.0 login flow successfully against it and found no error.

What nextcloud server version does the Exit instance run on?

(btw, you can use app tokens to quickly scan a qrcode and login - also easier to revoke access later. its in your web login settings at “create app password” → " Show QR code for mobile apps ")

1 Like


As I can see, Nextcloud client is giving up after a successful login to Exit.
You may try to get logs using this guide : GitHub - nextcloud/android: 📱 Nextcloud Android app
Also, I could see many Github issues for Android crash : Issues · nextcloud/android · GitHub
You may try to create a test account at and try to reproduce the problem.

Hi tcecyk,

I need to doublecheck with server admin. I will revert you back. Thanks for interesting

Hi smu44,

the successfull login is not for Exit instance but for /e/ instance. Then I tried to set Exit account without succeed in it.
Thanks for suggestion. I took a look but I’m not a that knowledge level to bring neccessary steps.

… better the account is settled but the access failed

Hi smu44,

You may try to create a test account at and try to reproduce the problem

I tried the demo account works fine…I don’t know if server version is the same of Exit server. Considering demo environement should be at the last realesed version I don’t think so. I need to doublecheck with server admin of Exit association

1 Like