Failing to sideload e-0.23-r-202204 to a Mi A2


I am trying to migrate from my old phone to a (well, also old) Xioami Mi A2 (jasmine_sprout).

Trying to sideload the e-0.23-202204…zip image results in a message “E:Signature verification failed” on the device itself.

Trying to install nevertheless (i.e. clicking YES on the device) results in a error applying update 29 (errorcode kDownloadOperationHashMismatch).

Can anyone suggest what I am doing wrong?

(just to be on the safe side, the e-zip and the recoveryimg are the same release)

Many thanks in advance.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone


Not much knowledge about /e/ Recovery here, but I’ve faced a similar problem in the past with TRWP …

Within TWRP, solved by copying (adb push) the file to /data then using TWRP’s Install button.
That’s how I’m installing every ROM image now, never failed me :slight_smile:

Thanks for the suggestion. I tried to do what you suggested, and the results are really strange.

First, it took quite a bit of effort to flash the device with TWRP. But, in the end that worked.

What is NOT working is pushing the e-0.23 file into the device. On slot A, the push stops around 18-20% of the upload. On slot B, the push stops around 90% of the upload.

I am beginning to wonder whether the flash on the device is shot.


Happy to read your success :smiley_cat:

But you may want to investigate further…

At first, you may try another USB cable, connected to an USB2 port if your computer has one (or a USB2 hub).

Are you sure you have enough free space on your device’s storage?
Within an ADB shell you can check with cd /somewhere then df -h . .
You may also search for another place with df -h (without the dot), but please be aware that some may not be your best bet to store ROM images :wink: (i.e. reserved partitions like EFS).

It’s very uncommon to have Flash chips problems, but I think that in this case you may have noticed it before with some weird behavior…


Your email was a very good lead. Instead of pushing to /sdcard, I now pushed to /data (both of which are mounted to the same MMC device, so I was not hopeful).

However, adb push to /data worked and the INSTALL from the TWRP menu also seemed to work, until it failed (at the very end) with failing to mount system_root (I THINK).

I did a factory reset, wiped cache, data and all other bits and pieces. Now let’s have another go.


…aaaaand, a different failure this time.

In step 1/2, the process failed and reported kDownloadOperationExecutionError.

Rather strange


Alas, it is jot a success yet. The previous phone was a breeze.

There should be no lack of space - but I will check.


Sorry, I was misleaded by:

To ensure your device health, you may try to install LineageOS.
Install instructions: Install LineageOS on jasmine_sprout | LineageOS Wiki
Some interesting readings (24 pages!): [ROM][11][OFFICIAL] LineageOS 18.1 for Mi A2 | XDA Forums

i had troubles flashing and updating on Mi A2, very helpful for me was

I unlock both - critical and non-ctirical.
So far, no joy.

Ok, i’ll give lineage a go.

After i followed the Information at the end of the linked text:
" Once in fastboot mode, check which slot is active:
fastboot getvar current-slot

And activate the inactive slot:
fastboot set_active a
fastboot set_active b

After marking the previously inactive slot as active, reboot the device normally:
fastboot reboot"

i could start /e/ os

1 Like

@marcvolovic , I always use the latest unofficial TWRP (with good Android 11 support and decrypts) from a well known developer (Nebrassy) of the Mi A2 (although he hasn’t released anything new in a while).
TWRP 3.5.1-jasmine_sprout

With that TWRP, I’ve never had any problems installing /e/OS (nor LienageOS) by sideload.
What’s more, I never flash TWRP, I simply boot into it, and from it I perform the whole process. In short, I keep the one that comes with the ROM.