Fairphone 3 Mac OS Issue

Hi all,

First time post and very much an amateur in this area .

I have tried following the steps on the e/ website regarding installation on the Fairphone 3. So far all the elements related to the handset itself are complete, the pathway tools are downloaded but when I try to run ‘adb devices’ it returns the message ‘command not found’ so I am unable to move forward from this point.

Any advice greatly received.

Many thanks


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Do you know where the files are? (adb and fastboot)? If i were you :slight_smile: i’d go here to be sure you have the right version of adb and fastboot. Extract the zipfile somewhere on your mac, and put the img files for the fairphone there too. Go into the directory where you have all the files, and just put ./ for the commands, example:
fastboot -w becomes ./fastboot -w


Hi - thanks for responding!

I’ve downloaded the right version of adb and fastboot - extracted the zip file onto my desktop. There was no mention in the guide about putting the img files in there for the Fairphone though - can you advise how to do this?

I have checked the Fairphone is connecting to the Mac correctly through USB and this seems fine as the Android file transfer works.

The idea is to put the .img files in the same directory as where adb and fastboot are. You can use Finder to put them all in one folder. You are correct the instructions need some improvement.

Thanks - how do you transfer the .img files from phone to Mac? The phone is recognised by the android file transfer but it doesn’t show up in Finder as a connected USB drive. I can’t find any .img files in the folders shown on the android file transfer app there?

Hello, the .img are inside the zipfile here. You put all files on the Mac (adb, fastboot and the img files) If you follow these instructions, the listed fastboot commands wil put them on the phone, this process is called “flashing”.

In your case macOS could not find add and Fastboot, that’s why I advised to put all files in one place, and start the fastboot command like this ./fastboot.

another newbie here. Thank you, Andrelam, for your replies here, which helped me, too.

My problem is that I do not have any .bash_profile as mentioned here. I have other .bash_ files on my Sierra Mac, but not that. Would you have time to please help me out on what to do about that?

And thanks to AndrewW for starting the conversation :slight_smile:

Hi Irene,

The problem I had was getting the Mac to communicate with the handset via adb, it wasn’t recognising it at all at first. I searched around the web and found home-brew at this link The Missing Package Manager for macOS (or Linux) — Homebrew

Once I installed that it worked fine, I was able to follow the steps on the various guides provided on the Fairphone website and successfully installed the e operating system.

All the best


If you put all files in one folder you don’t need to edit. bash files. The only reason to edit this .bash file is to get macOS find adb and fastboot. So if I were you, I’d download fastboot and adb and the /e/OS put it in 1 folder and run the commands in the documentation prefixed by dot slash ./ (after you cd into that folder)

You can simply create one with that name.

Detailed steps can be found here: https://stackoverflow.com/a/41709096/6309275

Thanks, all three!
I’ll put it all in one bask… sorry, folder, then :smile:
Just waiting for my FP3 to arrive, probably the end of this week.

Hello again!
(My reason for not ordering directly from the E foundation was that I want to return my old FP2, which I cannot do if I haven’t bought the FP3 through the Fairphone website, if anyone wonders what I’m doing here.)

FP3 arrived and charged.
Now please forgive a non-expert, but is this then the procedure to follow:
1: USB debugging allowed and bootloader unlocked on FP3.
2: Current adb zip folder unzipped straight into the Home folder.
3: FP3 connected to computer and turns up when in Terminal writing adb devices.
4: Turn off FP3.
5: Pressing Power + Volume - as stated in the instructions here.
6: In Terminal: not writing fastboot flashing unlock, but instead ./fastboot flashing unlock and following the rest of the instructions under Unlock the bootloader on the previously linked Install page.
7: In Terminal, follow the instructions under Installing /e/ from the bootloader on the previously linked Install page BUT with ./ before.

I did get the fastboot error message “Couldn’t parse partition size ‘0x’.” Apart from that, it seems to work.
EDIT: No, it didn’t work at all, I’m still on Google. See below.

That’s an issue, for more info look here

To solve this, you have to type this:
./fastboot getvar current-slot remember the result, (a or b)
Depending on the result you got, type:
./fastboot flash boot_a boot.img
./fastboot flash boot_b boot.img

Rest of the commands are the same.


Thank you.
So I return again to shutting it down and then onward from

5: Pressing Power + Volume - as stated in the instructions here.

, right?

Yes go into fastboot mode and redo the steps.

Thank you!
So the installation instructions after getting into fastboot are
./fastboot flashing unlock ./fastboot getvar current-slot ./fastboot -w ./fastboot flash system system.img ./fastboot flash boot_b (or a) `boot.img
./fastboot flash vendor vendor.img
./fastboot flash dtbo dtbo.img
./fastboot flash product product.img
./fastboot flash vbmeta vbmeta.img

./fastboot flashing lock`

Thank you so very much for this! :purple_heart: :man_dancing:t4:

1 Like

Yes that should do it.