Fairphone 3+ random stop and mms not sending


i experiment some problems with my new fairephone under e os 0.19.

First and the most anoying is that he randomly stop for no reason, i saw some topic about that but nothing recent, is there a way to prevent that ? by reinstalling ? (i stop using my phone as alarm clock… dont trust it)

Second one since 0.19 i cant send mms (this problem appear recently, i have send some before in 0.18), same question here, is there a way to solve that ?


Did you already try to turn off the phone (no reboot, real shutdown), wait a few seconds and turn it on again?

First step would be a factory reset either via recovery mode or via Settings. This would delete all your data as well as Apps you installed and their data.

If this doesn’t help, reinstalling the OS would be the next step (as an Android factory reset doesn’t touch the installed OS).

To avoid popular causes for erratic phone behaviour make sure a micro SD card (if you use one) is kept as external/portable storage instead of incorporating it into Internal Storage, and make sure your SIM card has the right native form factor for the phone and isn’t cut to size with cutting tools to make it smaller and doesn’t need to be in an adapter frame to make it bigger.

Please check whether your APN settings are still correct for your provider in Settings - Network and internet - Mobile network - Advanced - Access point names.
Providers have the correct APN settings on their website or your provider’s support can give them to you or even send a configuring SMS to you.


Concerning the MMS issue, it has never been sold on my side. I own a Fairphone 3+ for almost 1year now, there had been 2 or 3 updates since, I followed topics to solve this issue: it never worked.

What you propose for APN settings did not work…

If anyone has other advices, I take them but it seems to me it will never been sold.

A quick check to identify if this is a Carrier issue go to
Settings > Network and internet > Mobile network > Advanced > Access point names > scroll to your selected carrier > Look at the entry for MMSC; here there must be shown a URL which will carry your MMS as here:

I did check again my service provider (red by sfr) settings : their and mines are the same (for MMSC it is http://mms1)

I dont really understand how those settings, after several checks, do not work. Neither why they should be checked since they are by default setup right.

I dont really care about MMS, but it is frustrating to not understand the issue…

Thanks for your advice, reset solve the random crash problem.

Concerning the mms not sent, this is not solved, the apn info are good and i also tried to recreate one from start with my provider apn info, no change.

The reason that I suggested checking was only to rule it out. Carriers change methods, and it can happen … some carriers might put their customers on a non-MMS plan. This knowledge only informs you that it is not that carrier issue!

Finally the crash is not solved by just a reset, got some crash this week, so a reinstalled all from easy installer this weekend and… this happen again just now.

If someone got an hint on this… What i suspected the most is :
this is bound to touchscreen or overheat because it happen mostly when the phone is in my poket
this is bound to the poor quality of network because i work and live in such place
this is an hardware problem

Is there any way to see what cause the crash ? log file or something ?

Red mms problem is solved, i use a custom config and remove some options from the mms type :
MMSC http://mms1
Proxy MMS
Port MMS 8080
Type d’APN mms,default

Regarding a log, within Support topics you will find this Create a log @/e/.

If it is a fault with flexing of the screen in your pocket, I do think I have seen in the past the necessity to refix the screen internally. The display module is held with screws and clips and is said to be prone to loosening! Replace the display of your Fairphone 3 | How to | Fairphone - YouTube

Fairphone are proud of their construction techniques that allow for user repairs. You might start here: