Fairphone 3 with E/OS does not show up in windows 10

I wanted to copy some music to my fairphone 3.
My fairphone does not show up in windows 10 when I connect it through USB cable.
Laptop and fairphone are both updated.
I am using quality cable.
I did choose file transfer on the fairphone.
Phone and pc make connection sound but still fairphone does not show up in windows “My computer”
Copying by bluetooth connection is possible but very slow.

Suggestion are very welcome.

Thank you for your help and have a good day.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Unroll the top bar of the screen,
You wil see a very thin notification
“Android system — device in charge only”
Click on it to modify to “MTP files transfert”

Thank you very much Piero. Yes I did find the notfication and it gives me a couple of options, like file transfer, midi, ptp, usb tethering. I choose filetransfer but it still is not visible. Any other idea?

You can open the device settings, and search for gesture advanced reboot menu, and enable it.

Reboot to TWRP recovery mode, your pc must see the device storage…
When music is copied on the phone, reboot the phone to system

Thank you Piero. I have to find out what that looks like in a Dutch language :slight_smile:
How do I reboot to TWRP recovery mode? I never had an android let alone one with E/OS.
Do I have to do this every time I wanna copy music?

And don’t expect the device to appear as ordinary USB drive. This does never happen. Under Windows it appears as “FP3” in the Explorer, and there you can access both the internal device memory as well as the SD card of the device. But you never get a drive letter. Under Linux it’s much more complicated.

1 Like

Thank you Irrlicht. Yes that is what I expected. But it is not visible in explorer although I can hear the device connecting so windows does recognize it. It is really strange.

I changed to english on the fairphone, but I am sorry, I can’t find “gesture advanced reboot menu”. Is that name correct?

In english it is power menu

But FP3 don’t embed persistant TWRP as others devices

You sure of that ?
for every other device i know, it is plug and play !
when windows have also difficulties with the galaxy s9

Maybe windows needs specifics drivers as often.

Forget that boot menu.

After you plugged in the cable between the PC and the device go into the Settings on your FP3. Under “Connected Devices” (mine speaks German: “Verbundene Geräte”) you see a new USB section. There you must switch to file transfer, everytime you plug in the cable. After you did this you can open the Explorer an there you see a new “FP3” entry on the left side.

You can make this setting permanent (and that’s really a good idea) using developer settings. I did this once and then I forgot how to achieve this.


The display of the phone’s file structure on the computer is done via MTP. On Windows MTP needs working drivers … or in rare occurences (= Windows N version) an additional download (= Media Feature Pack).

1 Like

Hi Irrlicht,
What you describe is exactly what I did. The notification does show up on the fairphone. I do pick file transfer. Windows sounds, so it is recognize and connected and yet still not visible in explorer. That is what make it so strange.
Thank you for the tip, I will search how to make this permanent.

Hi AnotherElk
Thank you very much. I have uninstalled all driver I could find. I’ll let know if it will work.

Yes it worked! “a happy camper” here :grin:
Uninstalling the ADB drivers seems to have done the trick.
Thank you very much Piero, Irrlicht, AnotherElk


What Windows version is it concretely which makes that problem? I never installed anything on the PC.

It seems the problem here were defunct or conflicting drivers. Can happen.
Usually you don’t need to install anything.

But there are editions of Windows where you have to install something extra if you want to use MTP. This isn’t bound to a specific Windows version, this is going on for a while already, because on Windows you get MTP together with Microsoft Media Player, and some antitrust ruling forces Microsoft to offer a Windows edition without Media Player.



1 Like

I think it is because I tried to install E/OS by myself. I did not get it to work. The phone wasn’t found in fastboot mode. So I installed a couple of drivers to get it working withiout any succes. So I brought the phone to a technical guy who got the job done for me. I forgot to uninstall the drivers afterwards and was not aware of the "show hidden option"in device drivers. Once I did that and uninstalled the drivers the phone was recognized by windows without installing any additional drivers.

I had the same problem again FP3 not showing up in explorer. Found another solution this time.
I noticed there was an Acer installed. I choose to update the driver > picked search on my computer > choose from a list > picked Acer > Installed MTP USB device. This solved the problem.
Have a good weekend!