Fairphone 3+ with /e/ pre installed: localization not accurate


i have just received my Fairphone 3+ with /e/ pre installed. I bought it for my professional needs.

So i try to configure it and when it comes to the Maps application, i have found that my position is at nearly 8 kilometers of my real position… 8 kilometers not meters.

I am already a user of Magic Earth on my previous old phone where the localization worked fine.

So i was wondering if there is any manipulations to fix this major issue ?
Could it be a material issue ?

Thank you for your help.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

How long did you wait before you checked location.

IIRC the location is first determined by coarse unifiednlp until the more precise GPS location is found (which can take a couple of minutes).

Thank you for your help :slight_smile:

Actually, i test Magic Earth since yesterday evening (20h00) when i received the phone.
It takes a few seconds to display the position into Magic Earth.
But it always points to the same position … at nearly 8km of my real position.

So I have tried to disable and then enable the localization.
I have also tried to reboot the phone.
I have closed the app et relaunch it.
I have tried to disable the localization et launch the app to make it claiming to enable the localization.
But it has displayed the same position.

As mentionned, i have also tried with the GPS localization with Firefox and OSM (a Magick Earth-like app installed from Fdroid), and i get the very same position.

This morning, i have tried again and get the same position.

And now i have just checked and the position seems to be ok (only few meters away).

Maybe you have done some magic ^^ ?

Well, i will check for couple of days to see if it is still ok.

Thank you for your help and magic ^^

Best regards

Unfortunately, the position seems to be unstable.
The position jumps from my real position (few meters away) to the position 8km away. And then it jumps from the position 8km away to my real position.
It jumps again and again after few minutes from one position to the other.

I don’t understand :confused:



i have send a message to the customers service.

I hope my GPS can be fixed or replaced.

Best regards


I experience the same issue once in a while on my FP3.
The location is not 8 km’s off but about 2 km’s. Sometime to the East, sometimes to the West. Never to the South. Because I only experience this at home I rather think it has something to do with a W-Fi/Cell/GPS conflict
In the beginning, before I installed a compass the Maps location was about 35 km’s off, always to the same town, East of my home location…

2 questions:
Does the issue occur with a number of satellites visible to the system?
Is the off location which gets displayed a location where you once were, or is it random?

I’ve seen on several Android phones that when a location can’t be fixed, sometimes an older fix (not necessarily the last fix the system got, why ever that may be) might get displayed, until there’s a new fix.

Indoors would not be a good testing environment for location, I think.

You might be right.
I did not had a GPSTest app installed yet. Yesterday night I installed one and I could notice the device was connected to only 1 satellite. The moment it found a 2nd and a 3rd satellite the accuracy was OK again.
At the moment the device is not connected to any satellite and the accuracy is about 2km off to the West.

True, but it’s happening outside (when I’m in the garden) also.
Not sure this might be a reason, but we do have a crappy cell connection here…


thank you for your purchase and sorry for the issue you are facing.

I have never touched Android 10 (I will try to update my phone soon) but on previous version, you can choose a location mode (by clicking on the arrow in the location toggle in the control/notification center). Try “Device only” instead of “High accuracy” or “Battery saving” in order to use only GPS signal and not Wi-Fi/cell tower.

1 Like

Oh, I’m still on Android Pie (/e/OS 0.12-2020102981459)
Been playing with the settings you mentioned, but it doesn’t change anything to be honest.

I reckon @AnotherElk might be right: as long as there is no GPS satellite connected to my device the location shown in Maps (Magic Earth) won’t be accurate and it will probably use a cached location linked to a cell tower.


this week-end, i have realized that my 4G connection is not working at all. I can only connect to Internet with my WIFI connection. The phone has no connection when the WIFI is desactivate.
Whereas the GPS and 4G connection of my old phone work perfectly: so this is not a network issue.

I am really disappointed. I expected a lot about this combination of Fairphone & /e/OS.
I really thought that buying a Fairphone with the pre installation of /e/OS would prevent me from any issues.
The funny thing is that some people have been able to install EOS with an Internet connection and GPS that work.

So i will send back the phone and get refund.

It seems that it too early to buy a Fairphone with /e/OS pre-installed.

I hope it will be in the future.

Best regards


Perhaps you need to get a new SIM card.

1 Like

Thank you Lidwien for your help.

I would be surprised if i had to change my SIM card.
Actually this is the third phone i use this SIM card.
And there was no issue for the previous phones.

I really think this is too early to use /e/OS with the Fairphone 3+.
This phone has just been released and in a way, it is normal to have instabilities at the beginning.

I really hope this will be improved very soon because i consider /e/OS as an essential project.

This might be so, but @Lidwien could still be right.
SIM cards can degenerate over time and cause trouble, even trouble you wouldn’t logically link to them.
Of course I can’t tell if that’s the case here or not, but even if improbable, it’s not impossible. So you’re exactly right in that sense … you would be surprised.

Hi @samradji!

Thank you for the report. I raised an issue about the bug you are facing: https://gitlab.e.foundation/e/backlog/-/issues/2104

That said, I ran all tests on FP3+ with a SIM card and LTE… it worked perfectly. Maybe a SIM card or hardware issue?


1 Like

Thank you Romain for your help.

I also think it is a hardware issue.

That is why i will send back the phone and get refund.

Best regards